Need help updating to from 6.1 to 7.1

I am running Skyaware 6.1 and I am unable to update to 7.1. Have tried using the update restart command but it does not update. Using a Rapsberry pi. All other updates happened very easily but for some reason I can not get this update.

What error messages do you get?
Are you using
sudo apt upgrade followed by
sudo apt update?

Are you using the Piaware SD Card image or the package installed on top of Raspberry OS? If OS package which OS version?

1 Like

I use those commands the other way around, sudo apt update then sudo apt upgrade.
Works every time…


What iare the outputs of following commands?

apt-cache policy piaware

apt-cache policy dump1090-fa

True… I have written a short script for my devices, so i am mixing it up if writing down manually.

However the results from his device might be interesting

1 Like

Thank you for the help. I now have updated to 7.1

7.2 is out now :slightly_smiling_face:

Yes. Just saw that! Do you recommend me updating now or waiting to see if there are any bugs with 7.2?

The command (sudo apt upgrade) or (sudo apt full-upgrade) or (sudo apt dist-upgrade) not only upgrades piaware, dump1090-fa and dump978-fa, BUT upgrades lot of other things as well. I therefore use following selective commands which upgrade only specific package mentioned in the command (and its dependencies if required), and nothing else:

sudo apt update   

sudo apt install --reinstall piaware   

sudo apt install --reinstall dump1090-fa   

sudo apt install --reinstall dump978-fa   



And by doing so you don’t get security updates for Raspbian.


To exclusively install security updates (and nothing else)

sudo apt install unattended-upgrades   

sudo unattended-upgrade -d --dry-run
sudo unattended-upgrade -d # Idem --debug

## If you want to run it quietly instead:
sudo unattended-upgrade


  • Show all upgradeable packages
apt-get -s dist-upgrade | grep "^Inst"
  • Install security updates only
apt-get -s dist-upgrade | grep "^Inst" | 
    grep -i securi | awk -F " " {'print $2'} | 
    xargs apt-get install


pi@raspberrypi:~ $ unattended-upgrade --help
Usage: unattended-upgrade [options]

  -h, --help            show this help message and exit
  -d, --debug           print debug messages
  --apt-debug           make apt/libapt print verbose debug messages
  -v, --verbose         print info messages
  --dry-run             Simulation, download but do not install
  --download-only       Only download, do not even try to install.
                        Upgrade in minimal steps (and allow interrupting with
                        SIGTERM) (default)
                        Upgrade all packages together instead of in smaller


I prefer to upgrade mine manually. The version that I run has an update notifier that lives in the system tray of the GUI (Fluxbox with a tint2 panel) that turns green when there are updates, then I can easily review them and decide if I want to install them or wait, or perhaps pin a particular package at the current version and never upgrade it. I like to be in control of my OS and not let things happen in the background that might break something (like with Windows updates.)

Apparently I am running SkyAware 6.0. Is that the (latest) version that I should be using? I have run the update restart command but the SkyAware version doesn’t change…

Latest version is 7.2

Which type of device are you using? If you’re on a Raspberry, do you have SSH access?
Then a sudo apt update followed by sudo apt upgrade should help

I have a Raspberry and yes SSH access. I used the commands you suggested.
Thank you looks like got updated. This is what the version is showing now… 7.2~bpo10+1

This indicates your are running version 7.2 on the Raspberry PI Buster OS instead of the current version Bullseye.
You might want to consider an update to Bullseye in order to keep current on the operating system :wink:

Alright can you please describe how I should go about that please

Appreciate any help

the quickest way in your case ( since you use the sd card image) is to burn the current sd card image found here PiAware - build your own ADS-B ground station for integration with FlightAware - FlightAware to a new SD card ( keep the current one as a back-up), slip that into your Pi and then set the feeder id in the image to reflect your current feeder id that can be found on your ads-b stat page.

The new SD image is already created with Bullseye.

Steps below are copied from @abcd567 so thanks to him for the explanation for setting the feeder ID

Go to My-ADSB stats page and copy the feeder-id (Unique Identifier), as shown in red rectangle in screenshot below.


Issue following command to set your feeder-id.
(Replace xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx by Unique Identifer you have copied from My-ADSB stats page.

sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx   

sudo systemctl restart piaware  

sudo systemctl restart dump1090-fa   

Now check map again. Reload browser Ctrl+F5. Now the rings will be centered at your location :slight_smile:

After 5 minutes , check stats page My-ADSB. All 3 buttons should be green now.

1 Like

I have a 32 GB SD card. While attempting to flash the image to it the card throws an error during verification and states a fail.

The image may have gotten corrupted during the download. Download it over again and try again. If it still happens your extra SD card may be bad.