FlightAware Discussions

Piaware wont update ;/

sudo apt list --upgradable
Auflistung… Fertig
dhcpcd5/unbekannt 1:8.1.2-1+rpt1+fa4 armhf [aktualisierbar von: 6.10.1-1]
dump1090-fa/unbekannt 4.0 armhf [aktualisierbar von: 4.0~bpo9+1]
piaware/unbekannt 4.0 armhf [aktualisierbar von: 4.0~bpo9+1]

$ sudo apt upgrade
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
Paketaktualisierung (Upgrade) wird berechnet… Fertig
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

;(
any ideas?

Update to what? You are already on the latest.

(Also, I think you have broken your installation by installing a mix of buster and stretch packages)

ah ok

what can i do?

i wont a fresh install because of different other services running at my pi

Looks like you need to fix your apt package repository first.

Also check your repository sources found in /etc/apt/sources.list and the corresponding folder.

Here somebody reported a similar problem, maybe a starting point for troubleshooting:

sudo apt list --upgradable -a
Auflistung… Fertig
dhcpcd5/unbekannt 1:8.1.2-1+rpt1+fa4 armhf [aktualisierbar von: 6.10.1-1]
dhcpcd5/oldstable,now 6.10.1-1 armhf [Installiert,aktualisierbar auf: 1:8.1.2-1 +rpt1+fa4]
dhcpcd5/oldstable 6.7.1-1+rpi5 armhf

dump1090-fa/unbekannt 4.0 armhf [aktualisierbar von: 4.0~bpo9+1]
dump1090-fa/unbekannt,now 4.0~bpo9+1 armhf [Installiert,aktualisierbar auf: 4.0 ]
dump1090-fa/unbekannt 4.0~bpo8+1 armhf

piaware/unbekannt 4.0 armhf [aktualisierbar von: 4.0~bpo9+1]
piaware/unbekannt,now 4.0~bpo9+1 armhf [Installiert,aktualisierbar auf: 4.0]
piaware/unbekannt 4.0~bpo8+1 armhf

/etc/apt/sources.list

deb Index of /raspbian stretch main contrib non-free rpi
#Uncomment line below then ‘apt-get update’ to enable ‘apt-get source’
#deb-src Index of /raspbian/ stretch main contrib non-free rpi
deb http://repo.feed.flightradar24.com flightradar24 raspberrypi-stable