Unable to upgrade


#1

Today I tried to upgrade Piaware by sending command from the ads-b site, but it failed as shown here below:

[2018-10-04 15:01 CEST] *** running command ‘/usr/lib/piaware/helpers/run-apt-get update’ and logging output
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:1 http://mirrordirector.raspbian.org jessie InRelease [14.9 kB]
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit http://archive.raspberrypi.org jessie InRelease
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit http://flightaware.com jessie InRelease
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit http://repo.feed.flightradar24.com flightradar24 InRelease
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit http://archive.raspberrypi.org jessie/ui armhf Packages
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:2 http://mirrordirector.raspbian.org jessie/main armhf Packages [9,537 kB]
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://archive.raspberrypi.org jessie/main Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://archive.raspberrypi.org jessie/ui Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://archive.raspberrypi.org jessie/ui Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit https://apt.rb24.com rpi-stable InRelease
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit http://flightaware.com jessie/piaware armhf Packages
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit http://flightaware.com stretch/piaware armhf Packages
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable armhf Packages
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:3 https://apt.rb24.com rpi-stable/main armhf Packages
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://repo.feed.flightradar24.com flightradar24/raspberrypi-stable Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://flightaware.com jessie/piaware Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:5 https://apt.rb24.com rpi-stable/main Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Hit https://apt.rb24.com rpi-stable/main armhf Packages
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://flightaware.com jessie/piaware Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:6 https://apt.rb24.com rpi-stable/main Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://flightaware.com stretch/piaware Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:7 https://apt.rb24.com rpi-stable/main Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://flightaware.com stretch/piaware Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:9 https://apt.rb24.com rpi-stable/main Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:10 https://apt.rb24.com rpi-stable/main Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:11 https://apt.rb24.com rpi-stable/main Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign https://apt.rb24.com rpi-stable/main Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:13 https://apt.rb24.com rpi-stable/main Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign https://apt.rb24.com rpi-stable/main Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:14 http://mirrordirector.raspbian.org jessie/contrib armhf Packages [43.3 kB]
[2018-10-04 15:01 CEST] run-apt-get(28487): Get:16 http://mirrordirector.raspbian.org jessie/rpi armhf Packages [1,356 B]
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://mirrordirector.raspbian.org jessie/contrib Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://mirrordirector.raspbian.org jessie/non-free Translation-en
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en_GB
[2018-10-04 15:01 CEST] run-apt-get(28487): Ign http://mirrordirector.raspbian.org jessie/rpi Translation-en
[2018-10-04 15:03 CEST] run-apt-get(28487): Reading package lists…
[2018-10-04 15:03 CEST] run-apt-get(28487): W: You may want to run apt-get update to correct these problems
[2018-10-04 15:03 CEST] *** running command ‘/usr/lib/piaware/helpers/run-apt-get upgrade-package piaware’ and logging output
[2018-10-04 15:04 CEST] run-apt-get(28609): Reading package lists…
[2018-10-04 15:04 CEST] run-apt-get(28609): Building dependency tree…
[2018-10-04 15:04 CEST] run-apt-get(28609): Reading state information…
[2018-10-04 15:04 CEST] run-apt-get(28609): Some packages could not be installed. This may mean that you have
[2018-10-04 15:04 CEST] run-apt-get(28609): requested an impossible situation or if you are using the unstable
[2018-10-04 15:04 CEST] run-apt-get(28609): or been moved out of Incoming.
[2018-10-04 15:04 CEST] run-apt-get(28609): The following information may help to resolve the situation:
[2018-10-04 15:04 CEST] run-apt-get(28609): The following packages have unmet dependencies:
[2018-10-04 15:04 CEST] run-apt-get(28609): piaware : Depends: libreadline7 (>= 7.0~beta) but it is not installable
[2018-10-04 15:04 CEST] run-apt-get(28609): Depends: libssl1.1 (>= 1.1.0) but it is not installable
[2018-10-04 15:04 CEST] child process 28609 exited with status EXIT 1
[2018-10-04 15:04 CEST] aborting upgrade…
[2018-10-04 15:04 CEST] update request complete


#2

You have a mixed jessie/stretch setup; this is not going to work.
Please ensure that your sources.list refers to the piaware repository that matches your distribution version.


#3

Easy solution:
Use Etcher or Win32DiskImager.
Download Piaware SD card image 3.6.3, and write to microSD card.


#4

@abcd567, the re-image guy!:smile:

If at first you don’t succeed, re-imaging is the way to go.


#5

:smile: Reimaging is the easiest way out is what I discovered the hard way.


#6

Thanks - will do when I get the time to it.