FlightAware Discussions

Piaware Update Help

Hi there,

I am currently running piaware 3.7.1 and tried upgrading to 3.8.1 via ssh.

Ran update lines and I am getting this message. Not sure what is happening. Can you guys be able to help?

try
sudo apt update
sudo apt full-upgrade

The command you are trying to run is to install the application from scratch.

You can also look here for other ways to upgrade
https://discussions.flightaware.com/t/announcing-piaware-3-8-1/

Did not work. I even tried running upgrade from FA website

Please provide the commands and error messages. “Did not work” is not helpful.

[2020-05-01 11:20 PDT] Started faup1090 (pid 741) to connect to dump1090-fa
[2020-05-01 11:20 PDT] performing manual update, action: piaware
[2020-05-01 11:20 PDT] mlat-client(732): Input connected to localhost:30005
[2020-05-01 11:20 PDT] manual update (user-initiated via their flightaware control page) requested by adept server
[2020-05-01 11:20 PDT] mlat-client(732): Listening for Beast-format results connection on port 30105
[2020-05-01 11:20 PDT] *** running command ‘/usr/lib/piaware/helpers/run-apt-get update’ and logging output
[2020-05-01 11:20 PDT] mlat-client(732): Using UDP transport to 70.42.6.156 port 10972
[2020-05-01 11:20 PDT] mlat-client(732): Listening for Extended Basestation-format results connection on port 30106
[2020-05-01 11:20 PDT] mlat-client(732): Input format changed to BEAST, 12MHz clock
[2020-05-01 11:20 PDT] mlat-client(732): fa-mlat-client 0.2.10 starting up
[2020-05-01 11:20 PDT] run-apt-get(756): Hit:1 http://flightaware.com/adsb/piaware/files/packages buster InRelease
[2020-05-01 11:20 PDT] run-apt-get(756): Hit:2 http://flightaware.com/adsb/piaware/files/packages stretch InRelease
[2020-05-01 11:20 PDT] run-apt-get(756): Hit:3 http://repo.feed.flightradar24.com flightradar24 InRelease
[2020-05-01 11:20 PDT] mlat-client(732): Beast-format results connection with 127.0.0.1:30104: connection established
[2020-05-01 11:20 PDT] run-apt-get(756): Hit:5 http://raspbian.raspberrypi.org/raspbian stretch InRelease
[2020-05-01 11:20 PDT] run-apt-get(756): Get:4 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
[2020-05-01 11:20 PDT] run-apt-get(756): Hit:6 https://apt.rb24.com rpi-stable InRelease
[2020-05-01 11:20 PDT] run-apt-get(756): Fetched 25.4 kB in 2s (9,264 B/s)
[2020-05-01 11:20 PDT] *** running command ‘/usr/lib/piaware/helpers/run-apt-get upgrade-package piaware’ and logging output
[2020-05-01 11:20 PDT] run-apt-get(756): Reading package lists…
[2020-05-01 11:20 PDT] run-apt-get(1359): Reading package lists…
[2020-05-01 11:20 PDT] run-apt-get(1359): Building dependency tree…
[2020-05-01 11:20 PDT] run-apt-get(1359): Reading state information…
[2020-05-01 11:20 PDT] run-apt-get(1359): Reading package lists…
[2020-05-01 11:20 PDT] run-apt-get(1359): 0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
[2020-05-01 11:20 PDT] run-apt-get(1359): Reading state information…
[2020-05-01 11:20 PDT] run-apt-get(1359): Building dependency tree…
[2020-05-01 11:20 PDT] run-apt-get(1359): distribution that some required packages have not yet been created
[2020-05-01 11:20 PDT] run-apt-get(1359): requested an impossible situation or if you are using the unstable
[2020-05-01 11:20 PDT] run-apt-get(1359): The following information may help to resolve the situation:
[2020-05-01 11:20 PDT] run-apt-get(1359): Some packages could not be installed. This may mean that you have
[2020-05-01 11:20 PDT] run-apt-get(1359): The following packages have unmet dependencies:
[2020-05-01 11:20 PDT] aborting upgrade…
[2020-05-01 11:20 PDT] run-apt-get(1359): or been moved out of Incoming.
[2020-05-01 11:20 PDT] child process 1359 exited with status EXIT 1
[2020-05-01 11:20 PDT] run-apt-get(1359): Depends: libboost-system1.67.0 but it is not installable
[2020-05-01 11:20 PDT] run-apt-get(1359): Depends: libboost-program-options1.67.0 but it is not installable
[2020-05-01 11:20 PDT] run-apt-get(1359): E: Unable to correct problems, you have held broken packages.
[2020-05-01 11:20 PDT] run-apt-get(1359): Depends: libboost-regex1.67.0 (>= 1.67.0-10) but it is not installable
[2020-05-01 11:20 PDT] update request complete
[2020-05-01 11:20 PDT] run-apt-get(1359): Depends: libc6 (>= 2.28) but 2.24-11+deb9u4 is to be installed
[2020-05-01 11:20 PDT] run-apt-get(1359): piaware : Depends: libboost-filesystem1.67.0 but it is not installable
[2020-05-01 11:20 PDT] run-apt-get(1359): Depends: libssl1.1 (>= 1.1.1) but 1.1.0l-1~deb9u1 is to be installed
[2020-05-01 11:20 PDT] 58 msgs recv’d from dump1090-fa; 58 msgs sent to FlightAware
[2020-05-01 11:25 PDT] 801 msgs recv’d from dump1090-fa (743 in last 5m); 801 msgs sent to FlightAware

@richiegonzalez

The easiest, cleanest, and long-term solution is to re-image your microSD card with latest Piaware SD card image.

Even if you succeed to upgrade piaware and dump1090-fa in current install, your distro will remain outdated Raspbian Stretch.

The current Piaware SD card image (v 3.8.1) has:

  • Latest OS (Raspbian Buster Lite)
  • Latest versions of piaware & dump1090-fa (3.8.1)

Direct dwnload link (current image 3.8.1)
http://piaware.flightcdn.com/piaware-sd-card-3.8.1.img.zip

Download page:
https://flightaware.com/adsb/piaware/build

 

ALTERNATIVELY if you want to use Raspbian image, download it from https://www.raspberrypi.org/downloads/raspbian/, reimage your microSD card with it and install piaware and dump1090-fa latest versions from this page:

https://flightaware.com/adsb/piaware/install

1 Like

You are attempting to install the Buster version on a Stretch install. This will not work. You probably installed the wrong repository package.

This will require me to set up all my feeds to different sources again, correct?

Yes, you have to reinstall all other feeders, but it is not a big deal.

Before you write fresh image, copy-paste feeder keys in Notepad on your desktop/laptop and save notepad:

Plane finder key:
The sharecode is in the file /etc/pfclient-config.json
Scroll right to see it in full. Your Planefinder sharecode is the last item in this long line.

{"tcp_address":"127.0.0.1","tcp_port":"30005","select_timeout":"10","data_upload_interval":"10","connection_type":"1","aircraft_timeout":"30","data_format":"1","latitude":"xx.xxxx","longitude":"yy.yyyy","sharecode":"zzzzzzzzzzzz"}    

Flightradar24 key:
The fr24key is in the file /etc/fr24feed.ini

Radarbox24 key:
The key is in the file /etc/rbfeeder.ini

Installation commands

Planefinder

wget http://client.planefinder.net/pfclient_4.1.1_armhf.deb  

sudo dpkg -i pfclient_4.1.1_armhf.deb  

Flightradar24

sudo bash -c "$(wget -O - https://repo-feed.flightradar24.com/install_fr24_rpi.sh)"  

Caution:, During configuration of fr24feed, never choose “Receiver DVBT”. Choose Receiver: ModeS Beast(TCP), host/port: 127.0.0.1:30005

Radarbox24:

sudo bash -c "$(wget -O - http://apt.rb24.com/inst_rbfeeder.sh)"  

sudo rbfeeder --setkey xxxxxxxxxx --no-start   
## Replace xxxxx by your actual key
## Press Ctrl+C to break log output.

sudo systemctl restart rbfeeder  

 

2 Likes

This is great!!

I’ll be busy tomorrow with this. If I come across any problems, I’ll post back up here.

Thank you.

Better use a spare microSD card for fresh install, and preserve the existing one till on the spare one you have successfully completed fresh install.

If you dont have a spare microSD card, first make a backup image of existing microSD card on your Windows computer using Win32DiskImager. After making backup, you can write fresh image to your existing microSD card.

2 Likes

I got most of the feeds working, except the Planefinder feed. It shows that the feeder is connected, but not producing any data.

Any ideas what the issue may be?

(1) In your browser, go to following page, and wait for 10 ~ 20 seconds

http://ip-of-pi:30054

Do you see this? If no, then settings are wrong.

(2) In your web browser go to:

http://ip-of-pi:30053/setup.html

Compare settings with those in screenshot below.
(A very common mistake is missing zero in port number, i.e. port number entered is 3005, instead of 30005.)

To make any corrections, click button “Enable Configuration Mode”. You will be asked to enter sharecode to get access to configuration editing.

Missing a zero in port number. I’m an idiot.

Thank you for all your help. I was able to get everything running using a spare SD card.

Cheers!!

2 Likes

Glad to know you successfully made fresh install by writing latest image.

Now you have latest OS, and also have latest versions of dump1090-fa, piaware, pfclient, fr24feed, & rb24feeder. Everything is latest. This is what I meant by the long-term solution.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.