FlightAware Discussions

Updating to 3.7.1

Am I understanding this right, in order to update to 3.7.1, I need to download the new image and set it back up on my Rpi3?

I am currently on 3.6.3. Not the FA image. I did run sudo apt-get update and then upgrade and it shows 3.7.1 in my Skyview, but my Feeder Type still shows: PiAware (Debian Package Add-on) 3.6.3 on my stats page.

Package upgrade should be fine. I just sent a restart command to your feeder in case it didn’t restart on the new version for some reason when you upgraded, see if that helps.

(edit: nope. you definitely still have piaware 3.6.3 + dump1080-fa 3.7.1 installed, which is an unusual combination. try the upgrade again and check for anything unusual in what it’s trying to install)

Yeah, I am getting this message when trying to update:

W: Target Translations (piaware/i18n/Translation-en) is configured multiple time s in /etc/apt/sources.list.d/piaware-stretch.list:1 and /etc/apt/sources.list.d/ piaware.list:1

Is this a Jessie install that was later updated to Stretch?

I believe updated to stretch if I remember correctly.

cat /etc/os-release

Will tell you the Raspbian version.

If you are running stretch, removing the non-stretch file should solve your problem:

sudo rm  /etc/apt/sources.list.d/piaware.list

Yep, jessie-to-stretch upgrades are going to be a bit hairy; we don’t test against that (just jessie, and stretch, individually; not an upgraded jessie) so it’s possible that something broke.

If wiedehopf’s suggestions don’t help, I’d plan to reimage with a Stretch image (can be standard Raspbian, that’s fine)

My update went just fine, ordered from the feeder web page, but I was on a clean Stretch.

Updated my 2 ‘stations’ from the “My ADS-B” page, no issues.

Hey there -

I have a 3.6.3. build, jessie (not upgraded to stretch), but I am unique (sort of) – I have added on a few things to my Pi…

  • Feeder for adsb-exchange
  • Feeder for Radarbox 24
  • Feeder for Planefinder
  • Feeder for Flightradar 24
  • PiVPN

And, I have moved everything (except /boot) to a SSD. (Initially set up on MicroSD then moved to USB SSD, modified boot command line and /etc/fstab)

Any gotchas I need to worry about specifically with the upgrade?

I did try just a simple sudo apt-get update, sudo apt-get upgrade, reboot, and it did not come back up. I’m remote (of course), so the unit is just wedged for now until I can get back and tend to it.

The answer is quite simple: Don’t modify a piaware sd-card like that, the possible results are untested.
Why not start with a stretch lite image when you get back to the box.
If it’s not booting anymore i would do just that, really no way to say what the problem is.
(especially without even having access to the sd-card and even the i would just redo the image)

I can’t argue with your logic. Although, to be thorough, I will fix whatever’s making it not boot and go in and rescue some configs from the other feeders first… but yes, your point is quite valid. I will end up on a fresh stretch instance, and everything will be in a supported configuration.

Many variables, but I’d be most suspicious of this since it’s network related; maybe it’s “up”, just off the network.

Etcher& Win32DiskImager are my best friends. :slight_smile: I always use them whenever there is an upgrade.

1 Like

My thread got hijacked :slight_smile:
Anyway, I tried what wiedehopf suggested. Here are my results. Tried updating but nothing updates. So maybe I just have to re-image all this…

pi@ADS-B:~ cat /etc/os-release PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)" NAME="Raspbian GNU/Linux" VERSION_ID="9" VERSION="9 (stretch)" ID=raspbian ID_LIKE=debian HOME_URL="http://www.raspbian.org/" SUPPORT_URL="http://www.raspbian.org/RaspbianForums" BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs" pi@ADS-B:~ sudo rm /etc/apt/sources.list.d/piaware.list
pi@ADS-B:~ sudo rm /etc/apt/sources.list.d/piaware.list rm: cannot remove '/etc/apt/sources.list.d/piaware.list': No such file or directory pi@ADS-B:~ sudo apt-get update
Hit:1 http://flightaware.com/adsb/piaware/files/packages stretch InRelease
Get:2 http://archive.raspberrypi.org/debian stretch InRelease [25.4 kB]
Hit:3 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Fetched 25.4 kB in 1s (16.3 kB/s)
Reading package lists… Done
pi@ADS-B:~ sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages were automatically installed and are no longer required: lxkeymap python-cairo python-gobject python-gobject-2 python-gtk2 python-xklavier realpath Use 'sudo apt autoremove' to remove them. The following packages have been kept back: chromium-browser gstreamer1.0-omx nodejs nodered piaware python-gpiozero python3-gpiozero python3-thonny raspberrypi-ui-mods rpi-chromium-mods sense-emu-tools wolfram-engine 0 upgraded, 0 newly installed, 0 to remove and 12 not upgraded. pi@ADS-B:~

Well I don’t know why, but I sent the update and restart command from the FA myadsb page and it updated it to 3.7.1

Weird but it is working now…

1 Like

Ah, yeah, there’s the problem.

Sounds like you got it working now but next time you may need to do a dist-upgrade not an upgrade (it changes the conflict resolution rules a bit). Alternatively you could try sudo apt-get install piaware to specifically upgrade just piaware.

I will note this. Thank you.

So… thinking about the upgrade…so I have 3.6.3 and don’t have any intention at this point of putting up a UAT antenna.

  • Is there any other real gain to upgrading?
  • last time I did this, I did a new build with the image. Do I have jessie or stretch and what the heck is the difference?
  • How do I determine what I have and why is it important?
cat /etc/os-release

It’s the version of the operating system. (Like Windows XP, Windows 7, Windows 10)

If the update doesn’t work it’s important to know, otherwise it’s not that important.
With the 3.6.3 image you should be on the newest version (stretch) anyway.

If you have the functionality enabled you can update via the cogwheel on your stats page.
I’m not sure why they are asking people to upgrade but i’m sure FA has their reasons.
(Maybe it talks to the servers a little different)

But i’m not aware of any plans to disable feeding with old versions so you don’t need to update i think.

1 Like