FlightAware Discussions

Map Marker location on PiAware

Is there a way to add a map marker at my location on PiAware?

A map marker is automatically placed at the location specified when the feeder site is configured.


I think he may want to put his own markers on the map. I have seen posts about this in the past.
Have you tried a search for this?

Jon, you are correct. I want to mark where my house is. I will do a search.

That black dot on the map is exactly where my house (and station) is located. It is the lat/lon that is in your configuration file.

Also interested how this works, as I’ve had the same LAT/LONG and only changed Pi (set the feeder ID to the original Pi and all the config files reflect the same Lat/Long location), now it appears it’s moved since changing Pi’s over.

I’ve even tried moving the marker slightly on the Flightaware page then saved/updated it, after rebooting etc same as OP I’m keen to see if there’s a way to force the marker to move.



This will not work on the piaware image where the location should already be exact:

sudo sed -i -e 's/--json-location-accuracy 1/--json-location-accuracy 2/' /etc/default/dump1090-fa
sudo systemctl restart dump1090-fa

The dump1090-fa/SkyView map gets it’s marker position from piaware data feeder, which retrives it from FlightAware servers.

$ cat /usr/share/dump1090-fa/start-dump1090-fa

... ... ...
... ... ... 

if [ -f /var/cache/piaware/location.env ]
. /var/cache/piaware/location.env

if [ "x$ENABLED" != "xyes" ]
echo "dump1090-fa not enabled in /etc/default/dump1090-fa" >&2
exit 64

if [ -n "$PIAWARE_LAT" -a -n "$PIAWARE_LON" ]
... ... ...
... ... ...

Useful to know, though it’s interesting considering the SkyView map is pulling the LAT/LON from FlightAware’s populated location on the ‘My Adsb’ page for that feeder.

Using the LAT/LON from the “Location: (54.xxxxx, -1.5xxxx)” copied into Google maps for example is correct and shows the coordinates are right, it just appears on the SkyView page it’s about 80 miles out?

I guess I could try modify the variables and include the location manually in the file, but that defeats the point if it ever moves!

Then you’ve manually changed /etc/default/dump1090-fa

Or are you saying you use the piaware sd-card image?


(1) If you have Raspbian image with piaware package install, and want the location manually entered at your Pi (and not pulled from you FA stats page), edit file /etc/default/dump1090-fa, and add --lat 54.xxxx --lon 1.5xxxx in the line starting with RECEIVER_OPTIONS

(2) If you have Piaware SD card image, and want the location manually entered at your Pi (and not pulled from you FA stats page), try this

Open file start-dump1090-fa

$ sudo nano /usr/share/dump1090-fa/start-dump1090-fa

Scroll down and comment out following line.


Now add a new line below it, so it becomes like this:


POSITION="--lat 54.xxxx --lon -1.5xxxxx"

Thanks. I will try that.