FlightAware Discussions

How to see my live data olutside my local network

I guess no-ip is a dynamic DNS-service?
Since the webserver is working local, you don’t need to install any thing… You do how ever need to forward the local webserver port in your router/firewall to the Pi’s IP.

I connected to no-ip on the end router. My public ip address will appear there. But raspberry has a different address. This is my network:
netscheme

You didn’t answer the question if you forwarded the port.
That is required.

There are security implication in doing port forwards.

I did not know. So I have to put port forwarding and set what up there?

Forward port 80 or 8080 to the RPi.
It’s been discussed in the thread.
Google should also help you understand what happens.

1 Like

On the configuration page of the router, I put the following into forwarding:


Google didn’t help me.

So why are you exposing 22 (SSH) instead of 8080 or 80?

That’s what I don’t understand. Where do I have something to enter. Service port and internal port.

It says it on the right.
External port, internal port.

So one port is the port that the internet will see.
The other port is where the router will forward connections to when a connection on the external port comes in.

You can use an arbitrary external port - just remember what you used because that’s how you’ll access it when out of network. So internal ports should be 80 and 8080…or just 80 and then you’ll access your system using http://IP:EXT_PORT

I set the ports according to the advice and still doesn’t show me anything on my website.

Do you access your local website with ip-of-the-pi:8080? If yes, then you need to set the internal port to 8080.

Then from outside your network (ie. 4G/5G or at a friends network), type your-external-ip:8080, and the site should show up.

I’m giving up already. I just can’t set this up. Thank you for your effort, but I’m untalented.

Well, you’re almost there… Edit internal port to 8080 and make sure the IP you plotted in are your Pi’s. Thats all.

Just did a test setup; http://92.246.20.74:8080/

So I don’t know anymore

8080 for both settings …

Then visit blabla.myip:8080

Nonsense will appear under that address. Do I have to arrange something with the provider?

Are you under CG-NAT? If so, that could cause problems. It’s an Apacheserver you got hold of…
Just to make it clear, does the correct webinterface appear when you type 192.168.1.103:8080?

If I put the address 192.168.1.103:8080 on the local network, then I see my aircraft map.
Sorry I do not know what it is CG-NAT.

Okay. It was just to make sure, or else we could be fighting the problem for years. Are you 100% sure about your external IP? Please check with https://whatismyipaddress.com/