FlightAware Discussions

How to remove location dot from Skyview

Hello,

I sometimes share my Skyview map with others and I’ve recently registered a domain for it. I don’t want the location dot on the map.

Is there any way to remove it?

In the options toggle the site position and range rings button.

In the options of the map itself it can be enabled by everybody individually.
But he can change the accuracy of the tracker in the configuration of the site itself on FA

grafik

Maybe there’s an option for removing it completely in the config file itself.

On the piaware sd-card image you can’t remove it.
Even if you modify the javascript not to display it, it will still be in the receiver.json which is accessible from the web.

If it weren’t a piaware image you could at least make it round the latitude and longitude a bit.
(or modify the systemd unit file and disable location for the receiver.json entirely)

That doesn’t affect the SkyView map as far as i know.

I am using the SD image but I am willing to set up with a clean Buster install.

Changing the location accuracy in My ADS-B didn’t change anything on the map.

wiedehopf, I am a huge fan of tar1090 and am actually using that as my web front end, if that helps. I love your work btw. It’s an honour.

So i just checked and it should work fine on the sd-card image as well.
Disable automatic updates, any update will overwrite these changes, you’ll need to re-do them after updates.

sudo nano /usr/share/dump1090-fa/start-dump1090-fa

Line 26:

 24 if [ -n "$PIAWARE_LAT" -a -n "$PIAWARE_LON" ]
 25 then
 26     POSITION="--lat $PIAWARE_LAT --lon $PIAWARE_LON"
 27 fi

Just change to a closeby location, this way the position decoding can still use it as a reference.
This won’t mess with MLAT, the position for that is set somewhere else.
Wouldn’t go off more than 2 degrees in latitude and longtitude:

POSITION="--lat 43.2 --lon 5.2"

Ctrl-X to exit, Y and enter to save.

Be aware that with some effort your position can still be approximated.

Now if you want to disable the black dot (which is now in the wrong location):

sudo nano /usr/local/share/tar1090/html/config.js

Uncomment this line (remove the double / at the start of the line)

//SiteShow    = false;           // true to show a center marker

Ctrl-X to exit, Y and enter to save.

1 Like

Damn, you’re right. I mixed it up with the location on FA map.

holy cow it worked.
My Tar1090

2 Likes

So this isn’t your location i hope:

  1. lat: 43.089
  2. lon: -79.054

Do you have the key bindings disabled on purpose or is it due to the way you have exposed the website?

That is not my location.

I don’t recall messing with key bindings.

Thanks so much for your help.