Hello and start stop help.


#1

I’m new to piaware so hello everyone and good to be here.

I’ve run in to a small problem that I cannot find an answer to but I’m sure is covered so apologies for not being able to find it.

Current deficiencies to be corrected.

I’m using a Raspi B+ so I’ll probably upgrade to Raspi 2.
Upgraded power supply on order, currently using 1500mA.
Newsky TV28T v2 USB DVB-T & RTL-SDR Receiver from Nooelec plugged directly to the pi. My current usb powered hub (2 amp) will not work. New raspi suitable hub on order.
16Gb class 4 SD card. I’ve ordered a class 10 as no one locally stocks higher than class 4!!

Despite the deficiencies, once piaware is up and running it is stable. The problem comes when I have to shut down, which will probably be once a day. On start up everything seems OK but no messages are received. If I re-write the SD card then all is fine. I appreciate that this is probably a card problem, but perhaps I’m shutting down incorrectly and corrupting the image. Currently I use putty to shutdown the pi but I wondered if I should stop anything first?

Any advice greatly appreciated.

Phill


#2

at least as I know rpi don’t have a proper shutdown button because it’s built in on hardware a safe mode to shutdown no matter the way to do that, in passt I had the similar problem, I was solved when I re-write a raspbian image in sdcard on another PC… really I don’t know why but on the first PC are running Windows 8.1 on the second PC that solved the problem it was running Windows 7 if you can just try…
cheers


#3

To safety shutdown the system:


sudo shutdown -h now

The hardware has no hard/soft power off. After the system is safety halted, you have to disconnect the power to shutdown the hardware.


#4

Thanks for the help guys.

All went well yesterday, started up with no problems. Logged for 12 hours.

This morning everything seems to have started OK but I’m just not getting any messages. Certainly not a lack of traffic.

I re-wrote the card again but still the same. On the last start up I received an anomaly message 94% CPU. I’ll start fault finding.

Phill


#5

Hmmm,

All works fine as long as I allow piaware to start up completely with the dongle disconnected. Plugged in after about 90 seconds and all worked as described.

It didn’t help that I’m currently using the supplied small aeria,l on a paint tin, on the window sill. Found the signal wire was just touching the contact inside the base. Soldered it up and started getting some signals as far out as the 120 to 180 zone.

Phill


#6

This sounds like a power supply issue. Have you noticed the red led blinking during the boots with the dongle connected?


#7

Hi,

No problem with the red LED it’s on solid.

I started up this morning, left the pi on it’s own for a couple of minutes and then plugged in the dongle. After that everything was fine. I think you are right about the power supply though.

I have a 2amp USB hub that works fine on windows, but not at all on the pi. I have ordered one that is recommended for Raspberry Pi so hopefully that will prove the theory.

Many thanks

Phill