FlightAware Discussions

(noob) stopping piaware on Pi3

Hi there*.

I’m just getting started with ads-b tracking. Installed piaware on latest Raspberry Pi OS using flightaware.com/adsb/piaware/install walktrough .Everything is up and running fine.

Now i’m trying to stop Piaware in order to play with GQRX and other sdr software (that worked before installing piaware).

Although I stopped piaware and dump1090 via systemctl or service and running piaware-status states that everything is stopped, I still cannot use other software. It appears the rtl_sdr is in use. ```

usb_claim_interface error -6
Failed to open rtlsdr device #0.

Am I missing something ? Is there another service that grabs the sdr related to piaware that needs to be stopped ?

Thanks

*sry if this is in the wrong category

Try (again)

sudo systemctl stop dump1090-fa

And make sure the service actually stopped in top/htop

1 Like

Also:

(a) it will restart on reboot;
(b) piaware, if still running, will try to restart it after a while.

You can prevent both of these by systemctl mask dump1090-fa which will disable it entirely until you run a corresponding unmask command.

1 Like

Thanks for your replies.

I had to do sudo systemctl stop dump978-fa after stopping dump1090-fa.

After that, all other sdr apps are up and running as before.

I’ll get a second rtl_sdr and leave ads-b capture online 24/7.

That was your first time making mention of dump978-fa being in the picture… You’ll need a seperate radio if you want to run both services concurrently.

I didn’t knew about it. Haven’t paid enough attention during install and I installed both services… And now I know :slight_smile:

We’ve all been there and those who haven’t probably will be at some point. There are lots of nuances. Glad you got it sorted. :+1: