Feeder shown as inactive


#1

I have set up the FA feed through a Raspberry Pi and on the first day of the installation it reported positions and aircrafts but ever since, for the last 4 days the feeder is shown as inactive though Pi is powered up with a working internet connection. What could be missing?


#2

(1) Go to your Desktop/Laptop connected on same Local network as the RPi, and type following in your Browser’s address bar:
ip-of-pi/dump1090
ip-of-pi/dump1090-fa
(ip-of-pi will be something like 192.168.0.21)

What do you see?

(2) SSH to Pi and give following 2 commands one by one and post in this forum, last 3 lines of the output of each command.

sudo systemctl status piaware
sudo systemctl status dump1090-fa

(3) Reboot the Pi and check your Flightaware Stats page after 10 minutes.


#3

Thank you for the reply. I am travelling and will try out the above steps as soon as I am back and post the result. Thanks again!


#4

First do step #3 (i.e. reboot the Pi, then check FA Stats page after 10 minutes).
If it does not remedy the situation, then carry out steps 1 and 2.


#5

Tried the step #3 n number of times to no avail. Have to try the other option. But then, the feed to FR24 is working fine from the same pi.


#6

if feed to FR24 is working OK, then
(1) Internet is working OK.
(2) Either dump1090-fa is working, OR if it is not, then the integral dump1090-mr of FR24 feeder has taken over the DVB-T and receiving+decoding the signals. What settings you have done in FR24 feed?

If it is using its integral dump1090, the setting will be
Receiver: DVB-T

If it is using dump1090-fa, the setting would be
Receiver :AVR (TCP)
OR
Receiver: Beast (TCP)

You can check this by typing in your browser:
ip-of-pi:8754/settings.html


#7

I am using the DVB-T.


#8

THAT IS THE CAUSE OF FAILURE OF FLIGHTAWARE FEED!

Change settings to following:
Receiver: Beast (TCP)
Host/IP: 127.0.0.1:30005

After change, do not forget to click the “Save” Button and then “Restart” button, both located at bottom-right of FR24 Settings page.


#9

Awesome! Will try this and keep you posted. Thank you for the quick responses. Appreciate it.


#10

After change, do not forget to:
(1) click the “Save” Button and then “Restart” button, both located at bottom-right of FR24 Settings page.

(2) Reboot the RPi so that dump1090-fa grabs DVB-T and starts functioning normally. The FR24 feeder will now get its Beast feed on port 30005 from dump1090-fa.

After reboot, check status
(1) ip-of-pi:8754
(2) ip-of-pi/dump1090-fa/
(3) Your Flaghtaware Stats Page


#11

Ok one slight confusion. I am using dump1090, not dump1090-fa. So anything changes?


#12

No changes in configuration/settings of FR24 feeder. Do exactly as I have told in my last post.

Can you tell more about dump1090, I mean is it Malcom Robson or Mutability fork?

There is difference in map viewing address. If it is Malcom Robson fork try following
ip-of-pi:8080
ip-of-pi/dump1090/

If it is mutability fork, try following
ip-of-pi/dump1090/


#13

This is my fr24 feed settings after making the changes suggested by you. All good?

Regarding dump1090, i used to view map through ‘ip-of-pi:8080’, but after making changes it doesn’t work, neither does ip-of-pi/dump1090/


#14

COM/DEV/PATH usr/lib/fr24/dump1090

You are using built-in dump1090 of FR24 feeder !!!
Revert to
Receiver: DVB-T
Host/IP: leave blank

Also Change NO to YES for Decoded data (30003):

SAVE settings, and reboot.
Check status


#16

I have replicated your situation by formatting microSD card and writing Raspbian img, and installing FR24 feeder and Piaware feeder only. Made FR24 feeder setting DVB-T, using integral dump1090 of FR24 feeder.

Since the integral dump1090 of FR24 feeder is not capable to receive MLAT feedback at port 30104. Piaware got stuck trying to establish feedback connection, and data feeding to Flightaware stopped.

pi@raspberrypi:~ $ sudo systemctl status piaware -l
...............
...............

Nov 11 03:27:25 raspberrypi piaware[10292]: mlat-client(10320): Beast-format results connection with ::1:30104: [Errno 111] Connection refused
Nov 11 03:27:46 raspberrypi piaware[10292]: 191 msgs recv'd from dump1090 (34 in last 5m); 191 msgs sent to FlightAware
Nov 11 03:27:56 raspberrypi piaware[10292]: mlat-client(10320): Beast-format results connection with 127.0.0.1:30104: [Errno 111] Connection refused
Nov 11 03:28:26 raspberrypi piaware[10292]: mlat-client(10320): Beast-format results connection with ::1:30104: [Errno 111] Connection refused
Nov 11 03:28:56 raspberrypi piaware[10292]: mlat-client(10320): Beast-format results connection with 127.0.0.1:30104: [Errno 111] Connection refused

.
I DISABLED Mlat Feed-back (sudo piaware-config mlat-results no) and restarted Piaware (sudo systemctl restart piaware). The Piaware started feeding data to Flightaware normally.

pi@raspberrypi:~ $ sudo piaware-config mlat-results no
Set mlat-results to no in /etc/piaware.conf:10
pi@raspberrypi:~ $ sudo systemctl restart piaware
pi@raspberrypi:~ $ sudo systemctl status piaware -l
...............
...............
Nov 11 03:42:17 raspberrypi piaware[26541]: piaware received a message from dump1090!
Nov 11 03:42:17 raspberrypi piaware[26541]: mlat-client(26569): Input connected to localhost:30005
Nov 11 03:42:17 raspberrypi piaware[26541]: mlat-client(26569): Input format changed to BEAST, 12MHz clock
Nov 11 03:42:37 raspberrypi piaware[26541]: piaware has successfully sent several msgs to FlightAware!
Nov 11 03:42:47 raspberrypi piaware[26541]: 9 msgs recv'd from dump1090; 9 msgs sent to FlightAware
Nov 11 03:47:47 raspberrypi piaware[26541]: 67 msgs recv'd from dump1090 (58 in last 5m); 67 msgs sent to FlightAware

.

ACTION TO BE TAKEN BY YOU:

(1) Revert FR24 settings to DVB-T as originally it was.
(2) SSH and give following commands to your PI
(3) After 30 minutes go to your Flightaware stats page and check status.

#Disable mlat feed back
sudo piaware-config mlat-results no

#Restart Piaware
sudo systemctl restart piaware

#After 10 minutes, check status
sudo systemctl status piaware -l

.


#17

I doubt this is what happened; if port 30104 is not accepting connections, mlat-client just won’t feed results there. It does not affect the data feed to FA either way.


#18

Thanks for pointing out.

To test validity of my hypothesis, at 10:50 local time I have done following:

  1. Replaced regular microSD card (Piaware sd card img) and plugged in test microSD card which has:
    - Raspbian Stretch
    - FR24 Feeder
    - Piaware 3.5.3 (add-in) data feeder
    (No dupm1090 installed separately. Using integral dump1090 of FR24 feeder)

  2. Enabled mlat results
    sudo piaware-config mlat-results yes
    sudo systemctl restart piaware

Will leave this card running for next 4 hours and check stats at:
https://flightaware.com/adsb/stats/user/abcd567#stats-5252


#19

@arjun0412
In order to replicate your install, I need to know precisely what software you have installed
Is it Pi24 image from Flightradar24 or Raspbian from Raspberry Pi Org?


#20

@obj
Checked and found that you are right and my hypothesis is wrong.

Piaware do send messages to Flightaware, but in status/log, “connection refused to 30104” entries are so numerous compared to “messages sent to flightaware” entries, that these are not easily visible, and made me think messages are not being sent to flightaware.

Thanks again for guidance.

[2017-11-11 11:57 EST] mlat-client(7974): Beast-format results connection with 127.0.0.1:30104: [Errno 111] Connection refused
[2017-11-11 11:57 EST] 8392 msgs recv'd from dump1090 (540 in last 5m); 8392 msgs sent to FlightAware
[2017-11-11 11:57 EST] mlat-client(7974): Beast-format results connection with ::1:30104: [Errno 111] Connection refused
................
................
[2017-11-11 12:07 EST] mlat-client(7974): Beast-format results connection with 127.0.0.1:30104: [Errno 111] Connection refused
[2017-11-11 12:07 EST] 9471 msgs recv'd from dump1090 (579 in last 5m); 9471 msgs sent to FlightAware
[2017-11-11 12:08 EST] mlat-client(7974): Beast-format results connection with 127.0.0.1:30104: [Errno 111] Connection refused

.

.


#21

@arjun0412
Hi Arjun!
You did succeed to feed data to Flightaware today (Sat 11 Nov) from 5am to 8pm IST.
Source: https://flightaware.com/adsb/stats/user/arjun0412#stats-67957

What settings you used during this period?

.
Screenshot-2017-11-11 arjun narayanan ADS-B Feeder Statistics ✈ FlightAware