FlightAware Discussions

FlightAware Feeds; Other Feeds Go Down

Newbie here. I’m feeding FA, FR24, ADSB, RB, and PlaneFinder. Started with a Piaware 3.7.1 and dump1090-fa. Followed the instructions provided by some of you very smart people and fed all the other sites. No problems and in general everything works great for days at a time. Couple of times this week, I get a notice from FR24 (I have it set to 1 hour) that my feed is down. Checked each of the sites and only FR24 and RB are not feeding…the others appear to be feeding just fine. I can putty into the Pi. My long winded question is what do I need to check to possible narrow down what the issue could be? My solution at present is to just shrug and reboot the Pi. But since it happened more than once over a relatively short time frame, there must be something to review to address this. Thanks for any suggestions!

There have been cloudflare problems affecting at least FR24.
So that might be part of it.

You can change the systemd service for FR24 to actually produce useful logging information instead of just spamming:

Backup and edit /etc/systemd/system/fr24feed.service:

sudo mv /etc/systemd/system/fr24feed.service /root/fr24feed.service
sudo nano /etc/systemd/system/fr24feed.service

Paste the following:

[Unit]
Description=Flightradar24 Decoder & Feeder
After=network-online.target

[Service]
Type=simple
Restart=always
ExecStartPre=-/usr/lib/fr24/install_dump1090.sh
ExecStartPre=-/usr/lib/fr24/create_missing_directories.sh
ExecStart=/bin/bash -c "/usr/bin/fr24feed | sed -u -e 's/[0-9,-]* [0-9,:]* | //' | grep -F -e imeout -e rror -e info -e main -e onnect -e reader --line-buffered"
User=fr24
Group=fr24
PermissionsStartOnly=true
StandardOutput=syslog
SyslogIdentifier=fr24feed

[Install]
WantedBy=multi-user.target

Ctrl-O and enter to save, Ctrl-X to exit.

After saving the file:

sudo systemctl daemon-reload
sudo systemctl restart fr24feed
sudo journalctl -u fr24feed -f

Now if you get the mail from FR24 you can do this:

sudo journalctl -u fr24feed

That will give you at least some information what the feed client was doing at the time.

But my guess: nothing to do with you.

Perfect. I made the changes to that file. Appreciate your time and response!

Can you see the logs?

sudo journalctl -u fr24feed

The startup from restarting the service should already be in the log.

I can see the logs, appears to be working just fine. (I do need to learn to not right click by accident…that was interesting, pasted all that code in the terminal screen. I think I confused it a good bit). But all good now! Again, thank you very much for your replies!

As you are new to feeding, i’ll just without shame recommend my graphs:

https://github.com/wiedehopf/graphs1090#graphs1090

Graphs for dump1090 -- my version with install script

@markrrichardson

  1. I strongly recommend wiedehopf’s graphs. These are very good tool.

  2. No need to worry about FR24 and RB24, the problem is on their server side. The problem is temporary and intermittent. I also occasionally get FR24 & RB24 “feed not working”, but simply ignore it.

About 6 weeks so far. I have installed the graphs, they are incredible, highly recommended. Both of you have been a tremendous help to me just watching your posts. Learning a lot.

I currently feed 2 stations from 1 RPi:

  • PCB antenna, dongle 00000101, dump1090-mutability, piaware (station 5252), fr24feed (station cyyz9), planefinder, rb24, opensky-network, adsbexchange

  • Whip antenna, dongle 00000102, dump1090-mutability2, piaware2 (station 76000), fr24feed2 (cyyz30)

Tried to have two instances of rb24feeder, but its output ports are hard coded, cannot be changed for 2nd instance, causing conflict, and failure of any one of the 2 instances (EXTRPI000008 & EXTRPI000036)

I just started feeding RB24, I’d never seen it before. Pretty.

Have you activated MLAT on RB24?

I see my stations live on these web pages:

https://www.radarbox24.com/stations/EXTRPI000008

https://www.radarbox24.com/stations/EXTRPI000035

You can also see your station live on above url if you change station number 000008 by your station number (total six digits, like 00xxxx)

Yes, I was surprised it was an additional install. Mine is on that list you’ve posted, ends in 1140.

Seems that it gives a very precise location of the antenna… if you’re into that sort of thing

For me it’s 3 km off.
(Edit, it’s less than 1 km off, read the map wrong)
At least when i’m not logged in.

Those 3 km is the same rounding FA does on the stats page.

But on the FA page you can increase that rounding quite a bit by setting it to more.
(Or is it the larger setting by default? not sure)

Anyway i don’t like their overpriced Xrange hardware solution they sell.
(while i wouldn’t buy it, i’m annoyed that it doesn’t easily give beast data or AVR data))
Also reading about their Windows software on their forum gave me enough chills to remove their feeder.

Depends on how precise lat/lon you entered.
You can choose “Aproximate Location”

(1) Login to your RB24 account and go to map page.

(2) Click “Edit” as shown in screenshot below.

image

(3) Enter Lat / Lon, and choose “Aproximate Location”

(4) Click “Preview” button to see on map how far away from your actual location

image

Alternatively you can edit lat/Lon in file /etc/rbfeeder.ini

sudo nano /etc/rbfeeder.ini


[client]
network_mode=true
log_file=/var/log/rbfeeder.log
key=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
sn=EXTRPI00xxxx

lat=xx.xxxx
lon=yy.yyyy
alt=zzz

sat_used=0

sat_visible=0

[network]
mode=beast
external_port=30005
external_host=127.0.0.1

[mlat]
autostart_mlat=true

Yeah but that’s stupid in regards to MLAT.
But that’s still being worked on, still it should give you better options.

To enable mlat, one has to install mlat-client which they have uploaded to their repository by following command

sudo apt update
sudo apt install mlat-client

However on Buster their pre-built package failed to install. This was till last week. I dont know if now they have upgraded or not their package of mlat-client.
I had to built it from source code.

https://www.airnavsystems.com/forum/index.php?topic=101771.msg407051#msg407051

No i mean the “approximate location” setting should be display only.
It doesn’t make sense to do MLAT with an “approximate location”

Check your RB24 web map

  1. You are logged-in
  2. You are logged-out and after clearing cache Ctrl+F5)

Do both show the same receiver location when map is zoomed?
In my case same location, logged-in or logged-out

I always had Exact Location set for MLAT.
Despite that the location in an Incognito browser window was half a kilometer off.
So that’s good.

Still those checkboxes should read “round to 1km for display” and “round to 10km for display” while asking people to provide an exact location for mlat.