FAA Reg not showing up on Google


#1

Anyone know what happened? Previously you could type in the N# and the first option was a direct link(y) to the FAA reg.
:cry:


#2

Just worked for me. It’s 7:30 EST.


#3

Works for me… 9:43 AM EDT
(we’re on daylight time)


#4

Still not working for me.


#5

What reg isn’t working for you? Are you including the leading N?


#6

Works for me as well and as Mark noted the leading “N” is obligatory.


#7

Yes, I’m using the N and using aircraft I know. Flightaware usually comes up as the first option now. It used to say something like “Are you looking for aircraft registration for N1KE?” … with a link to FAA site. Then all the flightaware, airliner links and Chinese symbols would follow.


#8

I googled the above tail number and like others, it worked for me

FAA Registry
N-Number Inquiry Results
N1KE is Assigned

Since the general consensus is that it works, you may want to try another browser and see if you get the same results. If so, then you know it’s your browser, and you may need to clear the cache and cookie files.

Allen


#9

Wazzu 90 = LOOSER!

I had deleted all that stuff yesterday. Just did it again and we’re back to normal.

Thanks for all your help.

:smiley: