Dump1090-mutability on Stretch


#1

Hi,

I downloaded Raspbian Stretch Lite and installed mutability 1.15 dev version on it but it wasn’t able to decode any data. Then downloaded v1.14 and the same, no data was decoded. I then downloaded dump1090-fa and it works fine.

After that I dowloaded Joe’s image and it works, so I am wondering if there is anything that needs to be done to the decoder to be able to used it with Stretch? This was tested on Pi 3b+, with the antenna installed on the roof so no problems of data reception.


#2

Did you install all the RTL-SDR libraries/packages? Just installing mutability by itself will not work.

Follow the instructions here:

https://forum.flightradar24.com/threads/10232-How-to-Install-dump1090-mutability_1-15-dev-on-RPi

Hopefully they are still correct/valid, since the last revision was in 2017.

Another excellent ‘How to’ from @abcd567 .


#3

As a matter of fact I followed the exact same tutorial by @abcd567 for installation. So yes those packages are installed.


#4

Ok…things could have changed, as it worked fine for me a few months ago.

I wonder if the change from Jessie to Stretch is part of the problem.


#5

I think it has to do with Stretch as well. Did the same on Jessie back in the day and had no problems.


#6

Yes, dump1090-mutability ver 1.15~dev on Stretch has a problem of missing rtl-sdr.rules and requires a workaround.

I have posted the workaround in post #75 of FR24 thread which you and @Dxista have mentioned above. Here is the link to that post:

https://forum.flightradar24.com/threads/10232-How-to-Install-dump1090-mutability_1-15-dev-on-RPi?p=96279&viewfull=1#post96279

I have also posted it in Flightaware forum here:
When is STRETCH coming to PiAware SD card image version - post#9


#7

#8

This is weird as I already have them present and even re-installed them but still no joy.


#9

I just reflashed the SD and installed mutability v1.14, rtl-sdr.rules installed as well, still nothing is happening. Does anyone know how @jprochazka did it for his image? Previously, I had done the exact same and installed v1.15~dev with rtl-sdr.rules but no decoding happening.


#10

can you post the output of sudo ls /etc/modprob.d ?

it must have a file named rtl-sdr-blacklist.conf that has these lines

blacklist dvb_usb_rtl28xxu
blacklist e4000
blacklist rtl2832

many times had to rename rtlsdr-blacklist.conf to rtl-sdr-blacklist.conf after installing Joe’s scripts, and problem was solved.


#11

Thanks.

I don’t have that file but had added no-rtl.conf but that didn’t help

Screen%20Shot


#12

@flightfinderr

(1) Did you give these two commands?
NOTE: The first line below is very long. Scroll right to see it upto its end. While copying it, you can easily miss copying its last hidden part.

sudo wget -O /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules" 

sudo reboot

.

(2) If above commands were given, then to check if file rtl-sdr.rules was downloaded successfully, give following command:

cat /etc/udev/rules.d/rtl-sdr.rules

.

Above command should generate following output:

#
# Copyright 2012-2013 Osmocom rtl-sdr project
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation, either version 3 of the License, or
# (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.#
# You should have received a copy of the GNU General Public License
# along with this program.  If not, see <http://www.gnu.org/licenses/>.
#

# original RTL2832U vid/pid (hama nano, for example)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="2832", MODE:="0666"

# RTL2832U OEM vid/pid, e.g. ezcap EzTV668 (E4000), Newsky TV28T (E4000/R820T) etc.
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="2838", MODE:="0666"

# DigitalNow Quad DVB-T PCI-E card (4x FC0012?)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0413", ATTRS{idProduct}=="6680", MODE:="0666"

# Leadtek WinFast DTV Dongle mini D (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0413", ATTRS{idProduct}=="6f0f", MODE:="0666"

# Genius TVGo DVB-T03 USB dongle (Ver. B)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0458", ATTRS{idProduct}=="707f", MODE:="0666"

# Terratec Cinergy T Stick Black (rev 1) (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00a9", MODE:="0666"

# Terratec NOXON rev 1 (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00b3", MODE:="0666"

# Terratec Deutschlandradio DAB Stick (FC0013)SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00b4", MODE:="0666"

# Terratec NOXON DAB Stick - Radio Energy (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00b5", MODE:="0666"

# Terratec Media Broadcast DAB Stick (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00b7", MODE:="0666"

# Terratec BR DAB Stick (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00b8", MODE:="0666"

# Terratec WDR DAB Stick (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00b9", MODE:="0666"

# Terratec MuellerVerlag DAB Stick (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00c0", MODE:="0666"

# Terratec Fraunhofer DAB Stick (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00c6", MODE:="0666"

# Terratec Cinergy T Stick RC (Rev.3) (E4000)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00d3", MODE:="0666"

# Terratec T Stick PLUS (E4000)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00d7", MODE:="0666"

# Terratec NOXON rev 2 (E4000)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0ccd", ATTRS{idProduct}=="00e0", MODE:="0666"

# PixelView PV-DT235U(RN) (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1554", ATTRS{idProduct}=="5020", MODE:="0666"

# Astrometa DVB-T/DVB-T2 (R828D)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="15f4", ATTRS{idProduct}=="0131", MODE:="0666"

# HanfTek DAB+FM+DVB-T
SUBSYSTEMS=="usb", ATTRS{idVendor}=="15f4", ATTRS{idProduct}=="0133", MODE:="0666"

# Compro Videomate U620F (E4000)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="185b", ATTRS{idProduct}=="0620", MODE:="0666"

# Compro Videomate U650F (E4000)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="185b", ATTRS{idProduct}=="0650", MODE:="0666"

# Compro Videomate U680F (E4000)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="185b", ATTRS{idProduct}=="0680", MODE:="0666"

# GIGABYTE GT-U7300 (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d393", MODE:="0666"

# DIKOM USB-DVBT HD
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d394", MODE:="0666"

# Peak 102569AGPK (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d395", MODE:="0666"

# KWorld KW-UB450-T USB DVB-T Pico TV (TUA9001)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d397", MODE:="0666"

# Zaapa ZT-MINDVBZP (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d398", MODE:="0666"

# SVEON STV20 DVB-T USB & FM (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d39d", MODE:="0666"

# Twintech UT-40 (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d3a4", MODE:="0666"

# ASUS U3100MINI_PLUS_V2 (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d3a8", MODE:="0666"

# SVEON STV27 DVB-T USB & FM (FC0013)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d3af", MODE:="0666"

# SVEON STV21 DVB-T USB & FM
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1b80", ATTRS{idProduct}=="d3b0", MODE:="0666"

# Dexatek DK DVB-T Dongle (Logilink VG0002A) (FC2580)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1d19", ATTRS{idProduct}=="1101", MODE:="0666"

# Dexatek DK DVB-T Dongle (MSI DigiVox mini II V3.0)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1d19", ATTRS{idProduct}=="1102", MODE:="0666"

# Dexatek DK 5217 DVB-T Dongle (FC2580)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1d19", ATTRS{idProduct}=="1103", MODE:="0666"

# MSI DigiVox Micro HD (FC2580)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1d19", ATTRS{idProduct}=="1104", MODE:="0666"

# Sweex DVB-T USB (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1f4d", ATTRS{idProduct}=="a803", MODE:="0666"

# GTek T803 (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1f4d", ATTRS{idProduct}=="b803", MODE:="0666"

# Lifeview LV5TDeluxe (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1f4d", ATTRS{idProduct}=="c803", MODE:="0666"

# MyGica TD312 (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1f4d", ATTRS{idProduct}=="d286", MODE:="0666"

# PROlectrix DV107669 (FC0012)
SUBSYSTEMS=="usb", ATTRS{idVendor}=="1f4d", ATTRS{idProduct}=="d803", MODE:="0666"

#13

Yes, I did and have /etc/udev/rules.d/rtl-sdr.rules file present and is exactly the same file that you have copied.


#14

Ok, to check how many copies/versions of rtl-sdr.rules you have, give following command and post output

ls /etc/udev/rules.d/

.

In my Pi, following is output of above command.

99-com.rules  rtl-sdr.rules

#15

I appreciate you taking the time @abcd567 to look into it. I have the same two files

screenshot


#16

May be dump1090-mutability did not install properly. Check it:

apt-cache policy dump1090-mutability

#17

I thought the same and therefore reflashed the image n installed v1.14 but no change. Its installed properly as you can see. All your suggestions have been applied here as well

dump1090-mutability:
Installed: 1.14
Candidate: 1.14
Version table:
*** 1.14 100
100 /var/lib/dpkg/status


#18

(1) Few days ago, I have installed dump1090-mutability ver 1.15~dev on Stretch / Pi Model 2, and it works fine. I dont have Pi 3 or Pi 3 B+ to test installation on it.

Seems your problem is Pi 3 B+ specific. You can verify this by installing dump1090-mutability ver1.15~dev by JProchazka’s scripts.

.

(2) What is the output of following command?

pi@raspberrypi:~ $ sudo systemctl status dump1090-mutability -l

.
My dump1090-mutability ver 1.15~dev gives following output:

● dump1090-mutability.service - LSB: dump1090 daemon (mutability variant)
   Loaded: loaded (/etc/init.d/dump1090-mutability; generated; vendor preset: enabled)
   Active: active (running) since Fri 2018-08-10 12:04:03 EDT; 3min 17s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 447 ExecStart=/etc/init.d/dump1090-mutability start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/dump1090-mutability.service
           └─545 /usr/bin/dump1090-mutability --net --ppm 0 --fix --lat 43.xxxx --lon -79.xxxx --max-range 300 --net-ri-port 30001 --net-ro-port 30002 --net 

Aug 10 12:04:02 raspberrypi systemd[1]: Starting LSB: dump1090 daemon (mutability variant)...
Aug 10 12:04:03 raspberrypi systemd[1]: Started LSB: dump1090 daemon (mutability variant).



#19

@flightfinderr

Test if your dongle is available for use by dump1090-mutability

#First install test tool package 
sudo apt-get update
sudo apt-get install rtl-sdr

#STOP dump1090-mutability before test 
sudo systemctl stop dump1090-mutability

#Now conduct test
rtl_test -t

.

If dongle is available, the above test should give following output:

Found 1 device(s):
  0:  Realtek, RTL2832U, SN: 00000000

Using device 0: Generic RTL2832U
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.

.

What output do you get from rtl_test -t command?

.
.


#20

You might have missed my initial post where I had mentioned that it works fine if I use dump1090-fa. If I start dump1090-fa, it starts working as expected but when I stop that and start, regardless of which version it is, it does decode. Unfortunately I can’t post the output as I am not home but I have already tested the dongle and using dump1090-fa confirms as well.