Dump-1090 Mutability


#1

I have installed Dump-1090 Mutability onto a new Pi following the instructions on here. The installation was fine but despite numerous reboots, trying different antenna and Prosticks, nothing is happening i.e. no data is feeding.

Any help or suggestions would be appreciated.

Thank you


#2

This problem normally occours If dump1090-mutability is installed on Raspbian Stretch.

If you have installed dump1090-mutability on Raspbian STRETCH, then please carryout workaround (1) as shown in this post:

https://discussions.flightaware.com/t/when-is-stretch-coming-to-piaware-sd-card-image-version/25990/9


#3

Thank you. I have tried workaround (1) but still no data is feeding.


#4

Please give following commands and post their outputs:
(1)

lsusb

.
.
(2)

sudo systemctl status dump1090-mutability -l

.
.
(3)

sudo apt-get update
sudo apt-get install rtl-sdr
sudo systemctl stop dump1090-mutability

rtl_test -t

#5

Hi

I have tried to copy the content here

Bus 001 Device 004: ID 0bda:2832 Realtek Semiconductor Corp. RTL2832U DVB-T
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

  1. sudo systemctl status dump1090-mutability -l
    ● dump1090-mutability.service - LSB: dump1090 daemon (mutability variant)
    Loaded: loaded (/etc/init.d/dump1090-mutability; generated; vendor preset: en
    Active: active (running) since Tue 2017-10-03 19:02:43 UTC; 5min ago
    Docs: man:systemd-sysv-generator(8)
    Process: 507 ExecStart=/etc/init.d/dump1090-mutability start (code=exited, sta
    CGroup: /system.slice/dump1090-mutability.service
    └─542 /usr/bin/dump1090-mutability --measure-noise --net --ppm 0 --fi

Oct 03 19:02:42 raspberrypi systemd[1]: Starting LSB: dump1090 daemon (mutabilit
Oct 03 19:02:43 raspberrypi systemd[1]: Started LSB: dump1090 daemon (mutability
lines 1-10/10 (END)
● dump1090-mutability.service - LSB: dump1090 daemon (mutability variant)
Loaded: loaded (/etc/init.d/dump1090-mutability; generated; vendor preset: enabled)
Active: active (running) since Tue 2017-10-03 19:02:43 UTC; 5min ago
Docs: man:systemd-sysv-generator(8)
Process: 507 ExecStart=/etc/init.d/dump1090-mutability start (code=exited, status=0/SUCCESS)
CGroup: /system.slice/dump1090-mutability.service
└─542 /usr/bin/dump1090-mutability --measure-noise --net --ppm 0 --fix --lat 53.571053 --lon -3.

Oct 03 19:02:42 raspberrypi systemd[1]: Starting LSB: dump1090 daemon (mutability variant)…
Oct 03 19:02:43 raspberrypi systemd[1]: Started LSB: dump1090 daemon (mutability variant).

  1. rtl_test -t
    Found 1 device(s):
    0: Realtek, RTL2832U, SN: 00001000

Using device 0: Generic RTL2832U
Detached kernel driver
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.
Reattached kernel driver


#6

You dongle (DVB-T or ProStck) and dump1090-mutability seem to work ok. Now check your data feeders, and post results.

First reboot your Pi. After reboot, wait 5 minutes to enable piaware data feeder to complete startup and handshake, then conduct following tests:

(1) Piaware

sudo systemctl status piaware -l

.

(2) Planefinder

sudo systemctl status pfclient -l

.

(3) Flightradar24

sudo systemctl status fr24feed -l

#7

For Piaware:

sudo systemctl status piaware -l
● piaware.service - FlightAware ADS-B uploader
Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset:
Active: active (running) since Tue 2017-10-03 19:26:10 UTC; 7min ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 533 (piaware)
CGroup: /system.slice/piaware.service
├─533 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusf
└─660 /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --n

Oct 03 19:26:16 raspberrypi piaware[533]: Starting faup1090: /usr/lib/piaware/he
Oct 03 19:26:16 raspberrypi piaware[533]: Started faup1090 (pid 660) to connect
Oct 03 19:26:16 raspberrypi piaware[533]: logged in to FlightAware as user Nigel
Oct 03 19:26:16 raspberrypi piaware[533]: my feeder ID is b65997fd-245c-4cf9-bd7
Oct 03 19:26:16 raspberrypi piaware[533]: site statistics URL: https://flightawa
Oct 03 19:26:16 raspberrypi piaware[533]: piaware received a message from dump10
Oct 03 19:26:17 raspberrypi piaware[533]: piaware has successfully sent several
Oct 03 19:32:53 raspberrypi piaware[533]: 99 msgs recv’d from dump1090-mutabi; 9
Oct 03 19:32:53 raspberrypi piaware[533]: timed out waiting for alive message fr
Oct 03 19:32:53 raspberrypi piaware[533]: reconnecting in 52 seconds…
lines 1-19/19 (END)
● piaware.service - FlightAware ADS-B uploader

For Planefinder:

pi@raspberrypi:~ $ sudo systemctl status pfclient -l
● pfclient.service - LSB: planefinder.net ads-b decoder
Loaded: loaded (/etc/init.d/pfclient; generated; vendor preset: enabled)
Active: active (running) since Tue 2017-10-03 19:26:10 UTC; 10min ago
Docs: man:systemd-sysv-generator(8)
Process: 535 ExecStart=/etc/init.d/pfclient start (code=exited, status=0/SUCCE
CGroup: /system.slice/pfclient.service
└─578 /usr/bin/pfclient -d -i /var/run/pfclient.pid -z /etc/pfclient-

Oct 03 19:26:10 raspberrypi systemd[1]: Starting LSB: planefinder.net ads-b deco
Oct 03 19:26:10 raspberrypi pfclient[535]: Starting pfclient: pfclient.
Oct 03 19:26:10 raspberrypi systemd[1]: Started LSB: planefinder.net ads-b decod

For FR24:

pi@raspberrypi:~ $ sudo systemctl status fr24feed -l
● fr24feed.service - LSB: Flightradar24 Decoder & Feeder
Loaded: loaded (/etc/init.d/fr24feed; generated; vendor preset: enabled)
Active: active (exited) since Tue 2017-10-03 19:26:10 UTC; 13min ago
Docs: man:systemd-sysv-generator(8)
Process: 532 ExecStart=/etc/init.d/fr24feed start (code=exited, status=0/SUCCE
CGroup: /system.slice/fr24feed.service

Oct 03 19:26:10 raspberrypi systemd[1]: Starting LSB: Flightradar24 Decoder & Fe
Oct 03 19:26:10 raspberrypi fr24feed[532]: Starting FR24 feeder: fr24feed.
Oct 03 19:26:10 raspberrypi systemd[1]: Started LSB: Flightradar24 Decoder & Fee

Many thanks


#8

(1) There was “timed out waiting for messages from dump1090…”. Can you please again run following and post only last few lines?

sudo systemctl status piaware -l

(2) check the feed status of Planefinder by typing in address bar of your browser
< IP of Pi >:30053
It will show a map with planes. On this map, on top there is a menu bar. On menubar click tab “Logs” to see the live log of feed to Planefinder.

(3) Check feed status of Flightradar24 by typing in your browser address bar
< IP of Pi >:8754
The display will show if the feed is active or not.


#9

For Piaware, the last few output lines are:

Oct 03 21:24:17 raspberrypi sudo[697]: pam_unix(sudo:session): session opened for user root by (uid=0)
Oct 03 21:24:17 raspberrypi sudo[697]: pam_unix(sudo:session): session closed for user root
Oct 03 21:24:18 raspberrypi piaware[526]: logged in to FlightAware as user NigelRichardson
Oct 03 21:24:18 raspberrypi piaware[526]: my feeder ID is b65997fd-245c-4cf9-bd71-32e75b44170e
Oct 03 21:24:18 raspberrypi piaware[526]: site statistics URL: https://flightaware.com/adsb/stats/user/NigelRichardson#stats-65946
~
~
~
~

For Planefinder I get the map but no aircraft

For Flightradar24 I get a message ‘Unable to Connect’

Thank you


#10

hmmmm… What do you see when you type following address in browser?

< IP of Pi >/dump1090/gmap.html


#11

That’s working. I get the dump1090 Map with aircraft and the aircraft table


#12

That means the dongle and dump1090-mutability both are working ok, but the data is somehow not reaching the feeders. Looks some misconfiguration of dump1090’s port numbers for data output.

Can you please give following command and post its output? It will show configuration of dump1090-mutability.

cat  /etc/default/dump1090-mutability

#13

Hi

This is what I get:

dump1090-mutability configuration file

This is a POSIX shell fragment.

You can edit this file directly, or use

“dpkg-reconfigure dump1090-mutability”

Set to “yes” to start dump1090 on boot.

START_DUMP1090=“yes”

User to run dump1090 as.

DUMP1090_USER=“dump1090”

Logfile to log to

LOGFILE="/var/log/dump1090-mutability.log"

Receiver options

RTLSDR device index or serial number to use

If set to “none”, dump1090 will be started in --net-only mode

DEVICE=""

RTLSDR gain in dB.

If set to “max” (the default) the maximum supported gain is used.

If set to “agc”, the tuner AGC is used to set the gain.

GAIN=“max”

RTLSDR frequency correction in PPM

PPM=“0”

Decoding options

If yes, fixes messages with correctable CRC errors.

FIX_CRC=“yes”

If set, supplies a reference location for local position decoding.

LAT=“53.571053"
LON=”-3.05942"

If set, provides the absolute maximum receiver range used to

filter bad position reports, and to determine when local position

decoding is safe to use. Specify this in nautical miles (NM).

MAX_RANGE=“300”

Networking options

Port to listen on for raw (AVR-format) input connections. 0 disables.

RAW_INPUT_PORT=“30001”

Port to listen on for raw (AVR-format) output connections. 0 disables.

RAW_OUTPUT_PORT=“30002”

Port to listen on for SBS-format output connections. 0 disables.

SBS_OUTPUT_PORT=“30003”

Port to listen on for Beast-format input connections. 0 disables.

BEAST_INPUT_PORT=“30004,30104”

Port to listen on for Beast-format output connections. 0 disables.

BEAST_OUTPUT_PORT=“30005”

TCP heartbeat interval in seconds. 0 disables.

NET_HEARTBEAT=“60”

Minimum output buffer size per write, in bytes.

NET_OUTPUT_SIZE=“500”

Maximum buffering time before writing, in seconds.

NET_OUTPUT_INTERVAL=“1”

TCP buffer size, in bytes

NET_BUFFER=“262144”

Bind ports on a particular address. If unset, binds to all interfaces.

This defaults to binding to localhost. If you need to allow remote

connections, change this.

NET_BIND_ADDRESS=“127.0.0.1”

Misc options

Interval (in seconds) between logging stats to the logfile. 0 disables.

STATS_INTERVAL=“3600”

Path to write json state to (for use with an external webserver). Blank disabl es.

JSON_DIR="/run/dump1090-mutability"

Interval between writing json state (in seconds). 0 disables.

JSON_INTERVAL=“1”

Accuracy of receiver location to write to json state, one of “exact” / “approx imate” / “none”

JSON_LOCATION_ACCURACY=“approximate”

Set to yes to log all decoded messages

This can get large fast!

LOG_DECODED_MESSAGES=“no”

Additional options that are passed to the Daemon.

EXTRA_ARGS=""


#14

(1)All port settings look good. Cant understand why data is not reaching the three data feeders :confused: . It is really surprizing.

(2) In this new forum, a comment-out # of scripts is treated as heading, making all comments very large and bold, making the post look ugly.

To get rid of this ugliness, please edit you post, and add a line at start before first line “dump1090-mutability configuration file”, and containing only this:
[,code,]
and another line at the end of post containing only this:
[,/code,]
(without commas which I had to put to make it visible to you)


#15

Okay, many thanks. I’ll continue trialling different things

Thank you for your patience and advice.


#16

Just last try. Edit file /etc/default/dump1090-mutability, and change the entry as follows

sudo nano /etc/default/dump1090-mutability

# The above command will open file for editing. 
#Scroll down to following entry

NET_BIND_ADDRESS=“127.0.0.1”

#remove 127.0.0.1, so the entry becomes:
NET_BIND_ADDRESS=“”

#Now save file (ctrl+o) and close editor (ctrl+x)
#Restart Pi
sudo reboot

After reboot, check in your browser
< ip of pi >:8754
< ip of pi >:30053


#17

It worked!!! Many thanks

One final question - how do I access the performance graphs?

Many thanks again for all you advice and help with this and also your patience

Nigel


#18

I assume that you have already installed Web Portal using JProchazka’s “ADSB Project Scripts”.
If not, you cant see performance graphs. Install these first.

If already installed,
Graphs: < ip of pi >/graphs.php
Admin: < ip of pi >/admin/
If you have not yet done web portal configuration step: < ip of pi >/install/


#19

Thanks

I did install but when I click on the ADS-B Receiver Project link at the bottom of the page I get the following message ‘Secure Connection Failed’


#20

Also just noticed that FR24 isn’t working. Using :8754, I get ‘Problem Loading Page’ message