Piaware 3.5.3


#1

New version updated on Sunday, but dump 1090 keeps aborting. I am on Stretch which was fine with 3.5.1.
Anyone else with similar issues?


#2

Note that I don’t (yet) test on Stretch. Does it work OK on Jessie?

(There were no code changes to the compiled part of dump1090 between 3.5.1 and 3.5.3, only changes to the web side)


#3

I dont have Jessie at all anymore, so I can’t help there. As far the fault goes then its the local web pages that report the dump 1090 fail, i dont know enough to know if its an incorrectly reported failure or an actual failure. Has given me the reports 4 times in 20 hours of operation so far.


#4

OK, I can’t help you with problems on Stretch unless you have a specific problem report. From the description it just sounds like you have an intermittent network problem. If you have more specific information about what is failing (describe what is happening precisely, check the dump1090 logs, etc) then let me know. Or you could try a Jessie image on a spare sdcard on the same hardware and see if the same problem happens.


#5

@mikey1963
What have you installed, dump1090-fa or dump1090-mutability?


#6

I notice that ground operations vehicles are now being graphically depicted as such.

Nice!


#7

Dump1090-fa, I installed the package normally.

Please accept my apologies as this is mobile email and may be more error prone than is acceptable.

Mike Smith
Owner
T 01489616104
M 07973221971
E mike@realtimetesting.co.uk
W www.realtimetesting.co.uk
Follow us:
Portsmouth , Hants
realtimetesting accepts no liability for the content of this email, or for the consequences of any actions taken on the basis of the information provided, unless that information is subsequently confirmed in writing. Any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.


#8

I have installed dump1090-fa on Raspbian STRETCH, but not by Package install, by building the package (J Prochazka’s script). It works fine.

To replicate your situation, I will format my microSD Card, write Raspbian STRETCH Lite image, and install dump1090-fa + Piaware 3.5.1 by package install (STEP 2 on page https://flightaware.com/adsb/piaware/install) and report back.

P.S.
The Title of this thread is 3.5.3. Is this a typing error? I could not find version 3.5.3


#9

It’s this weekends update on 3.5.1 via apt-get

Please accept my apologies as this is mobile email and may be more error prone than is acceptable.

Mike Smith
Owner
T 01489616104
M 07973221971
E mike@realtimetesting.co.uk
W www.realtimetesting.co.uk
Follow us:
Portsmouth , Hants
realtimetesting accepts no liability for the content of this email, or for the consequences of any actions taken on the basis of the information provided, unless that information is subsequently confirmed in writing. Any views or opinions presented in this email are solely those of the author and do not necessarily represent those of the company.


#10

Formatted microSD card
Wrote Raspbian STRETCH Lite
Ran following commands (STEP 2 on page https://flightaware.com/adsb/piaware/install)
ALL WORKING OK

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
............

pi@raspberrypi:~ $ wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.5.3_all.deb
.........
.........
2017-11-06 14:24:26 (2.15 MB/s) - ‘piaware-repository_3.5.3_all.deb’ saved [4966/4966]

pi@raspberrypi:~ $ sudo dpkg -i piaware-repository_3.5.3_all.deb
..........
..........
Setting up piaware-repository (3.5.3) ...

pi@raspberrypi:~ $ sudo apt-get update
Get:1 http://flightaware.com/adsb/piaware/files/packages jessie InRelease [1,844 B]
Hit:2 http://mirrordirector.raspbian.org/raspbian stretch InRelease
..........
pi@raspberrypi:~ $ sudo apt-get install piaware
.........
Setting up piaware (3.5.3) ...
............

pi@raspberrypi:~ $ sudo apt-get install dump1090-fa
..........
Enabling dump1090-fa: ok
..........
Restarting lighttpd..
Created symlink /etc/systemd/system/default.target.wants/dump1090-fa.service → /lib/systemd/system/dump1090-fa.service.

pi@raspberrypi:~ $ sudo piaware-config allow-auto-updates yes
Set allow-auto-updates to yes in /etc/piaware.conf:7

pi@raspberrypi:~ $ sudo piaware-config allow-manual-updates yes
Set allow-manual-updates to yes in /etc/piaware.conf:8

pi@raspberrypi:~ $ sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
Set feeder-id to xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx in /etc/piaware.conf:9

pi@raspberrypi:~ $ sudo reboot

.


#11

Great news, keep your eye on it, it always seems to fail when looking at the local web interface with me. It’s not frequent, only 4 times in 24 hrs but I never had a single failure on 3.5.1


#12

Upgraded to 3.5.3 on Pi 3 running Raspbian Stretch. Has anyone else lost the button to enable bing maps? I re-entered my key in config.js but am not getting the option to enable that view.

Edit: Appears to be confined to safari since it works fine on same Mac running Firefox. I’ve probably done something unrelated that’s causing this.

Update: Quitting and restarting safari did not appear to clear the cached javascript files. With the Develop menu option enabled, viewing the source clearly had an an old config.js which still had the bing key as null. Emptying the cache from the Develop menu seems to have fixed the issue.


#13

Tried to upgrade from my FA Stats page, Piaware installed on PC running Ubuntu 16.04.03 x64

FAILED

[2017-11-08 11:27 EST] manual update (user-initiated via their flightaware control page) requested by adept server
[2017-11-08 11:27 EST] *** running command '/usr/lib/piaware/helpers/run-apt-get update' and logging output
[2017-11-08 11:27 EST] run-apt-get(4153): /etc/apt/trusted.gpg.d/flightaware-archive-keyring.gpg does not exist; installing it
[2017-11-08 11:27 EST] run-apt-get(4153): Automatic updates not available for OS ubuntu:16.04 (Ubuntu 16.04.3 LTS)
[2017-11-08 11:27 EST] skipping action dump1090
[2017-11-08 11:27 EST] update request complete

[2017-11-08 11:28 EST] 6522 msgs recv'd from dump1090-mutab (386 in last 5m); 6522 msgs sent to FlightAware

[2017-11-08 11:29 EST] manual update (user-initiated via their flightaware control page) requested by adept server
[2017-11-08 11:29 EST] *** running command '/usr/lib/piaware/helpers/run-apt-get update' and logging output
[2017-11-08 11:29 EST] run-apt-get(4191): Automatic updates not available for OS ubuntu:16.04 (Ubuntu 16.04.3 LTS)
[2017-11-08 11:29 EST] child process 4191 exited with status EXIT 1
[2017-11-08 11:29 EST] update request complete

#14

Like it says, unsupported OS; you’ll need to build your own packages as FlightAware doesn’t provide binary packages for Ubuntu / x86_64


#15

Thanks for pointing out. I have forgotten that I have originally installed both Piaware and dump1090-mutability v1.15~dev on my PC by building their packages.


#16

Hi. I am currently running Debian Package Add-on version 3.1.0 (I believe on JESSIE). How do I update to the latest version of Piaware?


#17

@oskeremmie

You can go to you Flightaware stats page, click the gear icon at top-right to open “CONFIGURE” page, and scroll down where you see “Device commands” and from dropdown select “Upgrade and restart PiAware”, and click button “send”, and wait for 5 minutes for process to complete.

Since your Piaware version is very old (3.1.0), a large jump to 3.5.3 may result in something broken. If this happens, the cleanest and easiest solution will be to format microSD card and make fresh install of everything.


#18

Thanks. Unfortunately I have the following message: Sending commands to your device is not available because the feature is disabled locally on your device. :). Have to look into this when I get home


#19

@oskeremmie

Give these commands, then check your configuration on stats page.

sudo piaware-config allow-auto-updates yes
sudo piaware-config allow-manual-updates yes
sudo systemctl restart piaware

#20

Ran the above commands and was able to update from the configuration on my stats page. Stats page is now showing three green for the feeder status. Thanks very much for your quick response and help :+1: