Raspbian STRETCH - dump1090-mutability v1.15~dev Does NOT Work


#1

Downloaded and wrote “2017-08-16-raspbian-stretch-lite.img” to microSD card.
Installed following using method Bake a Pi - Option 3:

  • Dump1090-mutability v1.15~dev
  • Piaware data feeder 3.5.1

Found:

(a) The Map at < IP of Pi >/dump1090/gmap.html gives error message:

Problem fetching data from dump1090.
AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
The displayed map data will be out of date.

(b) The dump1090 status says Started:

pi@raspberrypi:~ $ sudo systemctl status dump1090-mutability -l
● dump1090-mutability.service - LSB: dump1090 daemon (mutability variant)
   Loaded: loaded (/etc/init.d/dump1090-mutability; generated; vendor preset: enabled)
   Active: active (exited) since Wed 2017-08-23 12:52:42 EDT; 1min 6s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 526 ExecStart=/etc/init.d/dump1090-mutability start (code=exited, status=0/SUCCESS)

Aug 23 12:52:41 raspberrypi systemd[1]: Starting LSB: dump1090 daemon (mutability variant)...
Aug 23 12:52:42 raspberrypi systemd[1]: Started LSB: dump1090 daemon (mutability variant).

.

(c ) Piaware says dump1090 is not working:

pi@raspberrypi:~ $ sudo systemctl status piaware -l
● piaware.service - FlightAware ADS-B uploader
   Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2017-08-23 12:52:41 EDT; 13min ago
     Docs: https://flightaware.com/adsb/piaware/
 Main PID: 525 (piaware)
   CGroup: /system.slice/piaware.service
           └─525 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json

Aug 23 13:04:57 raspberrypi sudo[3376]:  piaware : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/netstat --program --tcp --wide
Aug 23 13:04:57 raspberrypi sudo[3376]: pam_unix(sudo:session): session opened for user root by (uid=0)
Aug 23 13:04:57 raspberrypi sudo[3376]: pam_unix(sudo:session): session closed for user root
Aug 23 13:04:57 raspberrypi piaware[525]: no ADS-B data program seen listening on port 30005 for 371 seconds, trying to start it.
Aug 23 13:04:57 raspberrypi piaware[525]: attempting to start dump1090..
Aug 23 13:04:57 raspberrypi piaware[525]: can't start dump1090, no services that look like dump1090 found
Aug 23 13:05:07 raspberrypi sudo[3421]:  piaware : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/netstat --program --tcp --wide
Aug 23 13:05:07 raspberrypi sudo[3421]: pam_unix(sudo:session): session opened for user root by (uid=0)
Aug 23 13:05:07 raspberrypi sudo[3421]: pam_unix(sudo:session): session closed for user root
Aug 23 13:05:07 raspberrypi piaware[525]: no ADS-B data program seen listening on port 30005 for 10 seconds, next check in 60s

.

FURTHER ACTION

To find out if the problem is with dump1090-mutability or Raspbian Stretch, wrote “2017-07-05-raspbian-jessie-lite.img” to another microSD card, and installed dump1090-mutability v1.15~dev and Piaware data feeder 3.5.1 by exactly the same method as carried out for Raspbian Stretch. Found everything is working OK.

Also, in build directory of Raspbian Stretch, found that one additional package “dump1090-mutability-dbgsym_1.15~dev_armhf.deb” has been built. Don’t know what it is for. Any way installed that additional .deb package also, and rebooted, but failure persisted.

Packages in build directory of Raspbian JESSIE:

dump1090-mutability_1.15~dev_armhf.changes
dump1090-mutability_1.15~dev_armhf.deb

.

Packages in build directory of Raspbian STRETCH:

dump1090-mutability_1.15~dev_armhf.deb
dump1090-mutability_1.15~dev_armhf.buildinfo
dump1090-mutability-dbgsym_1.15~dev_armhf.deb
dump1090-mutability_1.15~dev_armhf.changes


#2

Quickly red release notes for Rasbian and Debian stretch versions. Couple of thoughts:

  1. Seems that Debian Stretch changed the way how debug symbols are handled, so I think that explains the extra package. As long as you are not trying to debug the dump1090 you do not need to install the dbgsym package
  2. Raspbian Stretch changed the way how pi account is handled and behavior of the sudo. Looking at your piaware status I wonder if piaware have no permission to start dump1090.

I have not tried to install stretch yet, but will try next week.


#3

Thanks for replying and providing this valuable information. I was wondering what for this extra package is built.

.

I manually restarted dump1090-mut several times by command “sudo systemctl restart dump1090-mutability”, but it did not help.

I have noted that in Pi with Jessie, the status command (sudo systemctl status dump1090-mutability) displays two or thhree lines of arguments like
–lat 43.xxxx --lon -79.xxxx --gain -10 --max 300
and many more. All these arguments are not there when status command is given in Stretch.

When you try it, please post your results/observations.


#4

I have stretch running with piaware with no problems what so ever. I dont use the prepared img though, i had a Jessie img that i online updated to stretch with piaware on it. As i say i have encountered zero problems.


#5

@mikey1963
I understand that by “Piaware” you mean “dump1090-fa+Piaware data feeder”. If my understanding is correct, then You are right. There is no problems between Raspbian Stretch and dump1090-fa.

On my first microSD card after writing Raspbian Stretch image, I installed dump1090-fa + Piaware data feeder, and these worked ok.

On my second microSD card after writing Raspbian Stretch image, I installed dump1090-mutability + Piaware data feeder, and it failed.


#6

I have managed to have Raspbian Stretch Lite running dump1090-mutability~1.15dev

pi@raspberrypi:~ $ sudo systemctl status piaware -l
● piaware.service - FlightAware ADS-B uploader
Loaded: loaded (/lib/systemd/system/piaware.service; enabled; vendor preset:
Active: active (running) since Mon 2017-08-28 00:27:02 UTC; 2 days ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 561 (piaware)
CGroup: /system.slice/piaware.service
├─561 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusf
├─704 /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --n
└─713 /usr/lib/piaware/helpers/fa-mlat-client --input-connect localho

Aug 30 20:57:40 raspberrypi piaware[561]: 232918 msgs recv’d from dump1090-mutab
Aug 30 20:59:05 raspberrypi piaware[561]: mlat-client(713): Receiver status: con
Aug 30 20:59:05 raspberrypi piaware[561]: mlat-client(713): Server status: syn
Aug 30 20:59:05 raspberrypi piaware[561]: mlat-client(713): Receiver: 34.0 msg
Aug 30 20:59:05 raspberrypi piaware[561]: mlat-client(713): Server: 0.1 kB/
Aug 30 20:59:05 raspberrypi piaware[561]: mlat-client(713): Results: 36.3 posit
Aug 30 20:59:05 raspberrypi piaware[561]: mlat-client(713): Aircraft: 6 of 6 Mod
Aug 30 21:02:40 raspberrypi piaware[561]: 233107 msgs recv’d from dump1090-mutab
Aug 30 21:07:40 raspberrypi piaware[561]: 233465 msgs recv’d from dump1090-mutab
Aug 30 21:12:40 raspberrypi piaware[561]: 233791 msgs recv’d from dump1090-mutab

:slight_smile:


#7

I had the same error…

Problem fetching data from dump1090.
AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
The displayed map data will be out of date.

I fixed it by following these steps:

#open file rtl-sdr-blacklist.conf for editing
sudo nano /etc/modprobe.d/rtl-sdr-blacklist.conf

#add the following 2 lines to above file:
blacklist dvb_usb_rtl2832u
blacklist dvb_usb

#save file

#get the vendor and product ID from your USB receiver
lsusb

#note that line which is related to your stick (e.g. Bus 003 Device 018: ID 0bda:2832 Realtek Semiconductor Corp. RTL2832U DVB-T)

#open file rtl-sdr.rules for editing
sudo nano /etc/udev/rules.d/rtl-sdr.rules

#add the following line to above file and change the id’s, matching your device:
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0bda", ATTRS{idProduct}=="2832", MODE:="0666"

#save file
#exit and reboot
sudo reboot

Raspbian Stretch + dump1090-mutability~1.15dev is running fine now. :grinning:


#8

Thank you Randstad.
I will try your workaround tonight.


#9

Good luck. Let me know if it works.


#10

I have seen a post by member jaxxtheone in Planefinder forum, which confirms the problem lies with the pre built package rtl-sdr installed by “apt-get install” method. Member jxxtheone has solved it by not using “apt-get install”, and instead building it from source code by following method:

#Prior of installing dump1090-mutability_1.15~dev, I did a rtl-sdr install.

#Used:

sudo apt-get install -y git cmake libusb-1.0-0.dev build-essential
git clone git://git.osmocom.org/rtl-sdr.git
cd rtl-sdr/
mkdir build
cd build
cmake ../
make
sudo make install
sudo ldconfig

#Then:

chmod +x /home/pi/rtl-sdr/build/rtl_tcp.sh
sudo cp /home/pi/rtl-sdr/rtl-sdr.rules /etc/udev/rules.d
sudo bash -c 'echo "blacklist dvb_usb_rtl28xxu" > /etc/modprobe.d/dvb_usb_rtl28xxu.conf'

#And finally:

sudo systemctl enable /home/pi/rtl-sdr/build/rtl_tcp.service
sudo init 6

After building and installing package rtl-sdr from source code by above method, member jaxxtheone carried out the remaining steps of manual install of dump1090-mutability.


#11

Thanks Randstad, your method worked.

Initially it did not work. I found that :
(1) Only rtl-sdr.rules step is required, blacklisting is not required.

(2) In the line to be added to the file rtl-sdr.rules, the quotation marks in your post are of wrong format. This prevented your method to work. When I changed these to correct format it worked.

  • The quotes are wrong type “ ” (UTF U+201C, U+201D).
    These should be " " (UTF U+0022).

  • The minus (-) sign at end of line is not required, but if it is left there, it does not make any difference.


#12

A very easy, one step solution:

Based on posts of Randstad and jaxxtheone, I worked out a very easy solution which is given below.

Just now tested, works like a charm :smiley:

sudo wget -O  /etc/udev/rules.d/rtl-sdr.rules "https://raw.githubusercontent.com/osmocom/rtl-sdr/master/rtl-sdr.rules"

sudo reboot

#14

(2) In the line to be added to the file rtl-sdr.rules, the quotation marks in your post are of wrong format. This prevented your method to work. When I changed these to correct format it worked.

Hmm, thats a bug of the new forum software. As soon as you put text between " " (“test”) it gets changed to the wrong format. It stays OK with the preformatted text option: "test".

A very easy, one step solution:
Based on posts of Randstad and jaxxtheone, I worked out a very easy solution which is given below.
Just now tested, works like a charm :smiley:

Great!


#15

@abcd567

Glad we all have a nice and happy end!

I´d suggest you to post a new thread with the final solution so everybody can have it straight and easy. to find.

:slight_smile:


#16

You and Radstad have shown me the light to enable me to find out a simple solution.

Good idea, but first let me finish another excercise. I have still to find out the root cause of this problem, i.e. why the file “/etc/udev/rules.d/rtl-sdr.rules” is not installed in Raspbian Stretch, while exactly same procedure installs it in Raspbian Jessie?


#17

and again a perfekt abcd solution :)))

thanx - worked instantly
cheers
tom