Dump1090-mutability on Stretch


#21

What is the output of following command when using mutability?

cat /etc/modprobe.d/rtlsdr-blacklist.conf

#22

@flightfinderr

On mutability v 1.14 / v 1.15~dev install, check if file /etc/modprobe.d/rtlsdr-blacklist.conf exists

ls /etc/modprobe.d/

If it does not exist, proceed as follows:

.
(1) Create a new blank file with name rtlsdr-blacklist.conf

sudo nano /etc/modprobe.d/rtlsdr-blacklist.conf

.
(2) Copy-paste following code in this file

blacklist dvb_usb_rtl28xxu
blacklist dvb_usb_rtl2830u
blacklist dvb_usb_rtl2832u
blacklist rtl_2830
blacklist rtl_2832
blacklist r820t
blacklist rtl2830
blacklist rtl2832
blacklist dvb_usb_v2

.
(3) Save (Ctrl+o) and Close (Ctrl+x)

.
(4) Reboot PI
sudo reboot


#23

@abcd567 just tried that but unfortunately still not working.


#24

@flightfinderr

I give up. I have suggested all remedies I know, but your install seems to be tough nut.

May be @obj can solve this bug.


#25

@flightfinderr

I’ll take a guess here.
you have a RPi 3B+, downloaded, installed the piaware stretch SD iimage to use Skyview via dump1090-fa and you want the graphs that are only available by dump1090-mutability.

same here.
now the steps I followed to make this ‘salad’ (cause is not advisable to blend the two programs)

  1. unzipped the lite image with 7z.

  2. flashed the SD card using WinImageWriter (others use Etcher - combines steps 1 and 2 here)

  3. created a blank ssh file to be able to connect to RPi with Mobaxterm (dont use putty or filezilla as is all combined in Mobaxterm)

  4. edited the piaware-config.txt to add/change
    feeder id, fa user/pwd, wifi parameters, gain, ppm settings.
    [note: you may need to change wifi country - default is US - in which case you must
    interact with pi after 1st reboot with screen, keyboard, mouse, then reboot again]

  5. put on RPi, expanding image, reboot

  6. connected to RPi, changed user sudo su and installed apt-get install git

  7. then got Joe’s script with git clone https://github.com/jprochazka/adsb-receiver and downloaded the latest version 2.6.3 which includes the v1.15 decoder.

  8. cd adsb-receiver

  9. run install.sh, it installed bc then to you want to continue with setup [YES]
    kept pressing no to all menus till reached Would you like to install the ADS-B Receiver Project web portal? [YES] and after few more prompts finished the installation.

  10. checked piaware-status and verified connected and dump1090-fa sending data.

  11. in my browser (Opera) if I run RPi IP:80 or RPi IP/dump1090.php I get Skyview 'embedded in the ADSB receiver - mutability web page, where I can select the graphs.
    if I run RPi IP/dump1090-fa I just get the Skyview full page.
    While on Skyview if I need to see the graphs RPi IP/graphs.php.

works without any problems

you may try it see if it works. nowhere encountered the v1.14

HTH
evangel


#26

.
Most likely @flightfinderr has installed dump1090-mutability ver 1.14 by one of the following methods:

  • By using setting “receiver=dvbt” in FlightRadar24 feeder settings. (This setting prompts fr24feed to install dump1090-mutability ver 1.14 if already not installed)

    OR

  • By giving following two commands:

wget -O ~/dump1090-mutability_1.14_armhf.deb  "https://github.com/mutability/dump1090/releases/download/v1.14/dump1090-mutability_1.14_armhf.deb"  

sudo dpkg -i dump1090-mutability_1.14_armhf.deb  



#27

Thanks @abcd567 for all your time and suggestions. @evangelyul no I haven’t done that. I have 3b+ and installed raspbian stretch lite on it. Then as @abcd567 mentions installed mutability v1.14 only. I have tried mutability v1.15 as well as FR24 installation which comes with mutability v1.14.
All this have been tried separately on a newly flashed image with all suggestions mentioned here. When I install dump1090-fa, it starts working immediately so it seems like the issue is somewhere with mutability’s working with Stretch. Maybe @obj knows the answer?


#28

I feel that some files or configurations in your microSD card with mutability install are corrupted.

I will suggest you format your microSD card, download a fresh copy of Raspbian Stretch, write this newly downloaded copy to your microSD card, and then install dump1090-mutability ver 1.15~dev.

While making a fresh install, please note that you should take care of following:

(1) You must Install dump1090mutability ver 1.15~dev BEFORE installing FlightRadar24 feeder.

If you install fr24feed before installing any flavour of dump1090, the fr24feed will detect this and will install dump1090-mutability ver 1.14 in background, without you noticing it. If you then install ver 1.15~dev over the existing ver 1.14, it will create a mess and system may not work.

.

(2) In FR24 feeder settings, you should NEVER choose “Receiver DVB-T” at any stage. Choosing this option triggers fr24feeder to install dump1090 -mutab ver 1.14 over existing ver 1.15~dev, causing failure of system.


#29

@flightfinderr

If you decide to install and use dump1090-mutability ver 1.14, I will recommend do not get it installed by fr24feed (by using setting “receiver dvbt”). The ver 1.14 installed by fr24feed is controlled by fr24feed.

Instead install an independent copy of ver 1.14 by following commands:

wget -O ~/dump1090-mutability_1.14_armhf.deb "https://github.com/mutability/dump1090/releases/download/v1.14/dump1090-mutability_1.14_armhf.deb"  

sudo dpkg -i dump1090-mutability_1.14_armhf.deb 

For dump1090 ver 1.14 or ver 1.15~dev installed manually by you, use following settings:

“receiver beast-tcp” , “host 127.0.0.1:30005”
OR
“receiver avr-tcp” , “host 127.0.0.1:30002”

DO NOT INSTALL FR24 FEEDER BEFORE INSTALLING ANY VERSION OF DUMP1090


#30

@abcd567 I actually have tried all these separately, v1.14 and v1.15. After that to confirm its not installation problem, I installed fr24feed which uses v1.14 to confirm and that didn’t work either. After all that I installed dump1090-fa which works like a charm. I have also used two SD cards and tried all these at least two times to make sure I didn’t make any mistakes. It seems like there might be an issue between Stretch and mutability (both versions).


#31

I have Stretch and mutability v 1.15~dev, and no problems. The only difference is that I have Pi model 2, and you have Pi 3B+.


#32

I have pi2 lying somewhere as well. I will check it on that and see if that works.


#33

@abcd567 Did you install using Joe’s scripts or Stretch from raspberrypi.org and mutability v1.15 on top of that?


#34

@flightfinderr
This is what I have done:

(1) Downloaded 2018-06-27-raspbian-stretch-lite.zip , and wrote this image to microSD card.

Download page: https://www.raspberrypi.org/downloads/raspbian/

Direct download link: https://downloads.raspberrypi.org/raspbian_lite_latest

.

(2) Manually installed dump1090-mutability ver 1.15~dev using method given here:

How to Install dump1090-mutability_1.15~dev on RPi

.

(3) Manually installed following data feeders using instructions included in above noted web page for dump1090-mutability installation:

  • Flightradar24 data feeder - Step (11)
  • Piaware data feeder - Step (12)
  • Planefinder data feeder - Step (13)

#35

@abcd567 really appreciate all your help and suggestions. I played around with alot of settings and when I set gain to “-10”, decoding starts. I will keep on changing it to see where I get the most data. So far “-10” seems to be the magic number.

Didn’t have any such issues when I was running Jessie, gain was on default and I never changed it.


#36

This is really very strange.
In mutability, the default gain setting is “max”, and decoding takes place even without touching this setting.


#37

Yeah it is. I didn’t expect it to work. It was just by chance that I started doing that. At least now we have a solution in case someone else faces the same issue.


#38

@flightfinderr

How did you install mutability?

  • Using manual method I have used and described in my above post
  • Using J Prochaz’s adsb-receiver scripts
  • Writing adsb-receiver image to your microSD card

#39

I installed using the manual method from your post on flightradar24 forum.