Disabling on-board Wi-Fi


#1

Hello, I’m new to FlightAware and Raspberry Pi. I was up and running using the internal Wi-Fi on the PI, but experiencing connection issues. I’m thinking that it is mainly due to the distance between my Pi and wireless router. When I put them in the same room, all seemed well. That’s not a long-term solution because my antenna connection is in a different room. Wired Ethernet, unfortunately, is also not an option. So, I want to add an external USB Wi-Fi adapter stick which has a better antenna. My question is, do I need to disable the internal Raspberry Pi Wi-Fi and if so, how can I do that? Is there something I can do to modify the config file that will keep my SSID and password but use the external USB Wi-Fi stick?

Thanks in advance,

Dave
W9QL


#2

Install or upgrade to 3.3.0, then set “rfkill yes” in your piaware-config.txt. Other configuration can stay unchanged.


#3

Thanks for your help. I was able to upgrade and set “rfkill” in the pi-aware config. However, the external USB Wi-Fi adapter does not connect. I’m thinking that I need to change another configuration setting in the Raspberry Pi so that it recognizes the external USB adapter with my wireless network info? I’m not sure how / where to do that.

Thanks in advance,

Dave


#4

If you have a recognized external wifi adaptor connected and rfkill yes, then it will disable the pi 3’s internal wifi and use the external adaptor instead.
Perhaps your adaptor is not supported by Raspbian. Does “iwconfig” show the adaptor?