FlightAware Discussions

ChartBundleLayers

I recently updated from PiAware v3.1.0 where ChartBundlesLayers = true worked.

When I set CharBundlesLayers = true in v 3.7.1 nothing appears to work. I have used CNTRL+CHIFT+DEL to clear the caches and CNTRL+F5. Still does not work.

Any suggestions?

How did you update?

  • by re-imaging
    or
  • by command from your Flightaware stats page
    or
  • by command from PuTTY/SSH

I downloaded a zipped image file from Flightaware yesterday. The image file is dated 05-06-2019 2:15pm.

My old Pi was destroyed by a nearby lightning strike in early July, replaced it and did not realize until a few days ago that my replacement Pi was not sending info to FlightAware, hence the new image and new account number.

If it is reimaging, it should be ok with ChartBundle. Which model of RPi you have now, Pi3 or Pi4?

The symbol has moved to the bottom right of the map, maybe you are looking for it somewhere else?

Anyway if you want you can try my version of the webinterface, it has them enabled by default:
https://github.com/wiedehopf/tar1090#tar1090

1 Like

For Beginners - How to Get Back Existing Station Number in A Fresh Install

.

My current model is a Pi3

Piaware image 3.7.1 with Pi3 does not have any problems. It is strange that you dont get ChartBundle map layer.

I have 3B+s and 4Bs running chart bundles with 3.7.1 without a problem.

Post the config line so we can double check it for typos.

It should look something like this

pi@tardis1:~ grep undle /usr/share/dump1090-fa/html/config.js // Set to true to enable the ChartBundle base layers (US coverage only) ChartBundleLayers = true; pi@tardis1:~

For dump978-fa this is the file
pi@uat2:~ grep Bund /usr/share/skyview978/html/config.js // Set to true to enable the ChartBundle base layers (US coverage only) ChartBundleLayers = true; pi@uat2:~

There is also the ExtendedData function. It gives extra details.

// Turn on display of extra Mode S EHS / ADS-B v1/v2 data
// This is not polished yet (and so is disabled by default),
// currently it’s just a data dump of the new fields with no UX work.
ExtendedData = true;

Open file config.js in nano editor

sudo nano /usr/share/dump1090-fa/html/config.js 

Scroll down till you see these two lines

// Set to true to enable the ChartBundle base layers (US coverage only)
ChartBundleLayers = false;

Change false to true.
Save (Ctrl+o), Close editor (Ctrl+x)

Now reload map (Ctrl+F5).

1 Like

Is your Pi bigger on the inside? :slightly_smiling_face:

1 Like

That doesn’t have any effect anymore, it was made the default.

Thank you all for your suggestions.

Wiedehopf nailed the solution, I was looking in the wrong place for the “button”.

@biekerc, This is a replacement RPI4 for an old RPI2 that has a GPS hat for NTP and a Mode S Beast.
https://ava.upuaut.net/?p=951 (Actually this was setup for the older OS and GPS hat https://ava.upuaut.net/?p=726)
Tardis is for its NTP functionality. This has been sitting behind a dresser in the corner of our bedroom for years. The GPS antenna sits on a window sill but gets enough satellites for NTP.
This is the site https://flightaware.com/adsb/stats/user/jonhawkes2030#stats-17065

1 Like