Can't get PIAware running


#1

Not sure what’s happened, but went to check PIAware, and I now get the following error:

My Pi is still chucking out data to FlightAware and to my VRS installation - it’s just the PIAware web app that seems to be the issue.

I’ve re-booted the Pi, tried upgrading and restarting PIAware from the FlightAware Configure menu for the site in question.

Any thoughts or ideas?

Regards,

Mark


#2

Mmh, not sure that is because it is working properly, but my feeder does not have a GPS - field…

Just checked, you have two sites, did you by any chance reimage a site without copying feeder id?

If that is the case, search for how-to on this forums and check posts by @abcd567


#3

Hi. Thanks for the reply. I did indeed do a re-image. I’ve now set the ID of my setup back to the original identifier and restarted but I still get the error shown above.

Any other suggestions gratefully received :blush:


#4

Give following commands and post outputs

sudo systemctl status dump1090-fa -l

sudo systemctl status piaware -l


#5

Not sure, maybe the ip changed, did you try to connect via the stats page or and old link? Does the sky view via the link on the status page?


#6

IP is the same. The link on the FlightAware site to my SkyView shows me the error above.


#7

Did you ssh to Pi and issue commands in my last post above? What are the outputs of these 2 commands?


#8

Here’s the results:

dump1090-fa.service - dump1090 ADS-B receiver (Fl Loaded: loaded (/lib/systemd/system/dump1090-fa. Active: active (running) since Wed 2018-08-22 17 Docs: https://flightaware.com/adsb/piaware/
Main PID: 433 (dump1090-fa)
CGroup: /system.slice/dump1090-fa.service
└─433 /usr/bin/dump1090-fa --net-bo-port
Aug 22 17:57:36 piaware systemd[1]: Started dump109Aug 22 17:57:36 piaware dump1090-fa[433]: Wed Aug 2Aug 22 17:57:37 piaware dump1090-fa[433]: rtlsdr: uAug 22 17:57:37 piaware dump1090-fa[433]: Found RafAug 22 17:57:37 piaware dump1090-fa[433]: rtlsdr: elines 1-13/13 (END)

piaware.service - FlightAware ADS-B uploader
Loaded: loaded (/lib/systemd/system/piaware.serv Active: active (running) since Wed 2018-08-22 20 Docs: https://flightaware.com/adsb/piaware/
Main PID: 6959 (piaware)
CGroup: /system.slice/piaware.service
├─6959 /usr/bin/piaware -p /run/piaware/ ├─6989 /usr/lib/piaware/helpers/faup1090 └─6998 /usr/lib/piaware/helpers/fa-mlat-
Aug 22 20:54:40 piaware piaware[6959]: 1756 msgs reAug 22 20:59:11 piaware piaware[6959]: mlat-client(Aug 22 20:59:11 piaware piaware[6959]: mlat-client(Aug 22 20:59:11 piaware piaware[6959]: mlat-client(Aug 22 20:59:11 piaware piaware[6959]: mlat-client(Aug 22 20:59:11 piaware piaware[6959]: mlat-client(Aug 22 20:59:11 piaware piaware[6959]: mlat-client(Aug 22 20:59:40 piaware piaware[6959]: 1916 msgs reAug 22 21:04:40 piaware piaware[6959]: 2099 msgs reAug 22 21:09:40 piaware piaware[6959]: 2275 msgs relines 1-20/20 (END)

I have recently also installed PiHole on my Pi which runs runs in port 80. Pretty sure I’ve viewed SkyView on 8080 since then so I don’t think that should be any conflict.

Cheers,

Mark


#9

But the Go to map button works?

It might be the Pi hole thing, try search for pi hole here to see if other people had issues (change to lightpd?)


#10

No, that throws the error “ [ERROR]: Unable to parse results from queryads.php : Unhandled error message (Invalid domain! )”


#11

As edited above, I think I remember people having problems with Pihole and Piaware on the same RPi

E.g. Lighttpd broken


#12

The status command’s outputs show that both the dump1090 and piaware are working ok.

Your graphs (see screenshot below) also show that your old station 16904, which was inactive since August 5, has now started to work, as the blue line at right most end has raisen up from zero to some positive value.

Now try this

  1. Press (Ctrl+Shift+Delete) keys simultaneously to clear browser cache

  2. After clearing browser cache, press (Ctrl+F5) keys to reload the browser.

.


#13

I think this is a local network problem that you’re having - whatever queryads.php is, it’s not part of piaware.

Clear your browser cache and doublecheck that you’re using the right IP.


#14

Thanks for all the help folks. Looks like it’s almost certainly PiHole causing a clash so looks like I’ll need to re-image again (and set my ID back to the current one - thanks for the tip :blush:).

Thanks again everyone. I should have twigged it was PiHole lol.

I’ll get another Pi for PiHole as I love the application.


#15

A really helpful and soltion full thread, thanks to the creator for creating it and thanks to everyone who helped in solving this issue. I had a great help from this as my issue and this topic are similar. Thanks a lot.
KissAnime LetGo


#16

Yep, they’re a good bunch here, that’s for sure :smile: