FlightAware Discussions

Can't get PIAware running

That file is no longer processed when pi-hole is active. Or is it?

Nice that you got through the process and fixed it now this is confirmed to work :wink:

I can only assume that the file is still used by lighttpd as there is a symbolic link from /etc/lighttpd/conf-enabled and that is the file that I changed to port 8089 and restarted the service. I would assume that pi-hole only overwrites the lighttpd.conf file but allows other configuration files unchanged.

I am happy to have got it working and will now move the working memory card to my original pi-aware machine and re-configure my feed, shutdown the pi-hole machine and now I have another development Pi to resolve similar problems on :grin:

If that is actually the case the external.conf can be shortened significantly to:

server.modules += (
  "mod_alias"
)

Out of curiousity: was lighttpd running without the external.conf or was it reporting errors also?
Maybe you could just check the status with external.conf empty / moved away?

3 Likes

That is correct the external.conf file contains what you have just stated and nothing else.

Lighttpd was running all ok without the external.conf file, I was able to access pi-hole but not pi-aware. I did try the original external.config that was posted above but this would not allow the lighttpd service to start.

This seems such a simple fix now it is working. I will start a new rebuild once I have migrated my current machines into one. Then check that it is as easy as this to have both running concurrently/simultaneously.

Latest update

This is definitely the way to allow both applications to run. I decided to be brave and install Pi-Hole on my existing Pi-Aware machine and all I did was run the curl installation for Pi-Hole, follow the bouncing ball to complete the install. Add the external.conf file to /etc/lightttpd directory with the following contents.

server.modules += ( 
"mod_alias"
)

Low and behold

192.168.xxx.xxx:8080 - Shows the Pi-Aware web page
192.168.xxx.xxx/admin - Shows the Pi-Hole Interface

Pi-Hole

Pi-Hole1

2 Likes

Thanks for this. I’ve been scratching my head trying to get this work. Your post worked, thanks!

Thanks for the info guys! Just made this work using the resources here. You guys are awesome!

PiHole + piaware solution:

sudo nano /etc/lighttpd/external.conf

Paste this:

server.modules += (
  "mod_alias"
)

Press CTRL-O and ENTER to save
Press CTRL-X to exit

Reboot.

5 Likes

@wiedehopf - after uninstalling pihole, the graphs1090 stopped working. Server refuses connection. Reinstalling graphs1090 produces warning message: “Non-standard configuration detected, you need to change the data URL in /etc/collectd/collectd.conf”
Services on other ports than 80 do function properly. Only those on 80 port are rejected.

pihole destroys the lighttpd configuration.

You can try purging lighttpd and dump1090-fa and remove the directory /etc/lighttpd but i won’t assist you with that.
After that reinstall those programs.

Anyhow after having pihole installed the best solution is: fresh image.
Don’t have any clue what else it screws around with.

This thread is only for people who want to make it work on their pihole RPi.

1 Like

Procedure above worked successfully. Thanks.

I note the solution summarized by wiederhopf for overcoming a problem running pi-hole and piaware together … for the uninitiated is there a simple procedure to be applied when we have only the piaware image on the sd card?

Attempting to run curl -sSL https://install.pi-hole.net | bash at the prompt pi@piaware:-$ results in the error -bash: curl: command not found

I had the same problem (Pihole grabbing 8080), and your fix worked perfectly for me! Thanks!