Lighttpd broken


#1

Well, I have installed pi-hole on my pi (Pi-hole: black hole for Internet advertisements). It works, but the issues is that their installer tried to install an admin webpage on port 80. That’s great, I was expecting to be able to reconfigure it to avoid breaking my piaware webpage, but it didn’t.
So now on the http://192.168.1.xxx/dump1090.php I see the start pi-hole webpage (not even the configured one).
I have tried to reinstall the joe’s script, but it didn’t bring back the dump1090 page, only the dump978 one.
I have re-installed the pi-hole without web page… not solved the problem.
Any ideas how can I bring it back without reinstalling everything?


#2

I also run PiHole, but it is on a separate Pi, not on the box that runs PiAware. These things are so cheap it’s not worth the trouble trying to get them to play nice with each other on the same box. …my humble opinion at any rate.


#3

I guess you are right.


#4

have you looked at the configuration files in /etc/lighttpd/conf-enabled ?

you should be able to change the ports there.


#5

I have looked, but I think that the pi-hole broke that and somehow is ignoring it…

# Allows access to the static files that provide the dump1090 map view,
# and also to the dynamically-generated json parts that contain aircraft
# data and are periodically written by the dump1090 daemon.

alias.url += (
  "/dump1090-fa/data/" => "/run/dump1090-fa/",
  "/dump1090-fa/" => "/usr/share/dump1090-fa/html/"
)

# redirect the slash-less URL
url.redirect += (
  "^/dump1090-fa$" => "/dump1090-fa/"
)

# Listen on port 8080 and serve the map there, too.
$SERVER["socket"] == ":8080" {
  alias.url += (
    "/data/" => "/run/dump1090-fa/",
    "/" => "/usr/share/dump1090-fa/html/"
  )
}

#6

you should check /etc/lighttpd/lighttpd.conf too and you should check if pi-hole has put other files in conf-enabled.

also maybe do a journalctl -t lighttpd ?

i could imagine pi-hole brings it own webserver and then they wrangle with ports.
maybe in the main lighttpd.conf just change server.port to 8000 or some other unused port.

have you tried accessing dump1090 at http://192.168.1.xxx:8080 ?