FlightAware Discussions

Web interface port on same as pi-hole

Hi there,
I have installed flightaware on my pi which is also running pi-hole.
I can’t seem to access the flightaware web interface as this conflicts and uses same one as pi-hole.
Is there a way to change this to say 9090?

The web interface is served by lighttpd webserver. There should be some tutorial available to change the port accordingly

Have a look at this thread, same problem I think…

About two years ago I have opened a ticket on PiHole Discourse about incompatibility with Piaware webpage, but none of the devs there had ADS-B installed or wanted to have it installed. They tried some troubleshooting… but no results.

I ended up freeing two older RPi’s and dedicating them to PiHole. Even a PiZero W works for PiHole.

PS: Seems that somebody found a solution two years later:

Note this seems to be a bug in PiAware’s way of creating the lighttpd files - they don’t set the documentroot in a config file, nor they ensure that the alias module is enabled. I want to report it to them, but right now GitHub is having some issues. I’ll do it tomorrow, provided I don’t forget.

Here is another solution:

Adding the document root probably makes it work on :8080
While my solution only makes it work at /dump1090-fa

2 Likes

Yeah, I needed to make it work on a port, because that’s how I can port forward in my home router the incoming connections of port 80. I wanted to have a small web server for the piaware, visible from internet.

Now it serves the tar1090 web page, because you also provided a port (8504).

Be aware that you can access the rest of the lighttpd pages as well from that port.
It’s a limitation of lighttpd.

:8504/graphs1090 will give you the graphs for example.

Before you could have just forwarded port 80 to port 8021 or whatever and then accessed :8021/tar1090
There is marginal benefit in having an extra port.

1 Like

I saw that, it’s great. It just doesn’t have a link on the “main” page, you need to know about them being present.

Thank you again for sharing that with us!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.