unable to configure dump1090-fa config.js

I am running dump1090-fa v3.3.0 and piaware 3.1.0, I am unable to get any changes to my configuration when I change /usr/share/dump1090-fa/html/config.js

for example, I want to enable chartbundle, clock and add more circles.

changed, all the settings appropriately. But, no change at all.

anyone else have similar issues ? or any pointers please.

restart lightttpd for the changes to take effect.
You can re-boot the whole device if it is easier.
You may also need to refresh your browser.

Did All of those mentioned, I even confirmed by chmod 000 index.html to see if I get a 404 and I do, So. I know that the file in /usr/share/dump1090-fa/html/index.html is the one that the lightttpd is sourcing and not from somewhere else.

Just doesn’t honor the settings in config.js.

made a fresh install of rPI, PIaware and dump1090.

Still I can’t seem to reflect the changes I make in /usr/share/dump1090-fa/html/config.js or script.js

I tried the alternating red/blue circles - no effect.

yes, I have restarted the services, restarted pi. no effect.

I am now running 3.3.0 on both piaware and dump1090

Fetch the config file by hand (e.g. using wget or curl) and check you get what you’re expecting.
If you don’t get what you’re expecting, there is a problem on the Pi side.
If you do get what you’re expecting, there is a problem on the browser side.

Chrome/Settings/Advanced/Clear Browsing Data/Check Cached Images and Files/Clear Browsing Data/Refresh the page.

Thanks, that was it. Feel like an idiot, barking at the wrong tree.

Aye, it’s a PITA. I manually add any aircraft to the database whenever I spot one without full details and I have to go through this little process everytime :frowning:

went ahead and modified the index.html with meta tags to stop the browser from caching, I know this does not work with all browsers, but I Am happy that it works with chrome and I do see changes reflected when I refresh without clearing cache.

right after the meta tag below, add the ones in red.

            <meta http-equiv="cache-control" content="max-age=0" />
            <meta http-equiv="cache-control" content="no-cache" />
            <meta http-equiv="expires" content="0" />
            <meta http-equiv="expires" content="Tue, 01 Jan 1980 1:00:00 GMT" />
            <meta http-equiv="pragma" content="no-cache" />

For me, the PITA is adding the data. So I modified the csv-to-json.py script in the tools to take csv data and amend the database, instead of replacing the entire database (which is how the default script works). I can’t access it right now, but when I get home I’ll share the script.

As for a slightly faster way to clear the cache, click the three dots in the top right of Chrome, goto More tools, then Clear browsing data… That gets you to the dialog box quicker.

An alternative to that is to modify dbloader.js. Near the bottom you will see two different (but nearly identical) AJAX requests that include a “cache: true” parameter. Change both of these to “false” and you’re in business.

Note that disabling the cache for the database (with either method) does slow things down a bit, particular when the page is first loaded, and anytime an aircraft is picked up that is not already on the map.

I don’t mind manually editing the database tbh. It’s only very occasionally that I spot an unknown aircraft and I have WinSCP open permanently so that I can quickly Google the code and then edit the DB.