PiAware 3.0.5 configure flightaware's dump1090

Hey Guys!

I installed PiAware 3.0.5 with the integrated dump1090.
Now i want to configure the range rings and the metric signs , but I do not know how.
May someone could help me?

Not sure which version you have. FA or dump1090-mut

Try editing this for the range rings and metric settings:-

Metric = false;

SiteCircles = true; // true to show circles (only shown if the center marker is shown)
// In nautical miles or km (depending settings value ‘Metric’)
SiteCirclesDistances = new Array(100,150,200,225,250);

I have the fa version. I tried it with: /usr/share/dump1090-fa/html/config.js
But it says: permission denied

sudo vi (or nano or whatever editor you like) /usr/share/dump1090-fa/html/config.js

The same file is used for Bing and Mapzen keys. Get a Bing key if you don’t like OpenMaps(I hated them at first but got use to them). Bing is pretty close to google.

You may need to restart lighttpd

sudo service lighttpd restart

Sorry, but it says I have no permission to write…
Now, everything is allright! Thank you!

I did the upgrade using the control panel on my page and it all seemed to go fine. Now it says I am running 3.0.5. I then updated the dump1090 and now the dump1090 doesn’t work. I get the “placeholder” web page from lighttpd server.

Did you try ](http://)/dump1090-fa/index.html

Now that worked!

Now why wouldn’t that work being called up with the IP and port (xx.xxx.xxx.xxx:8080/dump1090-fa/index.html

Much Thanks


I dont use IP:8080, instead use only IP without port, like this:

Did you reboot after upgrading dump1090? The package installs a port 8080 listener, but it doesn’t work until you reboot on wheezy. Like the instructions say.

I rebooted the Pi, restart the lighttpd service and restarted the dump1090 service too. Actually I have to use the port in the address because I am off site and having the router redirect internally on the LAN. The Pi is far away from me on a mountaintop.
I like the new map and layout.
Much thanks.

Well, you didn’t mention that you were connecting externally and a port rewrite was involved!

Port 8080 just emits a redirect to port 80 which may be what is confusing things. At the end of the day you need a connection to what is listening on port 80 on the Pi after any NAT has happened.

I am in the same boat. Every time I need to do the :8080 bit, I cannot. On my Rpi the port is locked. I have spent HOURS trying to figure a way for it to work, but now, I just use what ABCD recommended and don’t worry about it. It is frustrating and I consider it a fail, but Check your ports and you will see it is locked, I am sure.

The canonical place for the dump1090-fa map is hostname/dump1090-fa/, i.e. on the normal HTTP port, port 80.
The canonical place for the piaware status page is hostname/

Port 8080 is only there to provide a compatibility redirect for existing links that are using port 8080. It is only a redirect, no content is served on that port, your browser still needs to be able to connect to the listener on port 80 to get the map.

If you are building new stuff, use port 80.

It is also relatively safe to expose the port 80 listener to the internet at large, as it’s hosted on a “real webserver” not the collection of #8 wire that was the dump1090 webserver. If you were exposing the old dump1090 map to the world, count yourself lucky that you’re not doing that any more.

OBJ, Thank you for your insight.

I know this is way beneath you, but it would help me a lot if you can sort this out.

When I go to MY ADS-B, there is a link, under my receiver info that sez “Web interface, view live data”

When I click on that I get “This site can’t be reached”. AND the URL is my :8080

That is why I have been feverishly trying to get 8080 going, so I could see this data!

Does the link, when it works, take one to the DUMP1090 web site? If that is the case, I am good.

Thank you for your time.

Right, that’s an example of a legacy link that refers to port 8080. It does (or should…) link to the map which is available under /dump1090-fa/

Eventually it’ll get updated to point directly there, it’s just relatively low priority since it requires some juggling with looking at the exact sdcard, piaware, dump1090 versions in use by a particular site to pick a suitable URL, and port 8080 should continue to work anyway.

If you are on the same network as the Pi with no firewalls or routers between you and the Pi, I don’t know why the port 8080 link doesn’t work for you; if it is an unmodified sdcard image it should definitely work, but I don’t know what modifications you have made.

But you should be able to just go directly to port 80 to reach the map (& status page if you are using a sdcard install) regardless.






(no slash / after fa)


(slash / after fa)

Edit: Image below replaced to show piaware version number (3.0.5) at top right (above the table)



Thanks again. I am with you, and I get the map with the link you provided. That has not been a problem.

I am 100% good to go.

I just did not know what I did not know!

Yes, the trailing slash is required. I used to know why, but have forgotten. It is something to do with the way lighttpd is configured. You can probably fix it by adding a rewrite rule if you really want to.