FlightAware Discussions

Dump1090-fa web panel showing 404-not found

Hi everyone

I have had my pi 4 running for ages but the other week I’ve had a powercut (Might be during an update not 100%)

The Dump1090-FA site comes back as 404 not found error. I’ve uninstalled and reinstalled dump1090-fa but the web site doesn’t display however it is feeding data.

Any ideas?

Try
Clear browser cache (Ctrl+Shift+Delete).
Reload browser (Ctrl+F5).

Also check router for any change in local IP of Pi4.

You can also find current local IP from your Flightaware stats page.

https://flightaware.com/adsb/stats/user/

Its the same on my phone and its the same IP.

check if it’s running.

sudo systemctl status dump1090-fa

and of course the correct URL http:///dump1090-fa or http://:8080/dump1090-fa

Error 404 means “page not found” so the webserver is running, but can’t deliver the webpages of dump1090

I just checked

pi@raspberrypi:~ $ sudo systemctl status dump1090-fa
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor pres
Active: active (running) since Sat 2020-06-06 15:44:28 BST; 4h 41min ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 421 (dump1090-fa)
Tasks: 3 (limit: 4915)
Memory: 7.5M
CGroup: /system.slice/dump1090-fa.service
└─421 /usr/bin/dump1090-fa --device-index 0 --gain -10 --ppm 0 --max-

Strangely tar1090 works

@stephenkurtianyk
What is the output of this command?

sudo systemctl status lighttpd

Would tar1090 work if this is not running?

Just checked

● lighttpd.service - Lighttpd Daemon
Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled; vendor preset:
Active: active (running) since Sat 2020-06-06 15:46:01 BST; 23h ago
Process: 1963 ExecStartPre=/usr/sbin/lighttpd -tt -f /etc/lighttpd/lighttpd.co
Main PID: 1968 (lighttpd)
Tasks: 1 (limit: 4915)
Memory: 6.6M
CGroup: /system.slice/lighttpd.service
└─1968 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf

Try purging, then reinstalling dump1090-fa
If that does not solved the issue, then easiest solution is to reimage the microSD card.

sudo apt-get purge dump1090-fa  

sudo apt-get install dump1090-fa

sudo reboot

That fixed it thank you so much!

Whats the different between remove and purge?

remove deletes the packages.
purge deletes the packages AND deletes the configuration files too.

1 Like