After update of dump1090 -> Problem fetching data on web pag


#1

Hi,

I have updated from piaware 2 to 3 seamlessly with the remote command. The web page at [IP of RPI]:8080 was working well, with the new design of lighttpd.

Then I have updated dump1090 to dump1090-fa successfully, all is OK except that the web page is no more fed :


Problem fetching data from dump1090.
AJAX call failed (error: Not Found). Maybe dump1090 is no longer running?
The displayed map data will be out of date. 

Can you tell me how dump1090-fa is “connected” to lighttpd ?

Thanks
J-Luc


#2

json files are written to /run/dump1090-fa/; these are served by lighttpd as URLs under /dump1090-fa/data/

A simple thing to try is to clear your browser cache, maybe you have stale javascript from the old version cached.

You also may need a reboot after the initial upgrade for the port 8080 listener to start working. (The port 80 listener should be OK immediately though)


#3

json files are written to /run/dump1090-fa/;

Ok, how to tell dump1090-fa to do this ?


#4

Same kind of problem here, updated via the stat page three of my remote sites in Mexico, two are working fine the other will not show the new map. Clear browser cache here on my PC, nothing. Change PC/browser same old map. The initial menu says piaware 3.1 running. It seems that dump1090-fa did not refresh. Then from the stat I upload and refresh dump1090, but same old map. Reboot directly the rPi, nothing changed. My partner in Mexico accessed from Cabo and also saw the old map. My question is, if feasible: Can I remove the old dump1090 and what is the appropriate command to erase and then load new dump1090? I am using there piaware 3.04 in a rPi 2. The two that are working now fine have rPi 3 and were on piaware 3.04, so the only thing different was the rPi. Could be the rPi 2 the factor?

Thanks

Alex


#5

In my case, the new map worked with the old dump1090 but does not work no more with the new one :frowning:


#6

Issue solved : I had to remove dump1090.sh into init.d as dump1090-fa is now launched by piaware.

All is ok now.

For areyes : you juste have to install manually dump1090-fa (fr.flightaware.com/adsb/piaware/install) with



sudo apt-get install dump1090-fa

then remove dump1090.sh (or dump1090-fa.sh) from init.d

Note that the configuration of dump1090 is now inside /etc/default/dump1090-fa


#7

Well… not exactly. But where was your dump1090.sh from? i.e. what did you have installed previously?


#8

Obj, could you expand on your comment: :not exactly?

Run sudo apt-get install dump1090-fa and i got an error:

To tun sudo dpkg --configure -a, so I did it and another error was given
so I run sudo apt-get update and rerun first command and got:

sudo apt-get install dump1090-fa
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
piaware-release : Depends: beast-splitter (= 3.1.0) but 3.0.3 is to be installed
Depends: piaware-web (= 3.1.0) but 3.0.3 is to be installed
Depends: socat but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
pi@piaware:$

So I am hesitant to continue, my site is 500 miles away.

Regrads

Alex


#9

This means a previous package operation was interrupted (you control-C’ed it, or lost power during an upgrade, or similar).
It can take some work to recover from that.

sudo apt-get install dump1090-fa
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
piaware-release : Depends: beast-splitter (= 3.1.0) but 3.0.3 is to be installed
Depends: piaware-web (= 3.1.0) but 3.0.3 is to be installed
Depends: socat but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
pi@piaware:$

Do an apt-get update and try again. You have piaware-release 3.1.0 installed, but the repository data you have is older.


#10

dump1090-fa is not started by piaware.


#11

Obj:
Rerun the command: sudo apt-get update
Then
Run the command
sudo apt-get install dump1090-fa
with same error as reported.

Do I use :
sudo apt-get -f install ?

I used the stat page to load all, so no way to ctrl-D it

Regards

Alex


#12

I suspect that your Pi has reset mid-upgrade which has corrupted things.

The simplest fix if you don’t have anything you need to preserve on the sdcard is to start again from a fresh PiAware 3.1.0 sdcard image.
Failing that, I suggest you restore from a backup and try the upgrade again.

If neither of those are possible then it gets trickier as it’s not obvious exactly what state your system is in. You could try removing /etc/apt/sources.list.d/piaware.list and then triggering an upgrade via the stats page.


#13

Thank you for the answer. I will do that when I get over there (500 miles) to Kino Bay Mexico from Phoenix.
Site is working now for our MLAT Baja project so I will be patient.

“Patience, young grasshopper”

Thanks Obj

Alex


#14

dump1090.sh from? i.e. what did you have installed previously?

The ancien, previous procedure. I had for a long time a Dump1090.sh in /etc/init.d which I have modified several times to adjust some parameters.

The Installation of Dump1090-fa renamed it dump1090-fa.sh. But I have seen that stopping it did not stop the data flow. Moreover, a look into the Piaware3 on a SD card image I have downloaded and prepared “in case of” showed that dump1090(-fa).sh was not used in /etc/init.d.

I have deleted mine : first the http server works, second, dump1090-fa work too.

:slight_smile:


#15

Ok, if it was an unpackaged dump1090 then the new dump1090 package is unaware of it so you do need to disable the old one manually in that case. Good that you got it going in the end.


#16

This a baffling situation: 3.1.0 is running remotely. All is fine uploading data to FA. Howvere I cannot get the map. Previously I had port forwarding issues due to 8080 redirects etc. Now I have port 80 on the router forwarded to port 80 on the Pi. My remote browser is connecting to port 80 but I get a Lighttpd welcome screen.


Placeholder page
The owner of this web site has not put up any web pages yet. Please come back later.
You should replace this page with your own web pages as soon as possible.
Unless you changed its configuration, your new server is configured as follows:

Configuration files can be found in /etc/lighttpd. Please read /etc/lighttpd/conf-available/README file.
The DocumentRoot, which is the directory under which all your HTML files should exist, is set to /var/www.
CGI scripts are looked for in /usr/lib/cgi-bin, which is where Debian packages will place their scripts. You can enable cgi module by using command "lighty-enable-mod cgi".
Log files are placed in /var/log/lighttpd, and will be rotated weekly. The frequency of rotation can be easily changed by editing /etc/logrotate.d/lighttpd.
The default directory index is index.html, meaning that requests for a directory /foo/bar/ will give the contents of the file /var/www/foo/bar/index.html if it exists (assuming that /var/www is your DocumentRoot).
You can enable user directories by using command "lighty-enable-mod userdir"

I am stumped. Upgraded all and rebooted. Joe K4AA

About this page

This is a placeholder page installed by the Debian release of the Lighttpd server package.

This computer has installed the Debian GNU/Linux operating system, but it has nothing to do with the Debian Project. Please do not contact the Debian Project about it.

If you find a bug in this Lighttpd package, or in Lighttpd itself, please file a bug report on it. Instructions on doing this, and the list of known bugs of this package, can be found in the Debian Bug Tracking System.

Valid XHTML 1.0 Transitional


#17

The web page is on the port 8080.
Port 80 is the lighttp welcome screen, yes.

Now I have port 80 on the router forwarded to port 8080 on the Pi.

J-Luc F1JEK


#18

If you are running a sdcard image (imaged with 3.0 or later, not an upgrade from a piaware 2 image), there should be a piaware status page there, not the lighttpd placeholder screen.

If you are not running that, then you will need to navigate to the actual map page: ](http://)/dump1090-fa/

The dump1090-fa package does not take over the top level landing page because it might be installed as a package on a system that has other things there. Only the sdcard install takes over the top-level page.

nb. piaware 3.1.0 replaced the redirect on port 8080 with directly serving the map data, since it seemed to be a common problem for people to have a port 8080 forwarding rule (even though that was a terrible idea with the old version) that stopped working. So with 3.1.0 you may be able to go back to just forwarding 8080 if it is easier.


#19

What you described is what I got when I upgraded to Piaware 3.1.0 by following 2 methods:
(1) Upgrade of Piawsre 3.0.4 img (SD card) using my stats page and “Send command to device” and command “Upgrade Piaware and restart”
(2) Burned Piaware 3.1.0 img (SD card) on a formatted blank microSD card.

Both gave following:

(A) http://IP takes to “PiAware info” page
(B) http://IP:8080 takes to map page
© http://IP/dump1090-fa/ also takes to map page
(D) http://IP/dump1090-fa/index.html also takes to map page

I then installed web portal using JP’s method, but with a install.sh file modified by me (I removed code lines for building package/installation of dump1090-mutability v1.15~dev, and Piaware data feeder add-on, as dump1090-fa and piaware data feeder were already available on the image).

After installation of web portal, following is the situation:

(A) http://IP takes to web portal’s Blog page
(B) http://IP/index.html takes to “PiAware info” page
© http://IP:8080 takes to a map page but no planes and yellow box “Problem fetching data from dump1090”
(D) http://IP/dump1090-fa/ takes to map page with planes.
(E) http://IP/graphs.php takes to Performance Graphs page.


#20

OBJ: I still cannot get a web page out of my Avalon, NJ site. I’ve done every combination of restart, update and reboot. I’m here in Florida.
My last trick was to have someone who controls my remote router to set up a VPN for me. So now I can connect directly to the Pi without port forwarding. I get nothing on 80 or 8080.
Data is streaming nicely at 30005. The Pi is uploading nicely to FA. I can get in ssh on 22 and execute any command.

What could possibly be the problem?? Joe K4AA