Cant display map from outside local network


#1

Thanks to Oliver for getting me up and running. Now, I cant display the map from anywhere outside my LAN. I have 8080 opened on my router, I enter the external IP plus :8080 and it converts it to XX.XX.XXX.XX/dump1090-fa . The page turns pink and it gives a 400 error calling out illegal file name. Apparently something doesn’t like that hyphen in there? Has anyone ran into this and any ideas?/ Thanks


#2

The map is actually served on port 80 (the default port) now, so you will need to forward port 80.
(You can forward it as some other port number if you like, e.g. connections to external IP port 12345 are forwarded to piaware-host port 80)

Port 8080 itself just redirects your browser to port 80 now.


#3

Just to try, I temporarily port-forwarded port 80 for my RPi, and I can see the map from outside my LAN.

If I type ](http://), the page opened is web portal’s "blog.php"
If I type ](http://)/dump1090-fa, the page opened is map (/dump1090-fa/index.html).

Here is my Piaware 3.0.3 map page on my phone using phone’s 4G data network (Phone’s WiFi was switched OFF):


#4

Ok, I’m able to see my RPi and the maps from outside the local network now. i’m still not 100% sure, but I think there was some conflict between my router’s remote management port and the rpi’s. I turned off the router’s remote management capability and I can now see my maps. Thanks for the help!


#5

Hello:

Lets see if I could get some advice;

When I try internalIP/dump1090-fa/ and it loads the map just fine

But from outside:

internetIP/dump1090-fa/ and gives an error “page not found”

                           External Port    Internal Port   Prtocol

I forward InternalIP 8080 8080 Both
Also tried:

I forward InternalIP 8080 80 Both

Same result.

I am using piaware 3 latest release .4.

*************UPDATE: *********************************************
Did a port forward 1234 to 80 AND IT WORKS with internetportIP:1234

See my Scottsdale AZ site on micasita.homeip.net:1234

For whatever reason 8080 to 80 will not work


Problem solved.

Thanks

Alex


#6

Alex try just opening up external port 80.


#7

Alex, it must be working pretty good- I can see your map all the way from St. Louis! :slight_smile: but you better be careful about publishing the address of your rpi, there was recently something in the forums about not letting our data go anywhere else besides flightaware because our rpi’s can see flights that are blocked on FlightAware. Someone could intercept and publish your feed (aggregate, I believe it was) We don’t want to get our hobby locked down or restricted…


#8

I originally used port forwarding but found a better solution for me was to set up a basic PPTP VPN and use it to hop onto my local network. I use duckdns for dynamic ip resolution back to my network.


#9

Thank your for the comments. The external feed is now closed.

Alex