Cannot access live view


#1

Hey all, I’m just getting back into computing after being out of it for many years and decided to start with this build using the 3 B+. Initially I went through and everything was great for a day but then I couldn’t access live view on port 8080 or 80. After fighting for a while I gave up and reformatted thinking I might have messed up some where. This time I did a full raspian then dump1090 and then PiAware. Again I can’t access the live view on 8080, 80 or dump1090.

FlightAware is reciving my packets so I know it’s up and running but I’m thinking it might be a networking thing. I’m currently using the Norton Core, which I had to change the DNS to start with because their DNS wouldn’t let me update. And also using my network analyzer it’s showing my pi is not pingable. Does anyone have any suggestions because I am lost. Any help will be greatly appreciated


#2

@hcisdch

  1. Do you see lighttpd Placeholder page at following address (no port number)?
    ip-of-pi

  2. Try ip-of-pi/dump1090-fa/


#3

I must be missing a command, both show command not found


#4

These are not commands. These are the addresses you have to type in your browser’s address bar to see the map. You have to replace the ip-of-pi by your Pi’s local IP which is something like 192.168.0.21. You can find it by giving command ifconfig in terminal console of Pi or SSH.


#5

Go it,
So just my ip is giving me this

dump1090 and dump1090-fa give me a 404


#6

Good, you get Placeholder page at IP of Pi.

sudo lighty-enable-mod dump1090-fa

sudo reboot

After reboot, check map at
172.16.4.2/dump1090-fa/


#7

It stated it was already enabled.
After the reboot I got “the server is not responding”

And just to clarify I’m using the dump1090 from github if that makes a difference at all.


#8

Which version of dump1090?
At least following 5 versions of dump1090 are available on GitHub (there may be more).

dump1090 (Antrez)
dump1090 (Malcom Robb)
dump1090-mutability v1.14
dump1090-mutability v1.15~dev
dump1090-fa


#9

dump1090-mutability v1.15 dev


#10

Ahaaaa…

sudo lighty-enable-mod dump1090-mutability

sudo reboot 

After reboot, check map at
172.16.4.2/dump1090/gmap.html


#11

Dump1090-mutability
Gave me “ignoring unknown module”
So I also ran just dump1090” and got service already enabled

After the reboot it still says server not responding. That’s why I have been thinking more on the router side, seems as if everything installed correctly.


#12

That goes to show that dump1090-mutability is NOT installed.

Please give following command and post output:

apt-cache policy dump1090-mutability

#13

Installed: 1.15~dev
Candidate: 1.15~dev
Version Table:
*** 1.15~dev 100
100 /var/lib/spigot/status


#14

If dump1090-mutability is installed, then lighttpd should not say ignoring unknown module.

Are you sure you cloned the source from mutability fork? Following is the correct command to clone the dump1090-mutability v1.15~dev

sudo git clone https://github.com/mutability/dump1090.git


#15

Tell you what, let me go back an start it over again. I’ll report back after I do that. Maybe I’m missing a step somewhere. Then I’ll know for sure if I have missed something or not.


#16

Step by Step Method to Install Stretch Lite image + dump1090-mutability

(1) Download Stretch Lite image and write the image to microSD Card

(2) Install dump1090-mutability v1.15~dev

Below is a step-by-step method to built & install dump1090-mutability_1.15~dev from source code.

STEP-1: UPDATE THE OPERATING SYSTEM

sudo apt-get update

.
STEP-2: INSTALL PRE REQUISIT PACKAGES
(needed to build, and needed to fulfill dependencies)

sudo apt-get install -y git
sudo apt-get install -y build-essential
sudo apt-get install -y debhelper
sudo apt-get install -y rtl-sdr
sudo apt-get install -y librtlsdr-dev
sudo apt-get install -y libusb-1.0-0-dev
sudo apt-get install -y pkg-config
sudo apt-get install -y fakeroot
sudo apt-get install -y curl
sudo apt-get install -y cron
sudo apt-get install -y lighttpd

.
STEP-3: DOWNLOAD / CLONE THE SOURCE FILES TO YOUR RPi

cd ~/
sudo mkdir install-dump
cd install-dump
sudo git clone https://github.com/mutability/dump1090.git

.
STEP-4: BUILD THE DUMP1090-MUTABILITY PACKAGE
Note: This is a lengthy process, and seems to freez at several occasions. Please be patient, and let the process take it’s time to finish.

cd ~/install-dump/dump1090
sudo dpkg-buildpackage -b

.
STEP-5: INSTALL THE DUMP1090-MUTABILITY PACKAGE

cd ~/install-dump
sudo dpkg -i dump1090-mutability_1.15~dev_*.deb

.
STEP-6: CONFIGURE THE WEB SERVER

sudo lighty-enable-mod dump1090
sudo systemctl force-reload lighttpd

.
STEP-7: DUMP1090-MUTABILITY POST INSTALLATION CONFIGURATION

sudo dpkg-reconfigure dump1090-mutability

.
For most settings, accept default settings by pressing “Enter”.
For following settings, enter values as shown:
(a) RTL-SDR dongle to use: 0
(b) Your receiver’s Latitude (in decimal format): xx.xxxx
© Your receiver’s Longitude (in decimal format): yy.yyyy
(d) Interface address to bind to (blank for all interfaces): remove default 127.0.0.1 and leave blank.

For advance users:Alternatively, you can change the settings by editing the configuration file shown below:

sudo nano /etc/default/dump1090-mutability
#after making changes, save file and exit 
#restart dump1090-mutability
sudo systemctl restart dump1090-mutability

.


#17

I went through and made sure I have installed everything and configured it. No errors on the installs, but I still seem to be locked out. It’s still reporting to FlightAware, but still getting no server respons when using 80, 8080, and dump1090


#18

But you do get lighttpd server’s Placeholder Page which shows the Server is OK.


#19

I do, but for somebody reason everything else seems to be blocked.


#20

Check this file
sudo nano /etc/lighttpd/conf-enabled/89-dump1090.conf

It should be like Screenshot below:
conf