Skyview inop


#1

Hey gang. Got everything set up today and working flawlessly, except skyview. To me that’s one of the coolest features of this. So everything works perfectly fine, flashed the SD card with the latest software and set it all up this morning. But no skyview. Not when I click the link from my page. Not from the link in the email they sent. Not when I manually type in the IP address and it doesn’t matter if it’s :8080 or /dump1090-fa/ - nothing works. Mac - safari and google chrome. PC - Firefox. iPad and iPhone with Safari, no go on all of them. Yes they’re all on the same network. On my ads-b page I can see the logs and see “message recvd dump1090” and my status is green across the board, so I’m confident that’s all working. I figure it’s either a network thing or…I dunno. I just get a server not responding message in my web browser.

I read some of the other posts on here but honestly that stuff is way over my head. It’s the 3.5.0 software straight off the site. Only change I made to the code was to name an SSID and password for wifi (it’s a pi 3), no other changes, I wouldn’t know how anyway.

Anyone have any ideas? I read they sometimes it just doesn’t work with this new update so maybe that’s the problem? It’s on FlightAware’s end? I emailed support and went back and forth a few emails sharing info and then the shift must have ended or I stumped the chump cuz I have heard back in hours. Thoughts? Thanks!


#2

Do you get any response, like a “not found” or anything similar? You tried just the IP address and nothing else, right? yourPiIPaddress??


#3

Maybe lighttpd or dump1090-fa is not running for some reason. Reboot the Pi to start these.

If you can SSH, then you may also check their status in SSH console.



sudo systemctl status lighttpd
sudo systemctl status dump1090-fa


To restart



sudo systemctl restart lighttpd
sudo systemctl restart dump1090-fa



#4

Same every time - Safari can’t open this page. Safari can’t open 192.xxx.xxx.x:8080 because the server where this page is located is not responding. If I change it from “:8080” to “/dump1090-fa/” the browser takes me to search results for what’s typed in the address bar.

I unplugged it and moved it this morning, fired right up, still no skyview. I sent a restart dump1090 earlier with no effect. Just did a straight reboot from the control panel, no change. Same server not found error. If it helps, here’s the log info for the reboot -

[2017-07-18 20:27 CDT] manual update (user-initiated via their flightaware control page) requested by adept server
[2017-07-18 20:27 CDT] performing manual update, action: reboot
[2017-07-18 20:27 CDT] rebooting…
[2017-07-18 20:27 CDT] update request complete
[2017-07-18 20:27 CDT] piaware (process 520) is shutting down because it received a shutdown signal (SIGTERM) from the system…
[2017-07-18 20:27 CDT] faup1090 exited with SIG SIGHUP
[2017-07-18 20:27 CDT] multilateration data no longer required, disabling mlat client
[2017-07-18 20:27 CDT] fa-mlat-client exited with SIG SIGTERM
[2017-07-18 20:27 CDT] piaware (process 520) is exiting…
[2017-07-18 20:28 CDT] ====== successful login from piaware 3.5.0 from 47.185.105.141 ======
[2017-07-18 20:28 CDT] adept reported location: 32.93917, -97.26520, 723ft AMSL
[2017-07-18 20:28 CDT] logged in to FlightAware as user nameredacted
[2017-07-18 20:28 CDT] my feeder ID is 56e39281-e722-493f-86ee-ea37f05b914f
[2017-07-18 20:28 CDT] site statistics URL: flightaware.com/adsb/stats/user … tats-60993
[2017-07-18 20:28 CDT] multilateration data requested
[2017-07-18 20:28 CDT] Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport 70.42.6.224:5288:2470855137
[2017-07-18 20:28 CDT] mlat-client(767): fa-mlat-client 0.2.9 starting up
[2017-07-18 20:28 CDT] mlat-client(767): Using UDP transport to 70.42.6.224 port 5288
[2017-07-18 20:28 CDT] mlat-client(767): Listening for Beast-format results connection on port 30105
[2017-07-18 20:28 CDT] mlat-client(767): Listening for Extended Basestation-format results connection on port 30106
[2017-07-18 20:28 CDT] mlat-client(767): Input connected to localhost:30005
[2017-07-18 20:28 CDT] mlat-client(767): Input format changed to BEAST, 12MHz clock
[2017-07-18 20:28 CDT] mlat-client(767): Beast-format results connection with 127.0.0.1:30104: connection established

And I’m still seeing logs like this - [2017-07-18 20:33 CDT] 139 msgs recv’d from dump1090-fa (127 in last 5m); 120 msgs sent to FlightAware So I think it’s working.

I haven’t figured out SSH yet, I have no way to access the RPi unless I pull the micro sd card and put it in my Mac. No clue how to remotely access it. Also no idea what lighttpd is. I read the SSH stuff online, can’t make heads or tails of it. But thanks for helping out!


#5

I’ve tried just the straight IP address and the addres with the 8080 attached or clicked the link, no luck. Even just the ip address give me the server not responding error.


#6

Maybe your access point / router is isolating wireless clients from each other?


#7

No clue how I would sort that out, or even how to verify it. I can access the router with its IP address and admin login/password and see all that stuff and all device connected. Have to do a google for isolating wireless clients and see if I can learn something. Thanks for the tip.

Edit - just cruised through the router settings, can’t find isolation listed anywhere.

I did create a guest network just for the RPi. I thought maybe that was the problem but if I switch any of my computers over the guest SSID it still doesn’t work. My regualr SSID has dashes in the name and I couldn’t get the RPi to connect wirelessly with that SSID, I guess the config file doesn’t like characters. There’s a way around that with quotes and slashes or something, I couldn’t understand, so I created another SSID with no special characters. Again, connect my computer the same wifi as the RPi and get the same error, server not responding.


#8

First you have to enable SSH in your Pi. To do this, read item (5) here post206001.html#p206001

Next in your Mac, open Terminal and type:

ssh pi@[ip of pi]

OR

ssh pi@piaware

and press enter key. You will be asked to type the password for pi, and then the terminal will login to Pi and ready to type in or copy-paste commands.


#9

Sorry in advance. I saw that, “right click in boot folder…” and add the ssh file there. Yeah, you lost me.

I’m leaning towards the guest network I created being the problem right now. Yeah, I wanna get SSH working, but no clue there yet. I swapped my Mac over to the guest network and I’m online no problem but can no longer connect to the router using the IP address. I cannot find a way to remove wireless isolation or IGMP or any other setting on the router, so now I need to figure out how to get the quotes and slashes to work and change the SSID on the RPi to my main one I use.

update - I added a text file to the sd card, ssh.txt. I changed the router setting to the 2.4GHz setting, SSID and password, but it’s not getting online now. I put the SSID in quotes, I think that’s all I had to do. Working on it!

Update - pulled the sd card again to check my wifi settings, got them all correct, but it’s not working/not online now. Also, the empty ssh file I added to the sd card vanished. I’m going to get the file from FlightAware again, change the wifi setting on that and then reflash the card, see if that will get me online again.


#10

That’s your problem. The “guest account” is intended to allow internet access to your ‘guest’ (RPi in this case), but isolate it from other devices on your network.
You need to get it onto your regular SSID or plug a UTP cable between the Pi and the router.

ian


#11

Working on it now. I changed the SSID to my regular one but it wouldn’t get online. So I changed the SSID and I’m reflashing the card now. Not a guest network, 2.4GHz side of the router full blown network access. Fingers crossed, card just finished flashing.


#12

Success!!

It did create a new IP address because of the network change so now I have two sites, but one will be dead forever I guess. But skyview popped right up! Need to set up the “new” site for MLAT to work.

Thanks for your help everyone. Much easier to trouble shoot when I got folks to bounce info off of.

Oh yeah - I got the SSH to work but…in terminal when it asks me for my password it says it’s not correct. I thought the default password was “raspberry” but that’s not working and I can’t find another default for the piawre software. Anyone? Bueller? Bueller?


#13

For Piaware image, the default user name is pi and default password is flightaware


#14

Woohoo! Got it, thank you!

Wifi works. Skyview works. SSH works.


#15

Great! So now you know how to create file named ssh in /boot partition, when the microSD card is plugged into your Mac laptop/desktop.


#16

I looked up changing back to the old station ID to keep stats but it was only running a day so no big deal.


#17

Yes, it had instructions for Windows only, and lacked instructions for Mac.
I have now updated item (5) (a). Now it includes instructions for Mac as well.
Please click here to see: post206001.html#p206001


#18

Ah yup, that woulda been easier to follow. Funny thing is I just created a .txt file named SSH.txt and dragged it into the pi aware image folder and it worked too. Though I did this BEFORE flashing the card, so that may have made a difference.