Aircraft Registration Database Lookup not working?

Did the lookup from dump1090-mutability stop working for everyone, or is it just me?

It stopped working for me recently. Takes me to the website but not the A/C.
Not sure if it is Joe’s web page or dump-mut.
(I use Joe’s scripts).

I played around a bit and it looks like the call from dump1090-mutability isn’t being supported at this time because I can enter the ICAO24 address followed by submit and get results, but I get “No data found on this query” when using the link in dump1090.


Me three. It’s usually my first detective step when I see an unknown plane.

same here. Something must have changed on the airframes side recently. I took a look at the gmap.html code, but I’m not smart enough to figure out how the call to airframes is suppose to work.

Maybe is now blocking posted data from outside their site now?

Look at the link
It doesn’t include the hex address any more.

Right it appears expects the ICAO to be POSTed.
This is the reason I am thinking that might be blocking POST requests or changed how it works from external sites.

In the file dump1090/public_html/gmap.html you can see the value for ica024 among other empty values are posted to to display the requested page.

36 		<form id="airframes_post" method="POST" action="" target="_blank" class="hidden"> 
37 			<input type="hidden" name="reg1" value=""> 
38 			<input type="hidden" name="selcal" value=""> 
39 			<input id="airframes_post_icao" type="hidden" name="ica024" value=""> 
40 			<input type="hidden" name="submit" value="submit"> 
41 		</form> 

Why would block requests is beyond me. I am guessing they simply changed the way things are requested.


Looking at their form I do not see any missing data which dump1090-mutability is not already posting leading me to belive they are blocking external POST requests?

  <form method="post" action="/">
      <legend> Aircraft database &nbsp; </legend>
      <table width="100%" class="no">
        <tr><td class="no">Registration:   </td><td class="no"><input type="text" name="reg1" value=""> </td><td class="no small">[e.g. D-AIHA or daiha]</td><td class="no" rowspan="4">&nbsp;</td>
          <td class="no" align="right" width="10%" rowspan="4">
 &nbsp; </td></tr>        
        <tr><td class="no">Selcal:         </td><td class="no"><input type="Text" name="selcal" value=""> </td><td class="no small">[e.g. AE-KQ or aekq]</td></tr>
        <tr><td class="no">ICAO24 address: </td><td class="no"><input type="Text" name="ica024" value=""> </td><td class="no small">[Mode-S address, default hex, or <input type="radio" name="t" value ="D">dec <input type="radio" name="t" value ="O">oct <input type="radio" name="t" value ="B">bin]</td></tr>
        <tr><td class="no">&nbsp;          </td><td class="no"><input type="submit" name="submit" value="submit"> <input type="reset" name="reset" value="reset"> &nbsp; </td><td class="no small">... <a href="/nobots.php">no bots</a> ... &nbsp; </td></tr>

That would be a bummer if in fact this is the case…

Today… it works! Although I was playing with gmap.html a few days ago, when i couldn’t fix the problem, I believe I reverted to the stock version. Perhaps someone else could try it and let me know if it works for them now too.

I can confirm it just worked for me.


I have send them an email zesterdaz and thez told me that blocking the requests from our dump sites was not their intention… Seems like thz fixed it verz fast…

It breaks for me if my browser is set up to drop referer info (e.g. blocking 3rd party referers will do this); otherwise it is fine.