Yet another MLAT problem

Hi – had a working setup for about a month, but then I needed to reinstall Ubuntu and set up my machine again.
Now everything works except for MLAT.
The main web interface status page has green for everything (1090 radio, piaware, flight aware) and yellow for MLAT (no clock sync with nearby receivers)

When I go to my personal flight aware stats page, all blocks are green, including MLAT, and MLAT shows “Multilateration (MLAT): Supported / Enabled” but not the usual connection to 130+ receivers.
Personal stats page- Eric Rickin ADS-B Feeder Statistics - FlightAware

I didn’t change anything with the setup.

I did move the antenna on the previous setup, and at that time I didn’t change the GPS coordinates or the height on flightaware, yet mlat still worked. I basically removed the receiver 50 feet.

So I went in and tweaked the receiver coordinates and height (they were only off by a tiny amount, the 5th place after the decimal) and it still doesn’t sync MLAT. I got very granular and found the exact spot outside it is and used a gps coordinates program on the web. I even got a tape measure and measured height off the ground.

Does this just take time or should it be synced by now? (30 min since coordinates were changed).

Bottom line-
Old copy of ubuntu, antenna in basement - MLAT worked
old copy of ubuntu, moved antenna outside and didn’t change coordinates - MLAT worked
new copy of ubuntu, antenna still outside, using same coordinates - MLAT not working
new copy of ubuntu, antenna still outside, tweaked coordinates - MLAT still not working


It takes time. Sync stats are updated every 5 minutes.
Wait for an hour or 2, then it will have reconnected to other MLAT sync sources is my expectation.

1 Like

thanks. whenever I rebooted the old server mlat connected immediately. I was thinking it would be the same.

after I changed the coordinates it turned the MLAT box red and now says lat/long not set even though it is. I guess it needs to work out the kinks.

just let it settle for a while and check your logs to see if there are any errors reported.

1 Like

If it’s a new install of the OS, are you sure that the time zone and time of day are set correctly?

good thought. I’ll check that. the time is correct but i’ll check the time zone.

you seem to be synchronized again :wink: It displays 135 adjecent sites at the moment.

Actually, I gave up, I put the old hard drive back into the Linux box and change the coordinates and altitude back to where it was before and after 5 minutes it synced. I’ll have more time this coming up weekend to play with the new setup and see if I can get the MLAT to sync. I’m thinking since Emily works with these coordinates and altitude I will just start FlightAware when I put in the new hard drive and just let it sink for an hour or two instead of monkeying with the coordinates.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.