WiFi issue when rebooting Router

Hi All

I have been having a issue all week with my Wi-Fi and once again learning as we go !!!

I discovered that when my Wi-Fi reboots my Rpi 4 running piaware 7.2 image doesn’t reconnect to my Wi-Fi !

I have learnt and set up a Static IP address but still when I reboot my Wi-Fi it struggles to find the pi.

Any help please as pulling my hair out.


you might want to have a look at this

it wil restart the networking service on the Pi and it will then try to reconnect to the router without rebooting the Pi.

1 Like

The other way round. The Pi struggles to find the Router. :slight_smile:

Do you by chance used mixed WiFi 2.4GHz/5GHz using the same SSID?
Sometimes this is causing problems. Also special characters in the SSID password can be a reason.

Setting up a static IP wont help. You can simply configure the router that it always assign the same IP to the Pi which ends up in the same result.

1 Like

Hi Foxhunter

Yes I have a Dual band router but with separate SSID

There is a comma mark in my password yes but not in the SSID

I am also running another Rpi with Weather Station software that always links straight back to the Wi-Fi if the router is rebooted instantly no issues !

I think I may have found the issue but haven’t had time to address it yet , I currently have the Rpi 4 on ethernet using a wireless Wi-Fi extender as was the only way i could get it connected again.

I found the MAC address is one digit out on wireless than on ethernet ie b4 and b5 at the end of the address.

I think i need to alter the Rpi wireless MAC address to the correct one when trying to connect to the static IP address on Wi-Fi

Any Thoughts if that sounds a valid reason for the issue ?


Yep that might be the cause indeed.

1 Like

You could also try to disable the Raspberries Ethernet if not needed.
Maybe the automatic switch is not working properly.

1 Like

Are you sure it is incorrect?
The RJ45 and WiFi do have different MAC addresses.


Hi all

I’m still having a problem but found out I had my Router set in the wrong mode, I’ve got that fixed but now I cant set a static IP address. I use my broadband supplied Router with its Wi-Fi disabled then I run my own Wi-Fi Router in access point mode via ethernet.

What Baffles me is if I reboot my router piaware always ends up on a new IP address which is frustrating as then need to find it and reset all my bookmarks, Putty and VRS to the new IP address

Yet my other Rpi running a weather software program doesn’t !! It always on same IP address

Can I put a line in the config file ie Force-IPaddress 192.168.0.** ?


I’m trying to get this bullet proof for our winter period if we get any power interruptions

Does this router have a DHCP server enabled?

1 Like

Hi @SweetPea11

Yes it is enabled

you could set a DHCP reservation that is setting the same IP adress to the MAC address of the Raspberry Pi.

Depending on the make and model of the router there should be documentation on that.

1 Like

Does this mean you have two DHCP servers on the same network?

it says its enabled on my router Netgear but I can only add ip address’s on my broadband router !

Does that make sense ? my netgear is in access mode

You should never have two DHCP servers.
Disable DHCP on the netgear if your router already is doing DHCP.

1 Like

I think my Netgear is disabled for DCHP as I have no access to reserve IP address in any setting.

See the screen shot as I’m lost with this. I have reserved the piaware ip address on my other router which does have DCHP enabled but is my Netgear saying on because of that fact? I’ve been through every setting on the Netgear and there is no option to disable DCHP or add static or reserve IP address.

Netgear seems it has a DHCP client on, that’s fine.
Just no two servers :slight_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.