FlightAware Discussions

Wi-FI sleep mode?

Hello,

Looking for some help in fixing a Raspberry Pi4 Wi-Fi problem

If loose the Wi-Fi link through rebooting the router, I lose connection to the Pi4 and the only way to reconnect is to connect via the ethernet port and reboot the Pi to re-establish the connection. DHCP is static

I have found some topics stating that Wi-Fi goes into a sleep mode but the links all seam to be old and not sure if they are still relevant or why this has only started to happen to my installation.

Running Raspberry Pi4 with latest Raspberry OS with all the software latest updates and current boot rom image…

Found this but very nervous in running the command without fully understanding the command
$ iw dev wlan0 get power_save
$ sudo iwconfig wlan0 power off

I’d advise you to look at these steps

The commands are still valid, also for the last version of Raspbian Buster.
Due to the weakness of the on board Wi-Fi you can do 2 things to improve it.

  • Add an external antenna to the Pi to increase range
  • Use the Ethernet port instead of the Wi-Fi ( if possible) since the Ethernetport doesn’t drop any signal.

Thanks @tomvdhorst
its not down to signal strength have all bars shown and is rock solid only see the problem if i take the router down…

I found that article but was looking at the Nov 2017 date as being a long while ago and things moving on so did question its relevance

Power save is on !!!

1 Like

I would turn the Power save off as described, that would sort the issue from the Pi side, since you already have a static IP how is that related in the router ? Combination of MAC adress and IP adress ?
Or did you set a DHCP reservation for it ?
Usually the 2nd option is tending to be more effective when rebooting the router.

I had a similar issue with one of my Raspberry 4B and was reading a lot about it.
Even with powermode = off, i was not able to fix the problem.

A second Raspberry 4B did not show this behavior after exchanging it.

With the faulty device i was helping myself with a little script pinging the router (or any Internet Adress) every five minutes. If no response, reboot the device.

Not a solution, but for me an acceptable workaround.

Thanks @tomvdhorst
Yes DHCP reservation set in the router and Pi

Been working over a year but taken all that time to tie the two events together

1 Like

That’s the reason I run wired connections to all of my Raspberry’s. I don’t need the Wi-Fi but that’s just my setup, others might not be able to get cabling to their equipment.
Friend of mine had the same issue, it was solved by adding an additional Wi-fi signal repeater close to the Pi in order to get this sorted.

That is the problem with my location. One device is outdoor, wired network would require to drill holes in walls.

I have beside my router downstairs two repeaters upstairs. The WiFi connection is excellent but this this specific device it failed every now and then.

My two other Raspberries and the AirSquitter never showed that behavior, all are WiFi connected

In case the other stuff doesn’t help, try this:
Raspbian dropping off the network potential workaround · wiedehopf/adsb-wiki Wiki · GitHub

1 Like

What do you mean?
You just copy paste the entire thing … not hard.

I had this on one of my very first Pis. The way I got around it was a short script that I triggered via cron every minute. It pinged the router and if it failed, it just restarted the WiFi interface.

Something like this.

No that’s not what the file should look like.

You copy paste the entire box into the console … it writes it to the file.

Maybe you are correct and a shell script would be better … i just prefer this as it’s not yet another random shell script people execute without seeing it …

1 Like

I have something like that as well: pingfail · wiedehopf/adsb-scripts Wiki · GitHub