Wifi Help


#1

I have the PiAware image 3.1.0 on an SD card on a Raspberry Pi B+ with CanaKit Wifi

It works fine with RJ45. Wifi does not. I see an IP in my router for the wifi and the RJ45

I editied the Config.tx file with the SSID and Password.

Interestingly in the Router DHCP list. The RJ45 listing says PiAware and the Wifi says Raspberry.

Any ideas?

The wifi worked fine with 2.0.5.


#2

Can you check if your IP is the same assigned by your router to your wlan0 with command “sudo ifconfig” ?

Also check if there are any problems with wlan0 setup with command “cat /var/log/syslog | grep wlan0”?


#3

I had the same issue with my copy. I discovered that by default the wifi is turned
off, but I managed to get it turned on and working well.

There are several things I did to get it working, one was to configure wlan0 in
/etc/network/interfaces by adding the following lines:

=====================
allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Next, I edited the file /etc/rc.local and added three lines above the “exit” line,
which were:

=====================
cd /etc/network
cat interfaces.d/wlan >> interfaces
ifup wlan0

Lastly, I went into /etc/wpa_supplicant and created the wpa_supplicant.conf file,
adding in the following three lines:

=====================
country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

You may have to change the country code, if you aren’t in the US.

Now you are set to add in your network info by doing the following:

edit the wpa_supplicant.conf file by typing:
wpa_passphrase (your ssid) >> wpa_supplicant.conf [Enter]
(your matching password) [Enter]

Now edit the wpa_supplicant.conf file and between the ssid line and psk line add
the following 5 lines:

=====================
key_mgmt=WPA-PSK
scan_ssid=1
proto=RSN
pairwise= CCMP TKIP
group=CCMP TKIP

When you’re done, your wpa_supplicant.conf file should look something like this:

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

reading passphrase from stdin

network={
ssid="your_ssid"
key_mgmt=WPA-PSK
scan_ssid=1
proto=RSN
pairwise=CCMP TKIP
group=CCMP TKIP
#psk="XXXXXXXX"
psk=dd033e0860063d611b39e0f602e1c6d64ca95c9354c90e0ce0f85aea468104bc
}

Now, to bring the wifi online, type ifup wlan0 [Enter], and you should be good
to go

I hope this helps you with your wifi issue.


#4

That’s a very obtuse approach. The image has support for wifi directly; either use that, or start from a Raspbian image and configure it however you want.

Did you try configuring wifi through piaware-config.txt? If so, what failed?


#5

No, I was already working with raspian, and just applied what I was doing in the original image to the piaware image. The only difference is that I had to come up with a way to auto correct for the fact that the piaware image automatically rewrites the interfaces file, and removes the info needed to bring up wlan0 on a reboot.

I have an image that I created that I am willing to make FREELY available to anyone that wants it. All they have to do is to run the wpa_passphrase command, and give it the password that matches their ssid and then bring up their network with the ifup command.

I also checked by using the piaware-config.txt program and find that although you can set the wifi to dhcp, it will ONLY use a hard-coded address. I much prefer dhcp for my IP addresses. If I’m going to use the piaware-config program, and there is a setting, I think it should do what it says, ultimately I like my method better… more control for me.


#6

If you configure the PiAware image to use DHCP, it uses DHCP to acquire an IP address, there are no fixed addresses on the PiAware side, though your DHCP server may be configured to always hand out the same address for the same MAC. So I don’t understand the behaviour you describe. If you configure PiAware for DHCP and it does not use DHCP then that’s a bug and i’d like to understand what’s failing so I can fix it.