What worked for me to connect to my wifi

What I do now:
Download the latest image following the instructions in:
When done and before you remove the SD card from your system you may edit the configuration file piaware-config.txt using any text editor like notepad. With this method and the rights IP’s, after rPi boot, you now can access it via terminal (like Putty) from your main computer. No need to have HDMI monitor, keyboard or mouse on the rPi.
If not, start your rPi with the new SD with piaware3. (You need to have a HDMI monitor, keyboard on the rPi):
To edit on the raspberry go to the terminal and:
 sudo nano /boot/piaware-config.txt

Then no matter editing method you choose, for WiFi change this lines to your right IP’s

change this to “yes” to enable wifi

wireless-network yes <===============

Wifi SSID and password.

This should be changed to match your wireless

network SSID and, for networks that require

a passphrase, the passphrase.

wireless-ssid my_SSID_router <========================
wireless-password your_wifi_secretpass <=======================

Wifi network configuration:

Most networks will use DHCP

Alternatively, a static address configuration

can be provided; set “wireless-type” to static to use this.

wireless-address <================
wireless-broadcast <===================
wireless-gateway <======================

In the above case I selected static, but you can allow your router to provide the IP with
wireless-type dhcp

If you select static address be sure to pick an IP outside of the IP’s range reserved for DHCP. Connect to your router to see the DHCP IP range. You could also reserve (depending of your router) an IP in the range, but you need to reserve it for the rPi particular MAC address. This will avoid the router assigning you preferred IP to another device that connects before the rPi

Remember you can’t use the GUI interface to scan/connect WiFi as before with piaware 2, it will give you the error “dhcp not working” or something like that. Basically with piaware 3 you must use the terminal interface, in my case on initial boot it always went to the GUI. (I disabled that using the tool raspi-config, call it with >sudo raspi-config)

This is what is working for me while i upgrade my systems to ver. 3, and I hope it will help somebody not wasting a few hours of testing. Please if you think I did something wrong here please let me know. I am not a programmer just a wanna be.