FlightAware Discussions

Piaware 3.8.0 change ssid

after making the BIG mistake to NOT enter the correct wifi-codes…….
when swapping the sd-card from a normal raspi to raspi-zero-w i found it nearly impossible to change the ssid and the password for the wifi.
i finaly maneged by editing following file.

sudo nano /usr/lib/piaware_packages/fa_piaware_config.tcl

     and i changed following lines

{“wireless-ssid” -default “ssid-name”}
{“wireless-password” -protect 1 “wifi-password”}
{“wireless-country” -type country -default “NL”}
{“wired-nameservers” -default {1.1.1.1 8.8.4.4}}
{“wireless-nameservers” -default {1.1.1.1 8.8.4.4}}

i think there should be someway to do this without all this playing around searching
and to just edit some file in the “dos partition”
kind regards Joop raspi61@bozzuul.nl

You should just edit /boot/piaware-config.txt which is on the “dos partition”; there is no need to touch the .tcl file (and in fact your changes will be lost when piaware is updated). This, in particular for setting up wifi, is well documented (step 3 of https://flightaware.com/adsb/piaware/build); I’m not sure how we can make it any more obvious.

NOPE,

  1. piaware 3.8.0 is setup in a raspi that has NO wifi onboard just ethernet.
  2. than the sd-card is placed in a raspi-zero-w
  3. the boot section file : /boot/piaware-config.txt is correctly edited
  4. there is no wifi connection
  5. booting with an extra external wifi dongle on the raspi-zero-w
    then the wifi comes up with BOTH adapters working
  6. then rebooting after removing the extra wifi dongle everything works
    ??? (and this time without touching the tcl file) (o yes everything reproducible)

Without the actual config files you used, and logfiles, I can’t help here.

I just verified that I can boot a PiAware 3.8.0 sdcard image with builtin wifi configured on a 0W and the network comes up as expected.

(write image to sdcard; edit piaware-config.txt to set wireless-ssid and wireless-password; create /boot/ssh for ssh access; put sdcard in the 0W; that’s all)