FlightAware Discussions

Piaware Change of Wifi network

I changed my wireless router today and have a new ssid and password. I can’t seem to figure out how to change the ssid and password on my piaware. I plugged it into my tv and it keeps scrolling that it can’t connect to the network. It doesn’t let me type anything more than a letter before moving to the next line. sorry for such a noob question. i searched and couldn’t seem to find an answer. I’m running 2.1-5. Thank you for your help.

Ignore the output to your screen and keep typing your command. The command you type will work even if it is continued on another line when such output is displayed.
If you are running the FlightAware PiAware image your best bet to change the SSID and password would be to do so using the GUI by running the command


startx

If I remember correctly wpa_gui is installed on the image which makes setting up your wireless connection cake. Try opening a terminal window and running the command


sudo wpa_gui

If you get an error stating it is not installed you can install it using this command


sudo apt-get install wpagui

Once started wpa_gui makes things as easy as setting up wireless on a Windows box.
It even has WPS “Push a Button to Connect” support.

I appreciate the help but no luck. Still getting the

network connection down! Attempting reconnection.
Wpa_supplicant: wpa_action us managing ifup/if down state of wlan0
Wpa_supplicant:execute ‘if down --force wlan0’ to stop wpa_action
run-parts:/etc/network/if-pre-up.d/wpasupplicant exited with a return code 1
run-parts:/etc/network/if-up./wpasupplicant exited with return code 1

You can try going the manual route then.

running the command as stated in the error message may stop the messages.
(as stated before continue typing out the entire command and ignore the messages)


sudo if down --force wlan0

Open the file /etc/wpa_supplicant/wpa_supplicant.conf in your favorite editor.


sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Change the SSID and PSK to the password for your access point.
Depending on your new setup you may need to change other settings but most all access points use WPA now so you shouldn’t need to change anything else.

You should have something that looks like this when done…


ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="YOUR_SSID"
        psk="YOUR_PASSWORD"
        proto=WPA
        key_mgmt=WPA-PSK
        pairwise=TKIP
        auth_alg=OPEN
}

Reboot the machine when your done to make sure all the changes are put in place.