FlightAware Discussions

Updated to 6.1 now NO WiFI

My ranking started to drop recently and I wa still running 6.0 version of Piaware. I tried to update from the Flightware stats page and it kept running into an error so I. updated using apt.

I lost my WiFi when I did this. I’ve been working for 8 hours straight trying to get back on the air with my feed. About an hour in I downloaded a new 6.1 image and configured it in a normal manner. I used the Advanced options file and set up my WiFi networking using each command verbatim in the Piaware-config.txt file. Yet, the country gets written over to 00 every time even though I put the country entry in the config file. Also there are a number of other recommended lines in the wpa_supplicant.conf file that are overwritten and removed from the file when you boot up.

I’ve tried every trick I can find in this forum and others but I cannot get my WiFi up. I don’t have an ethernet cable back in the area where my antenna cable is located.

Please HELP me get this back on the air. I’ve tried everything.

Thanks!

73 de Dale - K0HYD

Hi,

This is what I can find about it in the forums
Starting with 3.8.0 on Buster, the piaware sdcard image uses the same config method as upstream Raspbian. All interfaces use /etc/dhcpcd.conf (including the static IP case). The wifi network details are configured in /etc/wpa_supplicant/wpa_supplicant.conf .

Everything else happens automatically - dhcpcd starts wpa_supplicant on specific interfaces when it sees them appear, wpa_supplicant manages the wifi association and link state of the interface, and dhcpcd does DHCP when it sees the interface link come up (or configures a static IP if told to do that)

So basic questions first:
Is Wi-Fi enabled by default ?
Are you using a dynamic or static IP ?
If static, is it set on the Pi or did you make a reservation for it in the router that controls your internet ?
what does the command ifconfig /all display ?

1 Like

That’s probably the wrong place to put it. It works only for SD installs, not for add-on installs… and you didn’t say what’s yours.
Check the:
sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Hi SoNic67!

Thanks for quick response. I need to get to bed but wanted to answer. I am using an SD-Card install. The image was freshly downloaded this evening. The note at the top of the spa_supplicant.conf file says that is will be overwritten on boot up. It is. There are a number of additional lines in the wpa_supplicant.conf file now that are removed by the contents of the /boot/piaware-config.txt file. One problem is the country entry. I need it to be US. But when the file is written over it always come out “00”. It also removes the update-config=1 and several other lines. I even tried to put a valid wpa_suspplicant.conf file in the location where it’s copied in /etc/wpa_supplicant directory. And also copied the valid file into the .bak and the .save files. It didn’t work.

When I check the ifconfig command I do not have an IP address for the wlan0 interface. The same thing happens with the hostname -I command. With this one I get an empty line.

I hope this answers you questions and look forward to any ideas you might have.

Thanks!

73 de Dale - K0HYD

Hi Tom!

Thanks for the fast response. I’ll try to answer your questions. Please see my answer to SoNic67 also. I believe WiFi is enabled. At least I entered all the ssd and password data in the file. I also used all off the wireless-xxxxx=yyyy info that the Flightaware advanced configuration document recommends.

I am using a static IP address.

I have it set on the pi but I believe I also have a reservation in my router. I’m going to check that first thing tomorrow (today).

The ifconfig command does not show the “net” entry. It’s not getting an address.

If I had a network at all I could copy some of these response right out of the rpi. The way it is I am dead in the water.

I look forward to any ideas you might have. I’m obviously missing something at a very basic label, or something else besides the wpa_supuplicant.conf file is being overwritten.

Thanks!

73 de Dale - K0HYd

You can only configure via the piaware-config option, everything else is disregarded.

If you want to use the normal config stuff like wpa_supplicant.conf, just start with Raspbian Lite instead of the piaware image: https://github.com/wiedehopf/adsb-wiki/wiki/Raspbian-Lite:-ADS-B-receiver

A common issue is people using a static IP address with a bad subnet mask / broadcast address. That would me my best guess for your situation.
Posting your config with the wifi password redacted is the best way to get help here on the forum.

1 Like

try these steps in order to set it up correctly.

Make sure you replace the IPadresses correctly.
Here’s an example

Sudo nano /etc/dhcpcd.conf

interface_wlan0
static ip_address=x.x.x.x/24
static router=y.y.y.y
static domain_name_servers=z.z.z.z

Where X= the ip address
Y= the Ip adress of the router
Z= the DNS server you want to use ( or multiple)

Oh and even without a network you can configure this, as long as you have a keyboard, mouse and monitor connected to it.

Are you in US? Because people are just waking up here now.
If not in US, the router might reject the US configured Wi-Fi connection.

Any of that won’t work on the piaware sd-card image …
At least you can’t expect it to work, network configuration should only be done via piaware-config on the image.

1 Like

Ah thanks, I never use the image only package addons on my installations.

I wanted to get this information to everyone who has responded. Here is the note I sent to adsbsupport just now. Plus my static settings in the piaware-config.txt file. I started over from scratch and installed a new image on the SD Card being especially careful to follow all directions.

Here are the settings for the static config

Should piaware use the wired ethernet port

for network access?

wired-network no

Should piaware use a wifi adaptor for network access?

If you are using a Pi 3, this will use the built-in wifi.

Otherwise, you will need to attach a supported USB wifi adaptor.

wireless-network yes

Wifi SSID and password.

This should be changed to match your wireless

network SSID and, for networks that require

a passphrase, the passphrase.

If your SSID or password contains characters other than

numbers and letters, such as the # character or whitespace,

you should enclose the value in quotation marks. For example,

“pass word” or “pass#word”.

To include quotation marks (") in a quoted value, use "

To include a backslash () in a quoted value, use \

Alternatively, a static address configuration

can be provided; set “wireless-type” to static to use this.

wireless-type static

Example from piaware-config file

wireless-address 192.168.1.10

wireless-netmask 255.255.255.0

wireless-broadcast 192.168.1.255

wireless-gateway 192.168.1.254

wireless-nameservers 8.8.8.8 8.8.4.4

wireless-country=US
wireless-ssid “K0HYD Net-5G”
wireless-address 192.168.1.221
wireless-netmask 255.255.255.0
wireless-broadcast 192.168.1.255
wireless-gateway 192.168.1.1
wireless-nameservers 8.8.8.8 8.8.4.4

I deleted the PSK line with my password.

Here is my note to adsbsupport:

Gentlemen/Ladies!

My stats were getting worse each day for the past week or so, so I decided to update the Piaware software.

I tried to do it from the dashboard not he web but your process was running into errors every time. So, I ran it in APT in Raspian Buster direct.

When I finished, my WiFi would no longer connect.

So, after fighting it for several hours, I decided to just start over with a new image. I followed the directions painstakingly and then took care of the advanced configuration options too since the image defaults to GB instead of US.

Since I don’t have a network, I can’t save piaware-config output to send you. I tried but I kept getting empty files.

I did save my piaware-config.txt file. It is attached.

When the static setup didn’t work, I even reverted the piaware-config.txt file back to dhcp wireless-type and this still didn’t work.

When I do a ifconfig there is NO “net” address displayed. Same when I do “hostname -I”. I get an empty line.

I would also like to know how I should have the Adaptive dynamic settings at the bottom of the file.

I need to get my unit back on the air soonest.

PLEASE HELP!

Thanks to all that have tried to help with this issue.

73 de Dale - K0HYD

styled quotes (some editors will do this automatically, use a text editor that doesn’t or turn off “smart quotes” or whatever the feature is called)
you need the non-fancy quotes (no diff between start and end quote)

"K0HYD Net-5G"

Alternatively use wifi names that don’t have spaces … so you don’t need quotes.

Thank you for the note sir! And thank you for all who have replied to my cry for help! I’M BACK ON THE AIR!!!

I use BBEdit which does put out plain text with plain quotes in the real file.

GOOD NEWS! I’m back on the air, several hundred positions in the site rankings lower. I made one last try just now and figured out the problem.

I had thought the RPi I was using (a 3B+, I thought) would service my 5G LAN. Evidently the unit I have is too old and only works on the 2.4 GHz network. I switched it as one final try before pulling my hair out and the network came up and it was talking to the Flightaware servers in a few seconds and MLAT was enabled and working.

If you do know the preferred setting for the new dynamic settings in Version 6 I would like to hear your thoughts.

Thanks you very much for your assistance and morale support!

73 de Dale - K0HYD

4 Likes

Ah, yes no 5 Ghz Wi-fi indeed.
That’s not in the chipset of a Pi 3
In order to enable the dynamic range feature you have to enable it ( I assume you have your old feeder id in use).

Command:

For Piaware SD Card image:

In file /boot/piaware-config.txt , add this line
adaptive-dynamic-range=yes

when you have it running evaluate it for a while to determine if you benefit from it. It will try to get the best gain for your enviroment and will check that every hour if adjustments are needed.

Sometimes a problem is so obvious once you know what it is, times I have done similar.

Glad it is going now.

Geoff