working 3.1.0 image with working wifi free for the taking


#1

I have configured a copy of the piaware-3.1.0 image with all the things needed to use wi-fi, except your wifi ssid and matching password. The image has already undergone an apt-get update and apt-get upgrade as of 10/3/16, so the O/S is up to date of of then.

All you need to do is to run the command:
sudo wpa_passphrase (your ssid) >> wpa_supplicant.conf [Enter]
(your ssid password) [Enter]
from within /etc/wpa_supplicant
and then run the command:
ifup wlan0 [Enter]

You can download the image from here: dl.dropboxusercontent.com/u/962 … g-wifi.img

Download the image, and burn it to an SD card (micro, of course), and then boot your pi, then run the commands above, and you should be all set.
If you have any questions, feel free to pm me.


#2

While I appreciate the sentiment, I think you’re fixing a problem that doesn’t exist. DHCP + wifi works fine here. If it’s not working for you, let’s identify why and fix the problem in the base image.

If you do continue to maintain the image, a few requests

  1. please modify the image_type configured by the piaware-support package so that we don’t confuse users of this image with users of the base image when PiAware checks in;
  2. please rebuild piaware-support with a version number suffix that indicates it is modified;
  3. please change the piaware-support default configuration to turn off autoupgrades
  • obviously FA can’t provide support for modified images beyond what’s available for the base packages.

#3

We have been posting messages here for days about the problems with WIFI and FlightAware has not responded. At least someone is trying to help us.

I have lost wifi capability since the first 3.0 images.

Please follow this forum and respond when we have problems.


#4

I do forum support in my spare time. If you want support from FlightAware customer support, mail adsbsupport@flightaware.com

Here you said you had wifi working with the PiAware images: post198555.html#p198555
Also here: post198583.html#p198583

What changed?

I notice that you have also been posting about wifi problems using the adsb-receiver image. Perhaps it is your hardware, not the images, that is the problem?

If you still can’t get it working, then if you can provide a clear description of what you configured (include exact config files) and what happened, then that’s a good starting point. But “it doesn’t work” is no good - I don’t have the same hardware as you, I can’t reproduce your problems here.


#5

I bothered to read the posts from “Charter Member” that referenced. I suggest you go back and re-read them yourself, because in them I see that he indicates in those posts that things are NOT working correctly. Although he does say that SOME things are, not all is working.

My efforts were to provide an easy solution that worked for me, and make my solution available until I felt that those people that were having issues, didn’t need a work-around for themselves.

As to your requests… The auto updates ARE already turned off, and the other things, I will take care of, recreate the image and repost.


#6

Thanks for updating the image.


#7

Ok Houston (Flightaware) you have a problem. I put a standard Raspian image on my Raspberry Pi Model B+ V1.2 with CanaKit Wifi USB dongle. Configured it to work with my wifi and it is just FINE. Thanks to your advice, I ordered a 2nd Wifi dongle and it works fine. Thanks for having me waste $10.

You folks did something with 3.0+ builds to break the Raspberry Pi Model B systems. Lets remember that was your original hardware that many of us bought when this first started. To say you don’t have that hardware to test with is BS.

I wish I could have put the image in this thread on my SD card, but it says it is larger than my 8GB SD card.

So Flightaware, fix your image please and quit saying that it is fine and it is US.


#8

Ok, sent email to the address in this thread. Your stuff is BROKE. FIX IT and next time READ OUR MESSAGES and don’t ASSUME.


#9

I have sent you both PMs. I hope to hear back soon with information that will let me fix whatever the problems you are encountering are. Right now, I do not have the information to do that.


#10

It recently came to my attention that my original image that I made available, which was an 8GB download didn’t always fit on an 8GB card, probably due to some bad spots on the card they tried to copy it to.

As a result, I decided to make it available in a 4GB image, for those of you that wish to use my image.

As before, all you need to do is to download the image by clicking on the link below, burning it to an SD card, and then running the command:
wpa_passphrase (your ssid) >> wpa_supplicant.conf [Enter] and then (your ssid password) [Enter]

After this, run ifup wlan0 [Enter] and you should be good to go.

The image has already undergone apt-get update and apt-get upgrade as of 10/20/16, so the image already has the O/S upgrades as of this date.

I make the image available for anyone that wants to use it.


#11

Still waiting to hear a description of the problems you are having with the official image, David. I can’t fix problems if I don’t know what they are.

FWIW your 3.1.0 image is going to be obsoleted by 3.2.0 pretty soon; if anything needs to change in 3.2.0 to support your setup, you need to let me know now or it will miss 3.2.0


#12

Your image contains a FIXED ADDRESS for both the wired and wireless addresses of 192.168.1.10, and even though I set my image with the correct information to reflect dhcp, the CORRECT ssid, and matching password, the default IP Address is not changed, even though it is OUTSIDE of my dhcp address range.

I gave you this information previously, but you ignored it, I guess.


#13

I can’t reproduce the problem. I will copy the PM I sent you a few weeks ago below. I need the information I’m asking for below to make any progress. Can you send me that information or post it here?


Well, I still don’t have information that helps me diagnose the problem. Since you’re a computer tech I’m sure you understand that it’s hard to diagnose a problem with incomplete or imprecise information. Can you help me get the information I need?

Where did 192.168.1.10 come from? Are you looking at wireless-address in piaware-config.txt? That setting is not used at all if wireless-type is dhcp, so I am fairly confused why it would be appearing anywhere in the resulting config. See /usr/lib/piaware-support/generate-network-config

What settings did you change in piaware-config.txt? Can you send me a copy of the config file that doesn’t work?

Can you send me a copy of /var/log/syslog after booting in the not-working state?

If I configure the 3.1.0 image to use wifi + dhcp and boot it here, it works fine with no further intervention and gets an address via DHCP, so I need to work out what you’re doing differently.


#14

The IP Address of 192.168.1.10 comes from piaware-config, it is the DEFAULT value placed there in YOUR IMAGE.

I suggest you speak with the engineers as FA, and see why it is not being replaced with an address within my dhcp address range.

Not only that, if the IP Address of 192.168.1.10 did not come from your image, how can you explain that when I configure dhcp by ANY OTHER MEANS, I get an IP Address of
192.168.1.84?

These addresses are not even close, but should have come up at least next to one another, if configured in the same manner (dhcp), since dhcp addresses are not assigned BACKWARDS, but FORWARDS in order. If I was issued 192.168.1.84 my way, and then turn on piaware-config options for dhcp, I should have gotten an address in the 4th octet of something HIGHER than 84, not lower.


#15

I wrote and maintain the piaware image; you’re already talking to the engineer.

As I wrote above, the wireless-address value in piaware-config.txt is not used (or should not be used - maybe there’s a bug!) when wireless-type is set to dhcp. It is there solely as a placeholder/example value in the default config file.

You need to send me the files I asked for above, syslog and your piaware-config.txt in particular, or I cannot help you. If I can look at those I can work out if wireless-address is being used where it shouldn’t be, and if so then I have an example config file to reproduce the problem with. I’ve asked for these files three times now with no success, I am not going to spend more time chasing you for them.


#16

What replacement are you expecting? That file is not updated with the actual values obtained from DHCP.