FlightAware Discussions

I absolutely Cannot get FlightAware to connect to WIFI

I am trying to run flightaware over wifi which is the only option for me and piaware sd images will not connect on a rasberry pi 3b+ I have 2.4 and 5ghz wifi so not problem there. My piaware config file is
it connects just fine with default rasbian installed but I am trying to run both 978 and 1090 because I am in the us so I have to use the piaware sd image

This file configures the Piaware sdcard image

configuration. Whenever the system boots, this

file is read and its contents are used to

configure the system.

Lines beginning with a ‘#’ are comment lines

and are ignored. Blank lines are also ignored.

All other lines specify configuration settings.

For simplicity, this file only shows the most common options.

For a complete list of options, see

PiAware - Advanced Configuration Settings - FlightAware

NETWORK CONFIGURATION

By default, PiAware will use DHCP when connecting to your network.

For other configurations, see the Advanced Configuration page

linked at the top of this file.

Should piaware use the wired ethernet port

for network access?

wired-network no

Should piaware use a wifi adaptor for network access?

If you are using a Pi 3, this will use the built-in wifi.

Otherwise, you will need to attach a supported USB wifi adaptor.

wireless-network yes

Wifi SSID and password.

This should be changed to match your wireless

network SSID and, for networks that require

a passphrase, the passphrase.

If your SSID or password contains characters other than

numbers and letters, such as the # character or whitespace,

you should enclose the value in quotation marks. For example,

“pass word” or “pass#word”.

To include quotation marks (") in a quoted value, use "

To include a backslash () in a quoted value, use \

wireless-ssid “Stewart Family Wi-fi”
wireless-password redacted but is only numbers and letters

1090MHZ RECEIVER CONFIGURATION

For a complete list of receiver types and their associated settings,

see the Advanced Configuration page linked at the top of this file.

For a receiver type of ‘rtlsdr’, this setting controls the dongle gain.

Use “max” for maximum gain. Other values are interpreted as a gain in dB.

rtlsdr-gain max

OTHER CONFIGURATION

Should automatic system updates (initiated by FlightAware) be allowed?

allow-auto-updates yes

Should manual system updates (initiated by you from the website control

panel) be allowed?

allow-manual-updates yes

Should PiAware enable multilateration where possible?

You may need to disable this if multilateration overloads your receiver.

allow-mlat yes

Should PiAware enable reception of Mode A/C messages when requested?

You may need to disable this if processing Mode A/C overloads your receiver.

allow-modeac yes

Additional settings can be added below.

uat-receiver-type sdr
rtlsdr-device-index 00001090
uat-sdr-device driver=rtlsdr,serial=00000978

For absolutely no reason a full reinstall with the same settings fixed it I have no idea why I tried reinstalling multiple times the 5th or 6th time is the charm I guess

If you prefer, you can install dump978-fa / dump1090-fa from packages on a regular Raspbian image to run a dual-band receiver, you don’t have to use the piaware sdcard image.

 

Here is the how-to (OPTION-2)