Raspberry Pi 3 not connecting to wifi


#1

I’m having a problem with a Raspberry Pi 3 using the latest PiAware image and connecting to wifi. I have no problem connecting to either my 2G or 5G network when I use an SD card with the NOOBS software, but when I insert the SC card containing PiAware, it fails to connect to wifi. It should be noted that when inserting the same SD card containing PiAware into an older Raspberry Pi 2, it connects to wifi no problem.

I’m stumped…any ideas???


#2

I had a similar problem recently.
these 2 changes helped. gateway 192.168.1.254 or .0.254 does not work.

solved by altering the lines in /boot/piaware-config.txt as follows

 wireless-gateway 192.168.1.1
 wireless-nameservers 192.168.1.1 8.8.8.8 8.8.4.4

HTH
evangel

ED I use static IP and also changed the country code, as per next post.


#3

I had some problems with the country not being set and the pi3 refusing to connect.

It’s some new feature specific to the pi3 and stretch i believe. You might have to remove the piaware wireless options and use the guide here: https://www.raspberrypi.org/forums/viewtopic.php?t=191252
Be sure to set the correct code for your country. If the country is not set the pi3 will not work.
Probably flightaware people need to introduce a country setting that sets the country.

Regarding the other answer: gateway and nameservers should be configured by DNS, not sure why that would help without a static ip.


#4

I ended up flashing a clean download of piaware to the micro SD and now it connects to the wireless network correctly…


#5

There is a wireless-country piaware-config option that you can use to set the country code (it’s not properly documented yet)