FlightAware Discussions

Pi3 & 4 wifi Trouble

Hi all
i have looked through a few posts for a while with no success
ok a little info
huawei mobile mifi
ssid and password work fine to my mobile and laptop
its not seeing / connecting
ssid on pi3b 32bit
ssid on pi4 32bit
ssid on pi4 64bit
checked wpa all correct in all 3 pi’s
/// 0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no ///
set UK as country in piaware conf
tried fresh installs sdcards
on going testing as i speak

Assuming you are using the PiAware Image did you configure WiFi after writing the image as instructed on this page?

Or are you using the Piaware Script on top of Raspberry OS?
Then WiFi is disabled by default. You have to enable it also before putting the SDCard into the Raspberry

I have enabled via ssh with sdcard in
also wpa added in piaware-config after update/upgrade
on 32bit and 64
ok i will redo pi3 sdcard and add wifi and ssh before updating / upgrade on pi
see how i get on
thankyou

Ok fresh build of 32bit piaware 3.8.1
added ssh file & edited piaware-config.txt with correct details
still saying down in screen display with etho disconnected

 

(1) Raspbian Image - Howto Enable & Configure WiFi Before First Boot

 

(2) For Beginners - How-to SSH to RPi - Setup Putty in Windows

 

Using piaware only
1 thing i did forget to do was update … upgrade

have now fully updated / upgraded still not connecting
Hmm not sure what to try now
still “down” stated on pi screen
? would i need to install rasbian first as this is not the case on piaware?

Installed raspian first and all worked fine
SORTED

2 Likes

With some basic Linux skills i would always prefer using Raspberry OS with Piaware Script addon instead of the Piaware image.

Yer i know
but i lost all connections after a reboot early hours of this morning so back to sqr 1
its a spare pi to play with lol i got all day