help with wireless


#1

Hi Everyone,

Brand spanking new to ADS-B flight tracking in the Metro Boston area. I am trying to get my unit to talk with my iphone hotspot with no luck. So here is what my config file looks like. I have crossed out my iphone password. Does anyone see anything I have done wrong. For that matter I can’t get it to connect with the house wireless when I put that setup in as well. Setup works great when plugged into router directly and I switch wired-network to yes. Do I need to change anything to static vs whatever

Thanks in advance with any help for this computer illiterate newbie.

Cheers

Ross

This file configures the Piaware sdcard image

configuration. Whenever the system boots, this

file is read and its contents are used to

configure the system.

Lines beginning with a ‘#’ are comment lines

and are ignored. Blank lines are also ignored.

All other lines specify configuration settings.

For simplicity, this file only shows the most common options.

For a complete list of options, see

flightaware.com/adsb/piaware/ad … figuration

NETWORK CONFIGURATION

By default, PiAware will use DHCP when connecting to your network.

For other configurations, see the Advanced Configuration page

linked at the top of this file.

Should piaware use the wired ethernet port

for network access?

wired-network no

Should piaware use a wifi adaptor for network access?

If you are using a Pi 3, this will use the built-in wifi.

Otherwise, you will need to attach a supported USB wifi adaptor.

wireless-network yes

Wifi SSID and password.

This should be changed to match your wireless

network SSID and, for networks that require

a passphrase, the passphrase.

If your SSID or password contains characters other than

numbers and letters, such as the # character or whitespace,

you should enclose the value in quotation marks. For example,

“pass word” or “pass#word”.

To include quotation marks (") in a quoted value, use "

To include a backslash () in a quoted value, use \

wireless-ssid "Ross’s iPhone"
wireless-password xxxxxxxxxxxxxxx

RECEIVER CONFIGURATION

For a complete list of receiver types and their associated settings,

see the Advanced Configuration page linked at the top of this file.

For a receiver type of ‘rtlsdr’, this setting controls the dongle gain.

-10 means AGC / maximum gain; other values mean a gain value in dB.

rtlsdr-gain -10

OTHER CONFIGURATION

Should automatic system updates (initiated by FlightAware) be allowed?

allow-auto-updates yes

Should manual system updates (initiated by you from the website control

panel) be allowed?

allow-manual-updates yes


#2

Try adding a back-slash before apostrophe : “Ross’s iPhone”.

If above method does not work, try again wireless ssid and password without quotes, i.e. instead of “Ross’s iPhone”, use Ross’s iPhone.
In some cases removing quotes has worked.


#3

Rename your phone’s ssid and get rid of the quote mark. You are going to continually have problems. This is just the first of them! :slight_smile:


#4

Yes, it is apostrophe in ssid=“Ross’s iPhone” which necessitated use of quotes and back-slash.

Best is to change ssid & password so that these contain ALPHABETS and NUMBERS ONLY. Then it will be trouble free. No quotes, no back-slashes, and no hassle.


#5

Thank you both for the help. It worked for the Iphone. Still have to figure out how to change the name of the cable box