Updating piaware 3.1 to 3.5


#1

As of last Sunday I got my complete flightaware ADS-B receiver from Amazon including filter, cable, good size antenna, etc.

First thing i noticed however is the piaware software is 3.1 rather than the 3.5 current. Every page i go to talks about a single click to update the software but i can’t find which homepage that is.

Any ideas?


#2

You can send an upgrade command to PiAware from your stats page: flightaware.com/adsb/stats/user/sanchezpaulk


#3

On that page right now, where is the “send an upgrade command” area?


#4

STEP-1

STEP-2

STEP-3
After selecting command “Upgrade and Restart Piaware”, click the button “Send Command”


#5

On my homepage, nothing listed below “outage e-mails” and “Log”. Me thinks I’m not accessing the correct home page of the piaware. It is hooked to the router via Ethernet.


#6

Maybe the sdcard you got has remote updates disabled. (I don’t know where you sourced it from)
edit: or you’re being bitten by a bug in 3.1.0 that breaks remote upgrades, I forgot about that one…

You probably want to start over with a fresh 3.5.0 sdcard image since it’s a new site, 3.1.0 is pretty old now.


#7

Interesting, the complete flightaware kit was delivered from amazon.com on sunday. I would have thought that it would come with 3.5.

Can i order a new micro SD card with 3.5 software on it?

Or if I ordered the USB ProStick Plus with SD card would that solve the problem?


#8

You can reimage your existing sdcard by following the instructions on step 2 of flightaware.com/adsb/piaware/build

FlightAware itself doesn’t supply complete kits, but there are some 3rd party vendors that put them together. I guess the sdcard they shipped to amazon has been sitting in a warehouse for a while.


#9

On the same topic (apologies to OP), I tried the auto update function and was rewarded with this:


[2017-04-25 17:08 MDT] run-apt-get(21780): E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
[2017-04-25 17:08 MDT] child process 21780 exited with status EXIT 100

I’ve tried updating just the Debian packages, then going back for other bits, 1 by 1… but same issue occurred.

Thoughts?


#10

so you ran

sudo apt-get update

then

sudo apt-get upgrade

yes?


#11

I used the auto update feature that was mentioned above via the FA Statistics page.

I did NOT ssh into the pi.

If that’s the equivalent, then… yes, I suppose I did.


#12

Took me SSH’ing into the pi with some intervention on the command line to eventually run the scripts mentioned.

Main issues I encountered included responses required about the new config file from 3.5 vs. the 3.1 I’ve been running.

Thanks for the help. Hope this’ll help someone else out there who may be having similar issues.


#13

You need to run the command it says to run. It means power was lost or some other interruption happened while a previous package operation (not that particular upgrade - the interruption happened at some point in the past) was in progress.


#14

Yes. Thanks, obj.

As mentioned above, all is well.

Would be nice if the automated version would “take care of that” for me… just sayin’.


#15

Newer piawares do in fact run that automatically.

edit: checking the history, though, that was in fact in place right back in 3.0, so I’m not sure what went wrong with your setup; I’d need to see more context from the logs surrounding the error.
edit^2: I pulled the logs from the FA side and it looks like the failure is actually happening during the package list update step, which doesn’t run dpkg --config -a first. I can add it there too I guess.
edit^3: github.com/flightaware/piaware/ … 1f5482136b


#16

Thank you Oliver.


#17

I’m having upgrading problems too. I took down my receiver (not a trivial task) and re-imaged the card and then found that SSH was disabled by default. And SSH is the only way I can talk to this Pi. And without SSH I can’t install the SSH enable file. And I fear that using the manual remote update, I would lose SSH access. And…well, fail.

Any suggestions?


#18

See step 3 of raspberrypi.org/documentati … ccess/ssh/ (the piaware images use the same mechanism and defaults)

It is also mentioned in step 1 of flightaware.com/adsb/piaware/build/optional

You can create the file on /boot from your PC before installing the sdcard in the Pi.

Remote update doesn’t touch your ssh settings.


#19

See step 3 of raspberrypi.org/documentati … ccess/ssh/ (the piaware images use the same mechanism and defaults)

It is also mentioned in step 1 of flightaware.com/adsb/piaware/build/optional

You can create the file on /boot from your PC before installing the sdcard in the Pi.

Thanks for the reply. The crux of the issue is that I can’t see the /boot directory on the SD card on a Windows machine. What can I use to read the FAT SD partition short of setting up a virtual machine?


#20

You can see the boot partition on Windows. In fact /boot is the only partition you can see on Windows.

Go to Step (5) of OPTION-1 or OPTION-2, of this thread:

Bake a Pi

In very unlikely case that using the above method you are still unable to see boot partition, go to windows search, type cmd.exe, and press Enter button. This will open windows command prompt console. In this console type following, and it will create a file ssh in /boot partition of microSD card:

C:\Windows\System32> echo > E:\ssh
Hit ENTER key
(Replace letter E by drive letter of your microSD card)

This will create a file named ssh in microSD card’s /boot partition.