FlightAware Discussions

Underlying software

Q. I have the Welcome screen to PiAware 3.8.1 containing a few lines of text, running on my RPi4. I was hoping to see some sort of Raspberry Pi desktop underneath, but my knowledge with Linux is less than basic.

So, I bought another 32mb sd card and installed the Raspberry OS using NOOBS and now I have the desktop I require, but don’t have PiAware running, and also, by using the first option, I can only view my stats or maps from another PC on the same network.

Is there an ideal and simple solution whereby I can boot my RPi4 like an ordinary computer, then run PiAware just like any app when needed.

Start from your full Raspbian desktop install, then follow the steps at https://flightaware.com/adsb/piaware/install

1 Like

Thank you for the direction.
I just swapped out the SD cards and the OS in use is Raspbian GNU/Linux 10 (Buster), so that’s a good start.

I have followed the instructions and it shows a piaware repository in the home folders.
I want to install, I then password and it shows loading cache.
Thereafter I see no app or any run/ start option.
Puzzled and still looking?

There is none.

http://localhost:8080

Try that in a browser on the RPi that’s running piaware / dump1090-fa.

Not what i expected?
I was hoping i could simply start/stop piaware at my discretion.
Originally, Piaware is installed on a 32mb sd card and just works ( not that I know how) but it does, but its such a waste of such a large sd card and not able to do anything else with the pi4 itself. I’d like to use the Pi’s benefits as a desktop, and use Flightaware as required.

Before my present setup, i just used an RTL dongle with RTL1090 and Virtual radar server on an old duplicate PC that was sitting idle, That worked for me. I was hoping to have a similar setup using the much smaller Pi4

Maybe I should stick to Windows and my Mac a bit longer until I know what I’m dealing with ?

You can do those other things on a RPi while running ADS-B applications.
I have RPi 3b that runs desktop, spreadsheet, CUPS (my network printserver), FR24, FA, PF and RadarBox.

You can still do it.

  1. Open the terminal of Pi.
    To open the terminal in Raspberry Pi, click on the 4th icon (image ) to the left on the top bar.

  2. In the terminal type following command and press Enter key:
    sudo systemctl disable piaware

  3. In the terminal type following command and press Enter key:
    sudo systemctl disable dump1090-fa

  4. Reboot RPi
    Now dump1090-fa and piaware did NOT start automatically at reboot.

  5. To start dump1090-fa manually, open terminal, type following command, and press Enter key:
    sudo systemctl start dump1090-fa

    Now check map in RPi’s browser at following address:
    localhost/dump1090-fa/

  6. To stop dump1090-fa any time, open terminal, type following command, and press Enter key:
    sudo systemctl stop dump1090-fa

  7. To start piaware (data feeder) manually, open terminal, type following command, and press Enter key:
    sudo systemctl start piaware

  8. To stop piaware (data feeder), open terminal, type following command, and press Enter key:
    sudo systemctl stop piaware

just going through the process that obj linked me to.
Once I’ve completed that, I’ll try your instructions.
Noticed item 4, tonights install never worked at all?

By default both the dump1090-fa (decoder/map generator) and piaware (data feeder) start automatically at boot/reboot.

If anyone issues disable commands (items 2 & 3 in my last post), then these will never start automatically at boot/reboot. However these can be started/stopped manually by commands given in items 5, 6, 7, and 8.

If later you decide that automatic start of piaware & dump1090-fa should be allowed, then enable these again by following commands:

sudo systemctl enable dump1090-fa
sudo systemctl enable piaware
sudo reboot

So I have completed this task, though I did not include the dump978 nor the option to update.
Still nothing happening, and nothing from the macbook.
I noted the ip address has changed but still nothing when viewed from macbook, but then had a thought, did the above installation actually install or just downloaded?
I went to HomeFolders and right clicked piaware repository, selected package install.
Now when I open the web browser on pi, i see an icon, which when selected takes me to local host 8080, showing the piAware Skyaware map, but no data , no aircraft.

Ok…looked back at Pi monitor and now one aircraft is visible, so something is right :wink:
just gotta link other devices for when I’m away from the Pi setup and all should be ok?

Than you all so far for your involvement on this occasion, much appreciated

978MHz is only used in the US - no use to you at all.

What are you doing for an antenna?

Given your location, the reason you are not seeing many aircraft is that there are none to see!

Try this quick link to get an idea of what you should be able to see

Default FA Antenna. Could see AIC188 a few moments ago, but screening has caused the flight to disappear for now.
This shows my normal coverage…

Good choice!
I was worried you were using a PoS antenna supplied (with generic dongles) for local TV stations - they work, but not well.

You know you’ve chosen the worst time in history to sniff for air traffic? On the plus side, it’ll get a lot busier as restrictions ease.

geckoVN…I toyed with various diy antennas on this FlightAware Prostick Plus, but it was’nt until the full sized FA antenna arrived did I start to see any results.
There’s still areas I just cant see, due to screening in some form or another, and for now its the best I’ll achieve, unless I go much higher, but the hill to my South will still be higher.

If you followed the instructions and there were no errors then it is installed; the dpkg and apt-get install commands install software.

obj, I’ve learnt that now, and my system appears to be up and running.

Wow!, look how time just flies, i’ve just lost 5 hours of sleep!

Glad to know your system is up and running and now you understand it better than when you started.

I hope now you dont want to start & stop the piaware (data feeder) and dump1090-fa (decoder & map generator) manually at your discretion. Almost none of us do it.

The dump1090-fa & piaware are started at boot automatically, and keep running in the background. You can run any other software also on your RPi without any problem due to these two software running in the background.

1 Like

abcd567…I hear where your coming from!

When I investigated SBS-1 years ago and similar stuff since, I had envisaged having my own setup using ‘supplied’ equipment to track aircraft, however, my site is not perfect, so the hope of receiving any equipment for ‘free’ became just a thought.

Placed between two Mil and two Civ airports, makes no difference if I cant see all 360° of my horizon, so I gave up ?

Although there are several very good Apps available to plot and track aircraft, some just cant see the low level stuff around my two Mil airports, so I thought I’d have a go this year to see if me alone could track low level and circuits, but to no avail, hill screening knocks that on the head, even got to the stage whereby I though the Mil stuff were not using any ADSB, such was the lack of signals / data.

However I started to re-kindle the idea that I should get something?

Now, a black welcome screen, a 32mb micro sd and my Pi4 now seemed excessive if I cant use the Pi4 for anything else, or pick up the local stuff, so back to Planefinder/ADSexchange and the like seemed like the way to go, just using the Pi4 & PiAware - FlightAware on a needs basis.

But now I have the Pi4 working as expected, as a desktop, with the PiAware running in the background, it seems that i do have the setup I had intended from the start,.

However, still not sure I want to run the Pi4 or any other system 24/7/365, but hey, I run a fridge-freezer?
I know if the equipment was on loan, it would be expected.
I’m not sure my limited data would be truly missed if/when the Pi had some downtime.

Thanks again.