Unable to reclaim/reactivate old piaware


#1

Chasing some help/advise.

I had an active Piaware setup and working fine and in the process of moving the site was down for a few months.

I have just re-setup the site and cannot see the data being fed into my account, nor an option to disassociate it, so I can re add it.

Everything was (today) updated and still no data. I can local to dump1080 GUI and see active flights.

Any help is appreciated - affected piaware MAC below…

MAC Id b8:27:eb:0c:e7:86


#2

You have configured a username+password (not recommended) and the password is wrong.


#3

After unable auto claim your device, I have completed the manual claim process (flightaware.com/adsb/piaware/claim/manual) including updating with my FA account and password, which I’m 99.999% confident the right password is entered, as on entering the password a second time, the terminal is returning “no changes were made to password” (or words to that effect) - Either I’ve entered it wrong twice or or it is correct.


#4

check the logs afterwards
cat /tmp/piaware.out (Older versions)
cat /var/log/piaware.log (version 3 or above)

You should see an error message if the password is still incorrect.


#5

If you have manually claimed the device I suggest you just clear out the username+password:



$ piaware-config flightaware-user ""
$ piaware-config flightaware-password ""
$ sudo systemctl restart piaware 



#6

User/Pwd cleared using those commands
Cleared setting for flightaware-user in /boot/piaware-config.txt:7
Cleared setting for flightaware-password in /boot/piaware-config.txt:8

Linked PiAware Receivers (craigramsay84)

Great news! Your account is associated with the following PiAware receivers and you can view your statistics here:

b8:27:eb:f4:be:50: PiAware 3.1 added Tuesday, August 2, 2016 (XXXXXXX / 192.168.0.17)
e8:50:8b:3e:c8:47: PiAware 1.0.28 added Saturday, June 11, 2016 (XXXXXX / 192.168.0.12)
b8:27:eb:0c:e7:86: PiAware (SD Card) 3.1 added Tuesday, May 24, 2016 (XXXXXXXX / 192.168.0.16)

Still no data coming from bolded device nor can I see it on my-adsb page


#7

Looks like you have changed your username recently and piaware was still connected using the old username.
I killed off the old connection to force it to reconnect as the changed username which appears to have worked correctly.

However: the log messages that piaware is forwarding indicate that there is no dump1090 running (and attempts to restart it don’t fix that), which is why no data is being fed. (See /var/log/piaware.log)

Check “sudo journalctl -u dump1090-fa” which should tell you why dump1090 is failing to start.