Unable to access Web interface


#1

My statistics page shows “Data Feed: Live” but when I click on the “Web interface: view live data” I get the error

Unable to connect

Firefox can’t establish a connection to the server at 192.168.0.12:8080.

This is the correct IP address for my raspberry pi.

Ant ideas what I am doing wrong


#2

Is your firefox machine on the same intranet as the pi (192.168.0.xxx)?


#3

Yes my PC has a local IP of 192.168.0.2


#4

maybe clear your cache?


#5

Already tried that. I can access my local data on a map if I use

192.168.0.12/dump1090


#6

What software are you using? (Not dump1090-fa, given that URL)


#7

Hello,

I have the same problem, after every 2 or 3 days my Piaware gets “frozen” and I had to reboot. FIrst, the web interface stops responding and when I do not restart, after some more hours also the feeding function stops and I get an e-mail from Flightaware, that my feeder stopped working and I should check my network. But my network is absolutely OK. Also I am able to see the log on my personal page at Flightaware under the link “My ADS-B”. And also I can restart the Pi from there! After restarting it works again well but this situation repeats every 2 - 3 days.

Before that, when I installed the Pi about in the begeiining of this year, it perfectly worked and has no problem running more than a month without a touch. Then I had to do some reconstructions at home and I was not using it. Last week I reconnected it and made some update (hope that I get maybe some new functions…) and after this full update (Update everything command in the Flightaware personal page) it started to freeze… I hate updates… Now I am unhappy and don’t know what to do (maybe wait for the next update), because I have no Linux knowledge so I am not able to investigate the system and check what is wrong. Then you are welcome anybody who can help.
Thank you!


#8

If your Pi is freezing or the dongle stops working it is probably a hardware problem. The most common hardware problem is bad power. As a simple check (assuming you have a B+ or later) ensure that the red LED is solidly on and does not flicker or turn off.


#9

Thank you for your comment. i am sure, this is not hardware problem, because it started after upgrading the software to the newest version (without changing any hardware configuration). the power LED stays red and is not flashing and I use the 2Amps power supply - original one from the Pi manufacturer.
Also the Pi is not frozen completely because reacts for the reboot command. Only some processes in the software are stopping.
Today it was frozen again (it was not running even more than 24 hours) so I started again the “update everything” function and just now rebooted. I will see what comes next, I will watch it. Thank you!


#10

Ok, if it happens again please describe the exact behaviour - I need to know more than “it freezes”.


#11

@nonstopradio
Yesterday after upgrading, I faced some severe trouble, and I was sure that my hardware is OK. I did not bother to debug. Instead I slide out the microSD card from Pi, formatted it, and made a fresh install. Now I have OS & all other software latest version, working great. This method is headache-free, though it takes longer time than upgrading.

It is easy for me to go for a fresh install because:
(1) My Pi is located inside my apartment and at arms reach. In case of remotely located Pi, or Pi at a difficult to reach location, upgrade and debugging is the practical option.
(2) I never bother to save my data before formatting microSD card, as I have no use for it.


#12

Possible cause, see post by obj

ads-b-flight-tracking-f21/dump1090-mutability-not-showing-map-t38041.html


#13

@Haggis: I asked almost the identical question a month or so ago. I have a terrible memory, but I am pretty sure the answer was the link to live data on the stats page is no longer good, something about the move from 8080 and that the link would be removed in the near future. Not to put words in someone’s mouth (hand) but that is what I recall processing from the response.


#14

@jcinnb, yes, that’s it. I don’t normally use the link on the stats page, but I just tried it, and it fails because it is trying port 8080, and the web server is listening on port 80, when you get to PiAware V 3.1.

Port 80 is th default so just erase the :8080 bit from the end of the URL and you should connect ok, as long as you are in your home. (I.e. On the same LAN as the Pi)


#15

PiAware 3.1 listens on both 80 and 8080.


#16

I am fine on my network, but I just could not get the link on Stats to ever work. Regardless, thank you.


#17

Hello,

regarding my problem with “freezing” - I solved it by starting the “Update all” just once again. Now I have newer interface with nice colorful airplanes and I like it :slight_smile: It is still running on port 8080 (not on 80) as some of you mentioned here.

now I have another “problem” - today I get an e-mail from Flightaware support, that my account was downgraded and I am not feeding data for more than 15 days :slight_smile: But I am feeding and i checked the website of my stats
flightaware.com/adsb/stats/user/nonstopradio
There is everything OK. So I wrote that to Support e-mail, because i believe that is only a mistake.

Thank you all and have a nice time!


#18

All of my 3 Pis have dump1090-mutability + Piaware 3.1 (add-on) + Web Portal. On all the 3:
(1) :8080/ takes to “Unable to connect”
(2) :80/ takes to Web Portal’s default page
(3) / takes to Web Portal’s default page

In order to check how Piaware 3.1 image behaves, I just now wrote “piaware-sd-card-3.1.0.img” to a spare miroSD card and inserted in one of my Pi and booted. Following are the results:
(1) :8080/ takes to Map
(2) :80/ takes to Piaware status page
(3) / takes to Piaware status page

Now I will go ahead and install Web Portal and report in a short while how it modifies above links’ behavior.


#19

Update: Installed Web Portal over “piaware-sd-card-3.1.0.img”

(1) :80/ takes to Piaware status page

(2) / takes to Piaware status page

(3) :8080/ takes to a dead Map (no planes). The map has a yellow box which says “Problem fetching data from dump1090. AJAX call failed (error: Forbidden). Maybe dump1090 is no longer running? The displayed map data will be out of date”.

(4) /dump1090-fa/ takes to a live Map with planes.


#20

I’m having the same problem of

This site can’t be reached
192.168.1.242 refused to connect.
ERR_CONNECTION_REFUSED

IP is good. I can access the Raspberry Pi via SSH.

Flightaware’s website is showing that my feeder is active and sending info.
I used to be able to access the web interface.

Tried:
sudo piaware-status
PiAware master process (piaware) is running with pid 3828.
PiAware ADS-B client (faup1090) is running with pid 4144.
PiAware mlat client (fa-mlat-client) is running with pid 3867.
Local ADS-B receiver (dump1090-fa) is running with pid 4129.

dump1090-fa (pid 4129) is listening for connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.

dump1090 is producing data on localhost:30005.

Your feeder ID is (my feeder id)___ (from /var/cache/piaware/feeder_id)

Tried
:8080/
:80/
/
/dump1090-fa/

All of these gave the same error that it can’t be reached.

I’ve tried restarted PiAware and the Raspberry Pi. Tried upgrading PiAware and dump as well. Still getting the error.

(I have FlightRadar24 too, and it’s working fine on the same Pi. Both software have worked together on the same Pi with no issue. I can access the web interface of the FlightRadar.)