PiAware: Fine for 4+ yrs and now it's not


#1

Last night around midnight my RasPI stopped sending to FlightAware.
I can access the “radar” plot screen from my local network. Planes show up and I can track them so I know the SDR and other parts are working.

Things I have done:

I tried to run dump1090 from the command line and get the output below. See screen shot link.

dump1090

Thanks. I hope to get this fix in time to preserve my streak!

ironjungle


#2

What do the log files say?
They are in /var/log


#3

Post last few lines of output of following command:

sudo systemctl status piaware -l


#4

I don’t seem to have a /var/log. See image link:
slashvarslashlog


#5

abcd567: The command did not execute. I ran the command “piware” and got the results in the image link below. For what is it worth; the PI can ping the piaware/flightaware address on the screenshot.

piware output


#6

OK. Another screenshot. Note the error that /var/log can’t be opened. That’s seem odd for something like that to happen suddenly without anyone fiddling with the PI… Also note the last command error while trying to run “sudo systemctl status piaware -l” Also note the good pings.

Here is the image link:
no-var-log-no-systemctl


#7

Your device cannot connect to
Piaware.flightaware.com on TCP 1200.
There could be a problem with one of the FA servers.


#8

Very strange that systemctl won’t work.

When you ran the command “PiAware” you just started anothe copy. That explains the error opening PiAware.log (only root can write to this. You were running as user Pi)

Try “tail /var/log/piaware.log” and see what’s there.


#9

Are you running Wheezy or Jessie? Try “cat /etc/os-release”. If wheezy that explains why systemctl is not found.


#10

First off… THX to Everyone jumping in to help.

Below is the screen shot output of that “tail” command. Basically, a timeout. As I said earlier I can ping the IP, but of course; pinging a PORT is not allowed. See image at:
results_of_tail_command


#11

And… running Wheezy. (BTW, thx, I was not aware of that command! Very useful)


#12

Telnet to a port to test if a TCP port is open.


#13

Upgrading from Wheezy to Jessie (or Stretch), and Piaware from whatever to ver 3.5.3 most likely will solve this problem.

One way to do this is a fresh install: Format mocroSD card, download and write latest Raspbian Stretch image, then install Piaware 3.5.5 and dump1090-fa add-on package.

Alternatively, try to upgrade existing software from Wheezy to Jessie, and Piaware from whatever version to 3.5.3. Following post tells how to do above upgrade.

I recommend reading the whole thread before attemting upgrade from wheezy to jessie, and to piaware 3.5.3.


#14

I understand the suggestion, but something changed at midnight last night and I doesn’t seem like a Jessie upgrade solves that. Do you disagree?

Regarding the TELNET ping… How is that command executed?


#15

telnet ip/hostname portnumber


#16

telnet

“Command not found” on the RasPI or on my Windows 10 machine.


#17

.
By default, Telnet is disabled in Windows.
Please see following post which shows the method to enable telnet in Windows.

.


#18

I am away from home and cannot test if telnet is available in Pi/Raspbian.

However since I have terminal software “Termux” already istalled on my Android Phone from Google Play, and I just now tested, and it has telnet capability.

As Android is also Linux, hopefully Raspbian will also have Telnet capability.

Cilck on screenshot below to see larger size image


#19

THX. See image file link. I am passing the ping and failing the TELNET Port 1200.

Is it possible (as suggested) that this is on the FlightAware side? Others in my area are logging without issue. Is there a way to force a PORT other that 1200 to test the theory?

Ping-pass-Telnet-fail_screenshot


#20

STEP-1: Checked telnet installed or not. Not installed

pi@raspberrypi:~ $ apt-cache policy telnet
telnet:
  Installed: (none)
  Candidate: 0.17-41
  Version table:
     0.17-41 500
        500 http://mirrordirector.raspbian.org/raspbian stretch/main armhf Packages

STEP-2: Installed telnet.

pi@raspberrypi:~ $ sudo apt-get install telnet
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  telnet
0 upgraded, 1 newly installed, 0 to remove and 93 not upgraded.
Need to get 68.4 kB of archives.
After this operation, 145 kB of additional disk space will be used.
Get:1 http://muug.ca/mirror/raspbian/raspbian stretch/main armhf telnet armhf 0.17-41 [68.4 kB]
Fetched 68.4 kB in 0s (83.0 kB/s)
Selecting previously unselected package telnet.
(Reading database ... 41012 files and directories currently installed.)
Preparing to unpack .../telnet_0.17-41_armhf.deb ...
Unpacking telnet (0.17-41) ...
Setting up telnet (0.17-41) ...
update-alternatives: using /usr/bin/telnet.netkit to provide /usr/bin/telnet (telnet) in auto mode
Processing triggers for man-db (2.7.6.1-2) ...

STEP-3: Used telnet.

ON LOCAL HOST

pi@raspberrypi:~ $ telnet localhost 80  
Trying ::1...  
Connected to localhost.  
Escape character is '^]'. 
^] 
telnet> quit
Connection closed.
pi@raspberrypi:~ $

.
.
WITH FLIGHTAWARE SERVER

pi@raspberrypi:~ $ sudo service piaware status
...............
Using UDP transport to 70.42.6.224 port 8055
.....................
82 msgs recv'd from dump1090-mutabi; 82 msgs sent to FlightAware

.
.

pi@raspberrypi:~ $ telnet 70.42.6.224 8055
Trying 70.42.6.224...
telnet: Unable to connect to remote host: Connection timed out
pi@raspberrypi:~